[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[PATCH v2 22/27] failover: remove failover_find_primary_device() error p
From: |
Juan Quintela |
Subject: |
[PATCH v2 22/27] failover: remove failover_find_primary_device() error parameter |
Date: |
Wed, 18 Nov 2020 09:37:43 +0100 |
It can never give one error.
Signed-off-by: Juan Quintela <quintela@redhat.com>
---
hw/net/virtio-net.c | 9 +++------
1 file changed, 3 insertions(+), 6 deletions(-)
diff --git a/hw/net/virtio-net.c b/hw/net/virtio-net.c
index c708c03cf6..b994796734 100644
--- a/hw/net/virtio-net.c
+++ b/hw/net/virtio-net.c
@@ -832,7 +832,7 @@ static int is_my_primary(void *opaque, QemuOpts *opts,
Error **errp)
* @n: VirtIONet device
* @errp: returns an error if this function fails
*/
-static DeviceState *failover_find_primary_device(VirtIONet *n, Error **errp)
+static DeviceState *failover_find_primary_device(VirtIONet *n)
{
Error *err = NULL;
@@ -897,10 +897,7 @@ static void virtio_net_set_features(VirtIODevice *vdev,
uint64_t features)
qatomic_set(&n->failover_primary_hidden, false);
failover_add_primary(n, &err);
if (err) {
- n->primary_dev = failover_find_primary_device(n, &err);
- if (err) {
- goto out_err;
- }
+ n->primary_dev = failover_find_primary_device(n);
failover_add_primary(n, &err);
if (err) {
goto out_err;
@@ -3121,7 +3118,7 @@ static void virtio_net_handle_migration_primary(VirtIONet
*n,
should_be_hidden = qatomic_read(&n->failover_primary_hidden);
if (!n->primary_dev) {
- n->primary_dev = failover_find_primary_device(n, &err);
+ n->primary_dev = failover_find_primary_device(n);
if (!n->primary_dev) {
return;
}
--
2.26.2
- [PATCH v2 13/27] failover: Remove memory leak, (continued)
- [PATCH v2 13/27] failover: Remove memory leak, Juan Quintela, 2020/11/18
- [PATCH v2 12/27] failover: Remove primary_device_dict, Juan Quintela, 2020/11/18
- [PATCH v2 14/27] failover: simplify virtio_net_find_primary(), Juan Quintela, 2020/11/18
- [PATCH v2 15/27] failover: should_be_hidden() should take a bool, Juan Quintela, 2020/11/18
- [PATCH v2 16/27] failover: Rename function to hide_device(), Juan Quintela, 2020/11/18
- [PATCH v2 17/27] failover: virtio_net_connect_failover_devices() does nothing, Juan Quintela, 2020/11/18
- [PATCH v2 18/27] failover: Rename to failover_find_primary_device(), Juan Quintela, 2020/11/18
- [PATCH v2 19/27] failover: simplify qdev_device_add() failover case, Juan Quintela, 2020/11/18
- [PATCH v2 20/27] failover: simplify qdev_device_add(), Juan Quintela, 2020/11/18
- [PATCH v2 21/27] failover: make sure that id always exist, Juan Quintela, 2020/11/18
- [PATCH v2 22/27] failover: remove failover_find_primary_device() error parameter,
Juan Quintela <=
- [PATCH v2 23/27] failover: split failover_find_primary_device_id(), Juan Quintela, 2020/11/18
- [PATCH v2 24/27] failover: We don't need to cache primary_device_id anymore, Juan Quintela, 2020/11/18
- [PATCH v2 25/27] failover: Caller of this two functions already have primary_dev, Juan Quintela, 2020/11/18
- [PATCH v2 27/27] failover: Remove primary_dev member, Juan Quintela, 2020/11/18
- [PATCH v2 26/27] failover: simplify failover_unplug_primary, Juan Quintela, 2020/11/18
- Re: [PATCH v2 00/27] Virtio net failover fixes, Michael S. Tsirkin, 2020/11/18