qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH v2 2/9] configure: cross-compiling without cross_prefix


From: BALATON Zoltan
Subject: Re: [PATCH v2 2/9] configure: cross-compiling without cross_prefix
Date: Mon, 19 Oct 2020 13:24:08 +0200 (CEST)

On Mon, 19 Oct 2020, Thomas Huth wrote:
On 19/10/2020 10.07, Thomas Huth wrote:
On 19/10/2020 03.39, Joelle van Dyne wrote:
From: osy <osy86@users.noreply.github.com>

The iOS toolchain does not use the host prefix naming convention. We add a
new option `--enable-cross-compile` that forces cross-compile even without
a cross_prefix.

Signed-off-by: Joelle van Dyne <j@getutm.app>
---
 configure | 13 ++++++++++++-
 1 file changed, 12 insertions(+), 1 deletion(-)

diff --git a/configure b/configure
index 3c63879750..46d5db63e8 100755
--- a/configure
+++ b/configure
@@ -234,6 +234,7 @@ cpu=""
 iasl="iasl"
 interp_prefix="/usr/gnemul/qemu-%M"
 static="no"
+cross_compile="no"
 cross_prefix=""
 audio_drv_list=""
 block_drv_rw_whitelist=""
@@ -456,6 +457,11 @@ for opt do
   optarg=$(expr "x$opt" : 'x[^=]*=\(.*\)')
   case "$opt" in
   --cross-prefix=*) cross_prefix="$optarg"
+                    cross_compile="yes"
+  ;;
+  --enable-cross-compile) cross_compile="yes"
+  ;;
+  --disable-cross-compile) cross_compile="no"

Can't you simply use --cros-prefix="" instead?

I mean, still introduce the "cross_compile=yes" variable, just omit the new
options.

That seems less intuitive for people trying to find this option. If --help lists --enable-cross-compile I can guess what that means but there's no way I could guess --cros-prefix="" unless I've been told or searched and stumbled upon it. So unless it's a big problem I like the explicit options better. Or is that a convention in other projects to use empty prefix to enable cross compile that I don't know about?

Regards,
BALATON Zoltan



reply via email to

[Prev in Thread] Current Thread [Next in Thread]