qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH v6 01/13] hw/i386: Introduce X86CPUTopoInfo to contain topolo


From: Babu Moger
Subject: Re: [PATCH v6 01/13] hw/i386: Introduce X86CPUTopoInfo to contain topology info
Date: Wed, 11 Mar 2020 09:02:58 -0500
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Thunderbird/68.4.1


On 3/11/20 6:39 AM, Igor Mammedov wrote:
> On Tue, 10 Mar 2020 21:33:25 -0500
> Babu Moger <address@hidden> wrote:
> 
>> This is an effort to re-arrange few data structure for better readability.
>>
>> 1. Add X86CPUTopoInfo which will have all the topology informations
>>    required to build the cpu topology. There is no functional changes.
>>
>> 2. Introduce init_topo_info to initialize X86CPUTopoInfo members from
>>    X86MachineState.
>>
>> 3. Update x86 unit tests for new calling convention with parameter 
>> X86CPUTopoInfo
>>
>> There is no functional changes.
> 
> patch doesn't apply to current master, so I can't really test it

I generated the patches on top of Eduardo's tree.

It should work if you apply after this patch.

https://lore.kernel.org/qemu-devel/address@hidden/

Do you want me to generate on top of master ?

>>
>> Signed-off-by: Babu Moger <address@hidden>
>> ---
>>  hw/i386/pc.c               |   12 ++++++------
>>  hw/i386/x86.c              |   32 ++++++++++++++++++++++++--------
>>  include/hw/i386/topology.h |   38 ++++++++++++++++++++++++--------------
>>  include/hw/i386/x86.h      |    3 +++
>>  tests/test-x86-cpuid.c     |   43 
>> ++++++++++++++++++++++++-------------------
>>  5 files changed, 81 insertions(+), 47 deletions(-)
>>
> [...]
>> diff --git a/hw/i386/x86.c b/hw/i386/x86.c
>> index 322fb6abbc..03b8962c98 100644
>> --- a/hw/i386/x86.c
>> +++ b/hw/i386/x86.c
>> @@ -57,6 +57,16 @@
>>  /* Physical Address of PVH entry point read from kernel ELF NOTE */
>>  static size_t pvh_start_addr;
>>  
>> +inline void init_topo_info(X86CPUTopoInfo *topo_info,
>> +                                  const X86MachineState *x86ms)
> 
> not aligned properly

Will fix it.

> 
> [...]
> 



reply via email to

[Prev in Thread] Current Thread [Next in Thread]