[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [Qemu-devel] [PATCH] qapi: Make visit_next_list()'s comment less con
From: |
Eric Blake |
Subject: |
Re: [Qemu-devel] [PATCH] qapi: Make visit_next_list()'s comment less confusing |
Date: |
Fri, 2 Aug 2019 08:06:39 -0500 |
User-agent: |
Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Thunderbird/60.7.0 |
On 8/2/19 7:23 AM, Markus Armbruster wrote:
> visit_next_list() returns non-null on success, null on failure. The
> comment's phrasing "until NULL return or error occurs" is needlessly
> confusing. Scratch the "or error occurs" part.
>
> Signed-off-by: Markus Armbruster <address@hidden>
> ---
> include/qapi/visitor.h | 8 ++++----
> 1 file changed, 4 insertions(+), 4 deletions(-)
Reviewed-by: Eric Blake <address@hidden>
>
> diff --git a/include/qapi/visitor.h b/include/qapi/visitor.h
> index 5b2ed3f202..c5b23851a1 100644
> --- a/include/qapi/visitor.h
> +++ b/include/qapi/visitor.h
> @@ -364,10 +364,10 @@ void visit_start_list(Visitor *v, const char *name,
> GenericList **list,
> * @tail must not be NULL; on the first call, @tail is the value of
> * *list after visit_start_list(), and on subsequent calls @tail must
> * be the previously returned value. Should be called in a loop until
> - * a NULL return or error occurs; for each non-NULL return, the caller
> - * then calls the appropriate visit_type_*() for the element type of
> - * the list, with that function's name parameter set to NULL and obj
> - * set to the address of @tail->value.
> + * a NULL return; for each non-NULL return, the caller then calls the
> + * appropriate visit_type_*() for the element type of the list, with
> + * that function's name parameter set to NULL and obj set to the
> + * address of @tail->value.
> */
> GenericList *visit_next_list(Visitor *v, GenericList *tail, size_t size);
>
>
--
Eric Blake, Principal Software Engineer
Red Hat, Inc. +1-919-301-3226
Virtualization: qemu.org | libvirt.org
signature.asc
Description: OpenPGP digital signature