[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[Qemu-devel] [PATCH v5 04/23] qcow2: Switch is_zero_sectors() to byte-ba
From: |
Eric Blake |
Subject: |
[Qemu-devel] [PATCH v5 04/23] qcow2: Switch is_zero_sectors() to byte-based |
Date: |
Tue, 3 Oct 2017 21:00:29 -0500 |
We are gradually converting to byte-based interfaces, as they are
easier to reason about than sector-based. Convert another internal
function (no semantic change), and rename it to is_zero() in the
process.
Signed-off-by: Eric Blake <address@hidden>
Reviewed-by: Fam Zheng <address@hidden>
Reviewed-by: John Snow <address@hidden>
---
v3-v5: no change
v2: rename function, rebase to upstream changes
---
block/qcow2.c | 32 ++++++++++++++++++--------------
1 file changed, 18 insertions(+), 14 deletions(-)
diff --git a/block/qcow2.c b/block/qcow2.c
index bcd5c4a34c..e0de46f530 100644
--- a/block/qcow2.c
+++ b/block/qcow2.c
@@ -2972,21 +2972,28 @@ finish:
}
-static bool is_zero_sectors(BlockDriverState *bs, int64_t start,
- uint32_t count)
+static bool is_zero(BlockDriverState *bs, int64_t offset, int64_t bytes)
{
int nr;
int64_t res;
+ int64_t start;
- if (start + count > bs->total_sectors) {
- count = bs->total_sectors - start;
+ /* Widen to sector boundaries, then clamp to image length, before
+ * checking status of underlying sectors */
+ start = QEMU_ALIGN_DOWN(offset, BDRV_SECTOR_SIZE);
+ bytes = QEMU_ALIGN_UP(offset + bytes, BDRV_SECTOR_SIZE) - start;
+
+ if (start + bytes > bs->total_sectors * BDRV_SECTOR_SIZE) {
+ bytes = bs->total_sectors * BDRV_SECTOR_SIZE - start;
}
- if (!count) {
+ if (!bytes) {
return true;
}
- res = bdrv_get_block_status_above(bs, NULL, start, count, &nr, NULL);
- return res >= 0 && (res & BDRV_BLOCK_ZERO) && nr == count;
+ res = bdrv_get_block_status_above(bs, NULL, start >> BDRV_SECTOR_BITS,
+ bytes >> BDRV_SECTOR_BITS, &nr, NULL);
+ return res >= 0 && (res & BDRV_BLOCK_ZERO) &&
+ nr * BDRV_SECTOR_SIZE == bytes;
}
static coroutine_fn int qcow2_co_pwrite_zeroes(BlockDriverState *bs,
@@ -3004,24 +3011,21 @@ static coroutine_fn int
qcow2_co_pwrite_zeroes(BlockDriverState *bs,
}
if (head || tail) {
- int64_t cl_start = (offset - head) >> BDRV_SECTOR_BITS;
uint64_t off;
unsigned int nr;
assert(head + bytes <= s->cluster_size);
/* check whether remainder of cluster already reads as zero */
- if (!(is_zero_sectors(bs, cl_start,
- DIV_ROUND_UP(head, BDRV_SECTOR_SIZE)) &&
- is_zero_sectors(bs, (offset + bytes) >> BDRV_SECTOR_BITS,
- DIV_ROUND_UP(-tail & (s->cluster_size - 1),
- BDRV_SECTOR_SIZE)))) {
+ if (!(is_zero(bs, offset - head, head) &&
+ is_zero(bs, offset + bytes,
+ tail ? s->cluster_size - tail : 0))) {
return -ENOTSUP;
}
qemu_co_mutex_lock(&s->lock);
/* We can have new write after previous check */
- offset = cl_start << BDRV_SECTOR_BITS;
+ offset = QEMU_ALIGN_DOWN(offset, s->cluster_size);
bytes = s->cluster_size;
nr = s->cluster_size;
ret = qcow2_get_cluster_offset(bs, offset, &nr, &off);
--
2.13.6
- [Qemu-devel] [PATCH v5 00/23] make bdrv_get_block_status byte-based, Eric Blake, 2017/10/03
- [Qemu-devel] [PATCH v5 02/23] block: Add flag to avoid wasted work in bdrv_is_allocated(), Eric Blake, 2017/10/03
- [Qemu-devel] [PATCH v5 01/23] block: Allow NULL file for bdrv_get_block_status(), Eric Blake, 2017/10/03
- Re: [Qemu-devel] [PATCH v5 01/23] block: Allow NULL file for bdrv_get_block_status(), Kevin Wolf, 2017/10/10
- Re: [Qemu-devel] [PATCH v5 01/23] block: Allow NULL file for bdrv_get_block_status(), Eric Blake, 2017/10/10
- Re: [Qemu-devel] [PATCH v5 01/23] block: Allow NULL file for bdrv_get_block_status(), Eric Blake, 2017/10/10
- Re: [Qemu-devel] [PATCH v5 01/23] block: Allow NULL file for bdrv_get_block_status(), John Snow, 2017/10/10
- Re: [Qemu-devel] [PATCH v5 01/23] block: Allow NULL file for bdrv_get_block_status(), Kevin Wolf, 2017/10/11
- Re: [Qemu-devel] [PATCH v5 01/23] block: Allow NULL file for bdrv_get_block_status(), John Snow, 2017/10/11
- [Qemu-devel] [PATCH v5 03/23] block: Make bdrv_round_to_clusters() signature more useful, Eric Blake, 2017/10/03
- [Qemu-devel] [PATCH v5 04/23] qcow2: Switch is_zero_sectors() to byte-based,
Eric Blake <=
- [Qemu-devel] [PATCH v5 05/23] block: Switch bdrv_make_zero() to byte-based, Eric Blake, 2017/10/03
- [Qemu-devel] [PATCH v5 06/23] qemu-img: Switch get_block_status() to byte-based, Eric Blake, 2017/10/03
- [Qemu-devel] [PATCH v5 08/23] block: Switch bdrv_co_get_block_status() to byte-based, Eric Blake, 2017/10/03
- [Qemu-devel] [PATCH v5 07/23] block: Convert bdrv_get_block_status() to bytes, Eric Blake, 2017/10/03
- [Qemu-devel] [PATCH v5 10/23] block: Switch bdrv_common_block_status_above() to byte-based, Eric Blake, 2017/10/03
- [Qemu-devel] [PATCH v5 11/23] block: Switch bdrv_co_get_block_status_above() to byte-based, Eric Blake, 2017/10/03