[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [Qemu-devel] [PATCH v6 5/7] hw/core: rebase sysbus_get_fw_dev_path()
From: |
Michael S. Tsirkin |
Subject: |
Re: [Qemu-devel] [PATCH v6 5/7] hw/core: rebase sysbus_get_fw_dev_path() to g_strdup_printf() |
Date: |
Wed, 17 Jun 2015 15:46:24 +0200 |
On Wed, Jun 17, 2015 at 02:45:03PM +0200, Laszlo Ersek wrote:
> This is done mainly for improving readability, and in preparation for the
> next patch, but Markus pointed out another bonus for the string being
> returned:
>
> "No arbitrary length limit. Before the patch, it's 39 characters, and the
> code breaks catastrophically when qdev_fw_name() is longer: the second
> snprintf() is called with its first argument pointing beyond path[], and
> its second argument underflowing to a huge size."
>
> Cc: Markus Armbruster <address@hidden>
> Cc: Marcel Apfelbaum <address@hidden>
> Cc: Michael S. Tsirkin <address@hidden>
> Signed-off-by: Laszlo Ersek <address@hidden>
> Tested-by: Marcel Apfelbaum <address@hidden>
> Reviewed-by: Marcel Apfelbaum <address@hidden>
> Reviewed-by: Markus Armbruster <address@hidden>
Reviewed-by: Michael S. Tsirkin <address@hidden>
In fact, I'd Cc stable on this one.
> ---
>
> Notes:
> v6:
> - no changes
>
> v5:
> - separate "%s@" from TARGET_FMT_plx with a space [Markus]
> - copied Markus's note about "no arbitrary length limit" on the retval
> into the commit message
>
> v4:
> - unchanged
>
> v3:
> - new in v3
>
> hw/core/sysbus.c | 16 ++++++----------
> 1 file changed, 6 insertions(+), 10 deletions(-)
>
> diff --git a/hw/core/sysbus.c b/hw/core/sysbus.c
> index b53c351..92eced9 100644
> --- a/hw/core/sysbus.c
> +++ b/hw/core/sysbus.c
> @@ -281,19 +281,15 @@ static void sysbus_dev_print(Monitor *mon, DeviceState
> *dev, int indent)
> static char *sysbus_get_fw_dev_path(DeviceState *dev)
> {
> SysBusDevice *s = SYS_BUS_DEVICE(dev);
> - char path[40];
> - int off;
> -
> - off = snprintf(path, sizeof(path), "%s", qdev_fw_name(dev));
>
> if (s->num_mmio) {
> - snprintf(path + off, sizeof(path) - off, "@"TARGET_FMT_plx,
> - s->mmio[0].addr);
> - } else if (s->num_pio) {
> - snprintf(path + off, sizeof(path) - off, "@i%04x", s->pio[0]);
> + return g_strdup_printf("%s@" TARGET_FMT_plx, qdev_fw_name(dev),
> + s->mmio[0].addr);
> }
> -
> - return g_strdup(path);
> + if (s->num_pio) {
> + return g_strdup_printf("address@hidden", qdev_fw_name(dev),
> s->pio[0]);
> + }
> + return g_strdup(qdev_fw_name(dev));
> }
>
> void sysbus_add_io(SysBusDevice *dev, hwaddr addr,
> --
> 1.8.3.1
>
- [Qemu-devel] [PATCH v6 0/7] PXB changes, Laszlo Ersek, 2015/06/17
- [Qemu-devel] [PATCH v6 2/7] hw/pci-bridge: expose _test parameter in SHPC_VMSTATE(), Laszlo Ersek, 2015/06/17
- [Qemu-devel] [PATCH v6 5/7] hw/core: rebase sysbus_get_fw_dev_path() to g_strdup_printf(), Laszlo Ersek, 2015/06/17
- Re: [Qemu-devel] [PATCH v6 5/7] hw/core: rebase sysbus_get_fw_dev_path() to g_strdup_printf(),
Michael S. Tsirkin <=
- [Qemu-devel] [PATCH v6 3/7] hw/pci-bridge: introduce "hotplug" property, Laszlo Ersek, 2015/06/17
- Re: [Qemu-devel] [PATCH v6 3/7] hw/pci-bridge: introduce "hotplug" property, Michael S. Tsirkin, 2015/06/17
- Re: [Qemu-devel] [PATCH v6 3/7] hw/pci-bridge: introduce "hotplug" property, Laszlo Ersek, 2015/06/17
- Re: [Qemu-devel] [PATCH v6 3/7] hw/pci-bridge: introduce "hotplug" property, Michael S. Tsirkin, 2015/06/17
- Re: [Qemu-devel] [PATCH v6 3/7] hw/pci-bridge: introduce "hotplug" property, Laszlo Ersek, 2015/06/17
- Re: [Qemu-devel] [PATCH v6 3/7] hw/pci-bridge: introduce "hotplug" property, Marcel Apfelbaum, 2015/06/17
- Re: [Qemu-devel] [PATCH v6 3/7] hw/pci-bridge: introduce "hotplug" property, Paolo Bonzini, 2015/06/18
- Re: [Qemu-devel] [PATCH v6 3/7] hw/pci-bridge: introduce "hotplug" property, Michael S. Tsirkin, 2015/06/18
- [Qemu-devel] [PATCH v6 6/7] hw/core: explicit OFW unit address callback for SysBusDeviceClass, Laszlo Ersek, 2015/06/17