[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[Qemu-devel] [PATCH 0/7] x86 CPU subclasses, take 6
From: |
Eduardo Habkost |
Subject: |
[Qemu-devel] [PATCH 0/7] x86 CPU subclasses, take 6 |
Date: |
Wed, 27 Nov 2013 17:34:02 -0200 |
I want to try to get this in 1.8, because I have found one additional use-case
for the new subclasses:
libvirt needs to be able to query details about the existing CPU models, and it
can't do that today without restarting QEMU every time. Having separate classes
for each CPU model allows libvirt to create/destroy CPU objects in a loop just
to query the resulting properties (especially "feature-words") for each CPU
model.
This version is closer to the version sent by Andrea and then later resubmitted
by Igor as "[RFC v5] target-i386: Slim conversion to X86CPU subclasses + KVM
subclasses", than the previous version I have sent, as it doesn't create one new
class_init function for each subclass. One main difference is that this version
does not use KVM-specific subclasses, to keep things simpler.
Another difference is that instead of late registration of the "host" class, I
simply changed the "host" subclass to do KVM-dependent initialization steps on
instance_init instead of class_init. This way we won't require any
initialization-ordering tricks. In the past this was a problem, but today the
global properties are being set by qdev code on post_init, so we can safely
initialize property defaults on instance_init without having to worry that it
would break the setting of global properties.
This series needs to be applied on top of:
Subject: [PATCH 0/8] target-i386: Simplify kvm_cpu_fill_host() and
kvm_check_features_against_host()
Message-Id: <address@hidden>
http://article.gmane.org/gmane.comp.emulators.qemu/243013
Eduardo Habkost (7):
target-i386: Eliminate CONFIG_KVM #ifdefs
target-i386: Don't change x86_def_t struct on cpu_x86_register()
target-i386: Move KVM default-vendor hack to instance_init
target-i386: Rename cpu_x86_register() to x86_cpu_load_def()
target-i386: Call x86_cpu_load_def() earlier
target-i386: Rename x86_def_t to X86CPUDefinition
target-i386: CPU model subclasses
target-i386/cpu-qom.h | 13 ++
target-i386/cpu.c | 407 ++++++++++++++++++++++++++++++--------------------
target-i386/cpu.h | 2 -
3 files changed, 260 insertions(+), 162 deletions(-)
--
1.8.3.1
- [Qemu-devel] [PATCH 0/7] x86 CPU subclasses, take 6,
Eduardo Habkost <=
- [Qemu-devel] [PATCH 1/7] target-i386: Eliminate CONFIG_KVM #ifdefs, Eduardo Habkost, 2013/11/27
- [Qemu-devel] [PATCH 2/7] target-i386: Don't change x86_def_t struct on cpu_x86_register(), Eduardo Habkost, 2013/11/27
- [Qemu-devel] [PATCH 3/7] target-i386: Move KVM default-vendor hack to instance_init, Eduardo Habkost, 2013/11/27
- [Qemu-devel] [PATCH 4/7] target-i386: Rename cpu_x86_register() to x86_cpu_load_def(), Eduardo Habkost, 2013/11/27
- [Qemu-devel] [PATCH 5/7] target-i386: Call x86_cpu_load_def() earlier, Eduardo Habkost, 2013/11/27
- [Qemu-devel] [RFC 7/7] target-i386: CPU model subclasses, Eduardo Habkost, 2013/11/27
- [Qemu-devel] [PATCH 6/7] target-i386: Rename x86_def_t to X86CPUDefinition, Eduardo Habkost, 2013/11/27