[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[Qemu-devel] [PATCH v2 0/7] Further tcg ldst improvements
From: |
Richard Henderson |
Subject: |
[Qemu-devel] [PATCH v2 0/7] Further tcg ldst improvements |
Date: |
Thu, 29 Aug 2013 15:05:54 -0700 |
Changes from v1 to v2:
* Rebased vs master, fixing minor conflicts.
* Dropped the tail-call from qemu_ld slow path to helper,
as discussed wrt not constraining the ld output register.
The patch set is available at
git://github.com/rth7680/qemu.git tcg-ool-2
r~
Richard Henderson (7):
exec: Reorganize the GETRA/GETPC macros
tcg-i386: Don't perform GETPC adjustment in TCG code
exec: Rename USUFFIX to LSUFFIX
target: Include softmmu_exec.h where forgotten
exec: Split softmmu_defs.h
tcg: Introduce zero and sign-extended versions of load helpers
tcg-i386: Make use of zero-extended memory helper routines
include/exec/exec-all.h | 89 ++++++++++++++++++++---------------------
include/exec/softmmu_defs.h | 49 -----------------------
include/exec/softmmu_exec.h | 3 +-
include/exec/softmmu_template.h | 88 ++++++++++++++++++++++++++++++----------
target-lm32/op_helper.c | 2 +
target-moxie/helper.c | 1 +
target-ppc/mmu_helper.c | 2 +
target-unicore32/op_helper.c | 2 +
target-xtensa/op_helper.c | 1 +
tcg/aarch64/tcg-target.c | 2 -
tcg/arm/tcg-target.c | 2 -
tcg/hppa/tcg-target.c | 2 -
tcg/i386/tcg-target.c | 58 +++++++++++----------------
tcg/ia64/tcg-target.c | 3 --
tcg/mips/tcg-target.c | 3 --
tcg/ppc/tcg-target.c | 2 -
tcg/ppc64/tcg-target.c | 3 --
tcg/s390/tcg-target.c | 3 --
tcg/sparc/tcg-target.c | 2 -
tcg/tcg.h | 52 ++++++++++++++++++++++++
20 files changed, 194 insertions(+), 175 deletions(-)
delete mode 100644 include/exec/softmmu_defs.h
--
1.8.1.4
- [Qemu-devel] [PATCH v2 0/7] Further tcg ldst improvements,
Richard Henderson <=
- [Qemu-devel] [PATCH v2 1/7] exec: Reorganize the GETRA/GETPC macros, Richard Henderson, 2013/08/29
- [Qemu-devel] [PATCH v2 2/7] tcg-i386: Don't perform GETPC adjustment in TCG code, Richard Henderson, 2013/08/29
- [Qemu-devel] [PATCH v2 3/7] exec: Rename USUFFIX to LSUFFIX, Richard Henderson, 2013/08/29
- [Qemu-devel] [PATCH v2 4/7] target: Include softmmu_exec.h where forgotten, Richard Henderson, 2013/08/29
- [Qemu-devel] [PATCH v2 5/7] exec: Split softmmu_defs.h, Richard Henderson, 2013/08/29