[Top][All Lists]
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [Qemu-devel] [PATCH v3 13/16] net: Make the monitor output more reas
From: |
Jan Kiszka |
Subject: |
Re: [Qemu-devel] [PATCH v3 13/16] net: Make the monitor output more reasonable hub info |
Date: |
Thu, 24 May 2012 17:34:42 -0300 |
User-agent: |
Mozilla/5.0 (X11; U; Linux i686 (x86_64); de; rv:1.8.1.12) Gecko/20080226 SUSE/2.0.0.12-1.1 Thunderbird/2.0.0.12 Mnenhy/0.7.5.666 |
On 2012-05-24 14:59, address@hidden wrote:
> From: Zhi Yong Wu <address@hidden>
>
> Signed-off-by: Zhi Yong Wu <address@hidden>
> ---
> net.c | 7 ++++++-
> net/hub.c | 2 +-
> 2 files changed, 7 insertions(+), 2 deletions(-)
>
> diff --git a/net.c b/net.c
> index 61dc28d..79ac51f 100644
> --- a/net.c
> +++ b/net.c
> @@ -887,6 +887,12 @@ static const struct {
> },
> },
> #endif /* CONFIG_NET_BRIDGE */
> + [NET_CLIENT_TYPE_HUB] = {
> + .type = "hubport",
> + .desc = {
> + { /* end of list */ }
> + },
> + },
> };
>
> int net_client_init(Monitor *mon, QemuOpts *opts, int is_netdev)
> @@ -1079,7 +1085,6 @@ void do_info_network(Monitor *mon)
> NetClientState *nc, *peer;
> net_client_type type;
>
> - monitor_printf(mon, "Devices not on any VLAN:\n");
> QTAILQ_FOREACH(nc, &net_clients, next) {
> peer = nc->peer;
> type = nc->info->type;
> diff --git a/net/hub.c b/net/hub.c
> index 0cc385e..8a583ab 100644
> --- a/net/hub.c
> +++ b/net/hub.c
> @@ -193,7 +193,7 @@ void net_hub_info(Monitor *mon)
> QLIST_FOREACH(hub, &hubs, next) {
> monitor_printf(mon, "hub %u\n", hub->id);
> QLIST_FOREACH(port, &hub->ports, next) {
> - monitor_printf(mon, " port %u peer %s\n", port->id,
> + monitor_printf(mon, " \\ %s\n",
> port->nc.peer ? port->nc.peer->name : "<none>");
> }
> }
I still do not agree with this formatting (peer -> hubport + hub ->
abbreviated peers instead of just hub -> peers). But the series has a
higher value than this, and we can fix on top - unless there is a need
for another round anyway.
Jan
--
Siemens AG, Corporate Technology, CT T DE IT 1
Corporate Competence Center Embedded Linux
- [Qemu-devel] [PATCH v3 05/16] net: Drop vlan argument to qemu_new_net_client(), (continued)
- [Qemu-devel] [PATCH v3 05/16] net: Drop vlan argument to qemu_new_net_client(), zwu . kernel, 2012/05/24
- [Qemu-devel] [PATCH v3 06/16] net: Remove vlan qdev property, zwu . kernel, 2012/05/24
- [Qemu-devel] [PATCH v3 04/16] hub: Check that hubs are configured correctly, zwu . kernel, 2012/05/24
- [Qemu-devel] [PATCH v3 07/16] net: Remove vlan code from net.c, zwu . kernel, 2012/05/24
- [Qemu-devel] [PATCH v3 09/16] net: Rename non_vlan_clients to net_clients, zwu . kernel, 2012/05/24
- [Qemu-devel] [PATCH v3 08/16] net: Remove VLANState, zwu . kernel, 2012/05/24
- [Qemu-devel] [PATCH v3 14/16] net: cleanup deliver/deliver_iov func pointers, zwu . kernel, 2012/05/24
- [Qemu-devel] [PATCH v3 15/16] net: determine if packets can be sent before net queue deliver packets, zwu . kernel, 2012/05/24
- [Qemu-devel] [PATCH v3 11/16] net: Rename vc local variables to nc, zwu . kernel, 2012/05/24
- [Qemu-devel] [PATCH v3 13/16] net: Make the monitor output more reasonable hub info, zwu . kernel, 2012/05/24
- Re: [Qemu-devel] [PATCH v3 13/16] net: Make the monitor output more reasonable hub info,
Jan Kiszka <=
- [Qemu-devel] [PATCH v3 10/16] net: Rename VLANClientState to NetClientState, zwu . kernel, 2012/05/24
- [Qemu-devel] [PATCH v3 16/16] hub: add the support for hub own flow control, zwu . kernel, 2012/05/24