qemu-commits
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-commits] [qemu/qemu] 5afc8d: virtiofsd: xattr mapping add a new ty


From: Richard Henderson
Subject: [Qemu-commits] [qemu/qemu] 5afc8d: virtiofsd: xattr mapping add a new type "unsupported"
Date: Tue, 26 Oct 2021 10:12:03 -0700

  Branch: refs/heads/master
  Home:   https://github.com/qemu/qemu
  Commit: 5afc8df46cdf1a10fc44d43208cf449357009d2a
      
https://github.com/qemu/qemu/commit/5afc8df46cdf1a10fc44d43208cf449357009d2a
  Author: Vivek Goyal <vgoyal@redhat.com>
  Date:   2021-10-25 (Mon, 25 Oct 2021)

  Changed paths:
    M docs/tools/virtiofsd.rst
    M tools/virtiofsd/passthrough_ll.c

  Log Message:
  -----------
  virtiofsd: xattr mapping add a new type "unsupported"

Right now for xattr remapping, we support types of "prefix", "ok" or "bad".
Type "bad" returns -EPERM on setxattr and hides xattr in listxattr. For
getxattr, mapping code returns -EPERM but getxattr code converts it to -ENODATA.

I need a new semantics where if an xattr is unsupported, then
getxattr()/setxattr() return -ENOTSUP and listxattr() should hide the xattr.
This is needed to simulate that security.selinux is not supported by
virtiofs filesystem and in that case client falls back to some default
label specified by policy.

So add a new type "unsupported" which returns -ENOTSUP on getxattr() and
setxattr() and hides xattrs in listxattr().

For example, one can use following mapping rule to not support
security.selinux xattr and allow others.

"-o xattrmap=/unsupported/all/security.selinux/security.selinux//ok/all///"

Suggested-by: "Dr. David Alan Gilbert" <dgilbert@redhat.com>
Signed-off-by: Vivek Goyal <vgoyal@redhat.com>
Message-Id: <YUt9qbmgAfCFfg5t@redhat.com>
Reviewed-by: Dr. David Alan Gilbert <dgilbert@redhat.com>
Signed-off-by: Dr. David Alan Gilbert <dgilbert@redhat.com>


  Commit: a88abc6f841ea7f0a9c57d69ccf133e2c7d12348
      
https://github.com/qemu/qemu/commit/a88abc6f841ea7f0a9c57d69ccf133e2c7d12348
  Author: Vivek Goyal <vgoyal@redhat.com>
  Date:   2021-10-25 (Mon, 25 Oct 2021)

  Changed paths:
    M tools/virtiofsd/fuse_virtio.c

  Log Message:
  -----------
  virtiofsd: Remove unused virtio_fs_config definition

"struct virtio_fs_config" definition seems to be unused in fuse_virtio.c.
Remove it.

Signed-off-by: Vivek Goyal <vgoyal@redhat.com>
Message-Id: <20210930153037.1194279-4-vgoyal@redhat.com>
Reviewed-by: Stefan Hajnoczi <stefanha@redhat.com>
Signed-off-by: Dr. David Alan Gilbert <dgilbert@redhat.com>


  Commit: c68276556a1e6e035f9a27d0dbb2f87b349f3aea
      
https://github.com/qemu/qemu/commit/c68276556a1e6e035f9a27d0dbb2f87b349f3aea
  Author: Vivek Goyal <vgoyal@redhat.com>
  Date:   2021-10-25 (Mon, 25 Oct 2021)

  Changed paths:
    M tools/virtiofsd/fuse_virtio.c

  Log Message:
  -----------
  virtiofsd: Add a helper to send element on virtqueue

We have open coded logic to take locks and push element on virtqueue at
three places. Add a helper and use it everywhere. Code is easier to read and
less number of lines of code.

Signed-off-by: Vivek Goyal <vgoyal@redhat.com>
Message-Id: <20210930153037.1194279-5-vgoyal@redhat.com>
Reviewed-by: Stefan Hajnoczi <stefanha@redhat.com>
Signed-off-by: Dr. David Alan Gilbert <dgilbert@redhat.com>


  Commit: 50cf6d6cb7b6b0e43f626da2a65d7277add21bd9
      
https://github.com/qemu/qemu/commit/50cf6d6cb7b6b0e43f626da2a65d7277add21bd9
  Author: Vivek Goyal <vgoyal@redhat.com>
  Date:   2021-10-25 (Mon, 25 Oct 2021)

  Changed paths:
    M tools/virtiofsd/fuse_virtio.c

  Log Message:
  -----------
  virtiofsd: Add a helper to stop all queues

Use a helper to stop all the queues. Later in the patch series I am
planning to use this helper at one more place later in the patch series.

Signed-off-by: Vivek Goyal <vgoyal@redhat.com>
Message-Id: <20210930153037.1194279-6-vgoyal@redhat.com>
Reviewed-by: Stefan Hajnoczi <stefanha@redhat.com>
Signed-off-by: Dr. David Alan Gilbert <dgilbert@redhat.com>


  Commit: 555a76e5e5dc2cd3c84c5e1bc060be17d5b32584
      
https://github.com/qemu/qemu/commit/555a76e5e5dc2cd3c84c5e1bc060be17d5b32584
  Author: Dr. David Alan Gilbert <dgilbert@redhat.com>
  Date:   2021-10-25 (Mon, 25 Oct 2021)

  Changed paths:
    M tools/virtiofsd/fuse_virtio.c

  Log Message:
  -----------
  virtiofsd: Error on bad socket group name

Make the '--socket-group=' option fail if the group name is unknown:

./tools/virtiofsd/virtiofsd .... --socket-group=zaphod
vhost socket: unable to find group 'zaphod'

Reported-by: Xiaoling Gao <xiagao@redhat.com>
Signed-off-by: Dr. David Alan Gilbert <dgilbert@redhat.com>
Message-Id: <20211014122554.34599-1-dgilbert@redhat.com>
Reviewed-by: Vivek Goyal <vgoyal@redhat.com>
Signed-off-by: Dr. David Alan Gilbert <dgilbert@redhat.com>


  Commit: 931ce30859176f0f7daac6bac255dae5eb21284e
      
https://github.com/qemu/qemu/commit/931ce30859176f0f7daac6bac255dae5eb21284e
  Author: Richard Henderson <richard.henderson@linaro.org>
  Date:   2021-10-26 (Tue, 26 Oct 2021)

  Changed paths:
    M docs/tools/virtiofsd.rst
    M tools/virtiofsd/fuse_virtio.c
    M tools/virtiofsd/passthrough_ll.c

  Log Message:
  -----------
  Merge remote-tracking branch 'remotes/dagrh/tags/pull-virtiofs-20211026' into 
staging

Virtiofsd pull 2021-10-26

New 'unsupported' feature for xattr mapping
  Good for hiding selinux

Plus some tidy ups and error handling.
Signed-off-by: Dr. David Alan Gilbert <dgilbert@redhat.com>

# gpg: Signature made Tue 26 Oct 2021 03:28:44 AM PDT
# gpg:                using RSA key 45F5C71B4A0CB7FB977A9FA90516331EBC5BFDE7
# gpg: Good signature from "Dr. David Alan Gilbert (RH2) <dgilbert@redhat.com>" 
[full]

* remotes/dagrh/tags/pull-virtiofs-20211026:
  virtiofsd: Error on bad socket group name
  virtiofsd: Add a helper to stop all queues
  virtiofsd: Add a helper to send element on virtqueue
  virtiofsd: Remove unused virtio_fs_config definition
  virtiofsd: xattr mapping add a new type "unsupported"

Signed-off-by: Richard Henderson <richard.henderson@linaro.org>


Compare: https://github.com/qemu/qemu/compare/c5b2f5598141...931ce3085917



reply via email to

[Prev in Thread] Current Thread [Next in Thread]