qemu-commits
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-commits] [qemu/qemu] 0bab18: target/s390x/translate: Fix RNSBG ins


From: Peter Maydell
Subject: [Qemu-commits] [qemu/qemu] 0bab18: target/s390x/translate: Fix RNSBG instruction
Date: Fri, 28 Feb 2020 02:30:13 -0800

  Branch: refs/heads/master
  Home:   https://github.com/qemu/qemu
  Commit: 0bab189c96c780341a954186276f9b58ea3244b9
      
https://github.com/qemu/qemu/commit/0bab189c96c780341a954186276f9b58ea3244b9
  Author: Thomas Huth <address@hidden>
  Date:   2020-02-26 (Wed, 26 Feb 2020)

  Changed paths:
    M target/s390x/translate.c

  Log Message:
  -----------
  target/s390x/translate: Fix RNSBG instruction

RNSBG is handled via the op_rosbg() helper function. But RNSBG has
the opcode 0xEC54, i.e. 0x54 as second byte, while op_rosbg() currently
checks for 0x55. This seems to be a typo, fix it to use 0x54 instead,
so that op_rosbg() does not abort() anymore if a program uses RNSBG.

I've checked with a simple test function that I now get the same results
with KVM and with TCG:

 static void test_rnsbg(void)
 {
        uint64_t r1, r2;

        r2 = 0xffff000000000000UL;
        r1 = 0x123456789bdfaaaaUL;
        asm volatile (" rnsbg %0,%1,12,61,16 " : "+r"(r1) : "r"(r2));

        printf("r1 afterwards: 0x%lx\n", r1);
 }

Buglink: https://bugs.launchpad.net/qemu/+bug/1860920
Signed-off-by: Thomas Huth <address@hidden>
Message-Id: <address@hidden>
Fixes: d6c6372e186e ("target-s390: Implement R[NOX]SBG")
Reviewed-by: David Hildenbrand <address@hidden>
Signed-off-by: Cornelia Huck <address@hidden>


  Commit: ddda37483dd17c9936fdde9ebf8f6ca2692b3842
      
https://github.com/qemu/qemu/commit/ddda37483dd17c9936fdde9ebf8f6ca2692b3842
  Author: Cornelia Huck <address@hidden>
  Date:   2020-02-26 (Wed, 26 Feb 2020)

  Changed paths:
    M include/standard-headers/drm/drm_fourcc.h
    M include/standard-headers/linux/ethtool.h
    M include/standard-headers/linux/input.h
    M include/standard-headers/linux/pci_regs.h
    M linux-headers/asm-arm/unistd-common.h
    M linux-headers/asm-arm64/kvm.h
    M linux-headers/asm-arm64/unistd.h
    M linux-headers/asm-generic/mman-common.h
    M linux-headers/asm-generic/unistd.h
    M linux-headers/asm-mips/unistd_n32.h
    M linux-headers/asm-mips/unistd_n64.h
    M linux-headers/asm-mips/unistd_o32.h
    M linux-headers/asm-powerpc/unistd_32.h
    M linux-headers/asm-powerpc/unistd_64.h
    M linux-headers/asm-s390/unistd_32.h
    M linux-headers/asm-s390/unistd_64.h
    M linux-headers/asm-x86/unistd_32.h
    M linux-headers/asm-x86/unistd_64.h
    M linux-headers/asm-x86/unistd_x32.h
    M linux-headers/linux/kvm.h

  Log Message:
  -----------
  linux-headers: update

Update to commit b1da3acc781c ("Merge tag 'ecryptfs-5.6-rc3-fixes' of
git://git.kernel.org/pub/scm/linux/kernel/git/tyhicks/ecryptfs")

Signed-off-by: Cornelia Huck <address@hidden>


  Commit: b91a03946e0f65ddd22927dd80ca1276bf89c5af
      
https://github.com/qemu/qemu/commit/b91a03946e0f65ddd22927dd80ca1276bf89c5af
  Author: Janosch Frank <address@hidden>
  Date:   2020-02-26 (Wed, 26 Feb 2020)

  Changed paths:
    M target/s390x/cpu.c
    M target/s390x/kvm-stub.c
    M target/s390x/kvm.c
    M target/s390x/kvm_s390x.h

  Log Message:
  -----------
  s390x: Add missing vcpu reset functions

Up to now we only had an ioctl to reset vcpu data QEMU couldn't reach
for the initial reset, which was also called for the clear reset. To
be architecture compliant, we also need to clear local interrupts on a
normal reset.

Because of this and the upcoming protvirt support we need to add
ioctls for the missing clear and normal resets.

Signed-off-by: Janosch Frank <address@hidden>
Reviewed-by: Thomas Huth <address@hidden>
Acked-by: David Hildenbrand <address@hidden>
Message-Id: <address@hidden>
Signed-off-by: Cornelia Huck <address@hidden>


  Commit: 8b51c0961cc13e55b26bb6665ec3a341abdc7658
      
https://github.com/qemu/qemu/commit/8b51c0961cc13e55b26bb6665ec3a341abdc7658
  Author: Christian Borntraeger <address@hidden>
  Date:   2020-02-26 (Wed, 26 Feb 2020)

  Changed paths:
    M target/s390x/helper.c

  Log Message:
  -----------
  s390/sclp: improve special wait psw logic

There is a special quiesce PSW that we check for "shutdown". Otherwise disabled
wait is detected as "crashed". Architecturally we must only check PSW bits
116-127. Fix this.

Cc: address@hidden
Signed-off-by: Christian Borntraeger <address@hidden>
Message-Id: <address@hidden>
Reviewed-by: David Hildenbrand <address@hidden>
Acked-by: Janosch Frank <address@hidden>
Signed-off-by: Cornelia Huck <address@hidden>


  Commit: cc3d15a5ea960a65edbd1d6a3fb57e127f7a8080
      
https://github.com/qemu/qemu/commit/cc3d15a5ea960a65edbd1d6a3fb57e127f7a8080
  Author: Cornelia Huck <address@hidden>
  Date:   2020-02-26 (Wed, 26 Feb 2020)

  Changed paths:
    M MAINTAINERS
    M docs/devel/index.rst
    A docs/devel/s390-dasd-ipl.rst
    R docs/devel/s390-dasd-ipl.txt

  Log Message:
  -----------
  docs: rstfy s390 dasd ipl documentation

While at it, also fix the numbering in 'What QEMU does'.

Reviewed-by: Thomas Huth <address@hidden>
Message-Id: <address@hidden>
Signed-off-by: Cornelia Huck <address@hidden>


  Commit: 8f4335242a2ed7862363ff3bf08d0dfc3c3098e7
      
https://github.com/qemu/qemu/commit/8f4335242a2ed7862363ff3bf08d0dfc3c3098e7
  Author: Cornelia Huck <address@hidden>
  Date:   2020-02-26 (Wed, 26 Feb 2020)

  Changed paths:
    M MAINTAINERS
    M docs/system/index.rst
    A docs/system/vfio-ap.rst
    R docs/vfio-ap.txt

  Log Message:
  -----------
  docs: rstfy vfio-ap documentation

Move to system/, as this is mostly about configuring vfio-ap.

Message-Id: <address@hidden>
Reviewed-by: Pierre Morel <address@hidden>
Signed-off-by: Cornelia Huck <address@hidden>


  Commit: b6c2dbd7214b0b2396e1dcf9668c8b48ab571115
      
https://github.com/qemu/qemu/commit/b6c2dbd7214b0b2396e1dcf9668c8b48ab571115
  Author: Janosch Frank <address@hidden>
  Date:   2020-02-27 (Thu, 27 Feb 2020)

  Changed paths:
    M hw/s390x/ipl.c
    M target/s390x/cpu.c
    M target/s390x/cpu.h

  Log Message:
  -----------
  s390x: Rename and use constants for short PSW address and mask

Let's rename PSW_MASK_ESA_ADDR to PSW_MASK_SHORT_ADDR because we're
not working with a ESA PSW which would not support the extended
addressing bit. Also let's actually use it.

Additionally we introduce PSW_MASK_SHORT_CTRL and use it throughout
the codebase.

Signed-off-by: Janosch Frank <address@hidden>
Reviewed-by: Christian Borntraeger <address@hidden>
Reviewed-by: David Hildenbrand <address@hidden>
Message-Id: <address@hidden>
Signed-off-by: Cornelia Huck <address@hidden>


  Commit: 430f63e250a55c5fdfa31ffbddd8538dc1ce6b36
      
https://github.com/qemu/qemu/commit/430f63e250a55c5fdfa31ffbddd8538dc1ce6b36
  Author: Peter Maydell <address@hidden>
  Date:   2020-02-27 (Thu, 27 Feb 2020)

  Changed paths:
    M MAINTAINERS
    M docs/devel/index.rst
    A docs/devel/s390-dasd-ipl.rst
    R docs/devel/s390-dasd-ipl.txt
    M docs/system/index.rst
    A docs/system/vfio-ap.rst
    R docs/vfio-ap.txt
    M hw/s390x/ipl.c
    M include/standard-headers/drm/drm_fourcc.h
    M include/standard-headers/linux/ethtool.h
    M include/standard-headers/linux/input.h
    M include/standard-headers/linux/pci_regs.h
    M linux-headers/asm-arm/unistd-common.h
    M linux-headers/asm-arm64/kvm.h
    M linux-headers/asm-arm64/unistd.h
    M linux-headers/asm-generic/mman-common.h
    M linux-headers/asm-generic/unistd.h
    M linux-headers/asm-mips/unistd_n32.h
    M linux-headers/asm-mips/unistd_n64.h
    M linux-headers/asm-mips/unistd_o32.h
    M linux-headers/asm-powerpc/unistd_32.h
    M linux-headers/asm-powerpc/unistd_64.h
    M linux-headers/asm-s390/unistd_32.h
    M linux-headers/asm-s390/unistd_64.h
    M linux-headers/asm-x86/unistd_32.h
    M linux-headers/asm-x86/unistd_64.h
    M linux-headers/asm-x86/unistd_x32.h
    M linux-headers/linux/kvm.h
    M target/s390x/cpu.c
    M target/s390x/cpu.h
    M target/s390x/helper.c
    M target/s390x/kvm-stub.c
    M target/s390x/kvm.c
    M target/s390x/kvm_s390x.h
    M target/s390x/translate.c

  Log Message:
  -----------
  Merge remote-tracking branch 'remotes/cohuck/tags/s390x-20200227' into staging

Includes a headers update against 5.6-current.
- add missing vcpu reset functionality
- rstfy some s390 documentation
- fixes and enhancements

# gpg: Signature made Thu 27 Feb 2020 11:50:08 GMT
# gpg:                using RSA key C3D0D66DC3624FF6A8C018CEDECF6B93C6F02FAF
# gpg:                issuer "address@hidden"
# gpg: Good signature from "Cornelia Huck <address@hidden>" [marginal]
# gpg:                 aka "Cornelia Huck <address@hidden>" [full]
# gpg:                 aka "Cornelia Huck <address@hidden>" [full]
# gpg:                 aka "Cornelia Huck <address@hidden>" [marginal]
# gpg:                 aka "Cornelia Huck <address@hidden>" [marginal]
# Primary key fingerprint: C3D0 D66D C362 4FF6 A8C0  18CE DECF 6B93 C6F0 2FAF

* remotes/cohuck/tags/s390x-20200227:
  s390x: Rename and use constants for short PSW address and mask
  docs: rstfy vfio-ap documentation
  docs: rstfy s390 dasd ipl documentation
  s390/sclp: improve special wait psw logic
  s390x: Add missing vcpu reset functions
  linux-headers: update
  target/s390x/translate: Fix RNSBG instruction

Signed-off-by: Peter Maydell <address@hidden>


Compare: https://github.com/qemu/qemu/compare/8b6b68e05b43...430f63e250a5



reply via email to

[Prev in Thread] Current Thread [Next in Thread]