qemu-commits
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-commits] [qemu/qemu] ecccae: ui: remove misleading comment from vn


From: GitHub
Subject: [Qemu-commits] [qemu/qemu] ecccae: ui: remove misleading comment from vnc_init_state
Date: Thu, 13 Oct 2016 08:30:06 -0700

  Branch: refs/heads/master
  Home:   https://github.com/qemu/qemu
  Commit: ecccaea2f5769bb909c7a3510dc3ff9dbd736249
      
https://github.com/qemu/qemu/commit/ecccaea2f5769bb909c7a3510dc3ff9dbd736249
  Author: Daniel P. Berrange <address@hidden>
  Date:   2016-10-13 (Thu, 13 Oct 2016)

  Changed paths:
    M ui/vnc.c

  Log Message:
  -----------
  ui: remove misleading comment from vnc_init_state

The last line in vnc_init_state() says

     /* vs might be free()ed here */

This was added in

  commit 198a0039c5fca224a77e9761e2350dd9cc102ad0
  Author: Gerd Hoffmann <address@hidden>
  Date:   Tue Jun 16 14:19:48 2009 +0200

    vnc: rework VncState release workflow.

because the preceeding 'vnc_update_client()' could indeed
release the VncState instance.

The call to vnc_update_client() was removed not long after
though in

  commit 1fc624122fb923c7fc4c1f426541d953e7df13c9
  Author: Stefano Stabellini <address@hidden>
  Date:   Mon Aug 3 10:54:32 2009 +0100

    single vnc server surface

and so the comment has been wrong ever since

Signed-off-by: Daniel P. Berrange <address@hidden>
Message-id: address@hidden
Signed-off-by: Gerd Hoffmann <address@hidden>


  Commit: 12b2806761a2dd4b88bdbe6f3bee4bcd998a9918
      
https://github.com/qemu/qemu/commit/12b2806761a2dd4b88bdbe6f3bee4bcd998a9918
  Author: Daniel P. Berrange <address@hidden>
  Date:   2016-10-13 (Thu, 13 Oct 2016)

  Changed paths:
    M ui/vnc.c
    M ui/vnc.h

  Log Message:
  -----------
  ui: remove 'enabled' and 'ws_enabled' fields from VncState

The 'ws_enabled' field is never used outside of the
vnc_display_open method, so can be a local variable.

The 'enabled' field is easily replaced by a check
for whether 'lsock' is non-NULL.

Signed-off-by: Daniel P. Berrange <address@hidden>
Message-id: address@hidden
Signed-off-by: Gerd Hoffmann <address@hidden>


  Commit: 38e5756a614e9a492d1bb181166cd031bc87e159
      
https://github.com/qemu/qemu/commit/38e5756a614e9a492d1bb181166cd031bc87e159
  Author: Daniel P. Berrange <address@hidden>
  Date:   2016-10-13 (Thu, 13 Oct 2016)

  Changed paths:
    M ui/vnc.c
    M ui/vnc.h

  Log Message:
  -----------
  ui: remove 'ws_tls' field from VncState

The 'ws_tls' field in VncState is only ever representing
the result of 'tlscreds != NULL' and is thus pointless.
Replace use of 'ws_tls' with a direct check against
'tlscreds'

Signed-off-by: Daniel P. Berrange <address@hidden>
Message-id: address@hidden
Signed-off-by: Gerd Hoffmann <address@hidden>


  Commit: bf01c1794e870b6da83ccc57bb363e704ad9aa9e
      
https://github.com/qemu/qemu/commit/bf01c1794e870b6da83ccc57bb363e704ad9aa9e
  Author: Daniel P. Berrange <address@hidden>
  Date:   2016-10-13 (Thu, 13 Oct 2016)

  Changed paths:
    M ui/vnc.c

  Log Message:
  -----------
  ui: rename misleading 'VncDisplay' variables

Normally code declares 'VncDisplay *vd' or 'VncState *vs'
but there are a bunch of places which misleadingly declare
'VncDisplay *vs'.

Signed-off-by: Daniel P. Berrange <address@hidden>
Message-id: address@hidden
Signed-off-by: Gerd Hoffmann <address@hidden>


  Commit: eda24e188637e2f86db31c3edb76d457212fdcb1
      
https://github.com/qemu/qemu/commit/eda24e188637e2f86db31c3edb76d457212fdcb1
  Author: Daniel P. Berrange <address@hidden>
  Date:   2016-10-13 (Thu, 13 Oct 2016)

  Changed paths:
    M ui/vnc.c
    M ui/vnc.h

  Log Message:
  -----------
  ui: refactor method for setting up VncDisplay auth types

There is a lot of repeated code in the auth type setup method,
particularly around checking TLS credential types. Refactor
it to reduce duplication and instead of having one method
do both plain and websockets at once, call it separately
for each.

Signed-off-by: Daniel P. Berrange <address@hidden>
Message-id: address@hidden
Signed-off-by: Gerd Hoffmann <address@hidden>


  Commit: f54195ddf7460df077bec42a2475fd2d30a3f3f1
      
https://github.com/qemu/qemu/commit/f54195ddf7460df077bec42a2475fd2d30a3f3f1
  Author: Daniel P. Berrange <address@hidden>
  Date:   2016-10-13 (Thu, 13 Oct 2016)

  Changed paths:
    M ui/vnc.c

  Log Message:
  -----------
  ui: remove bogus call to graphic_hw_update() in vnc_listen_io

Just before accepting a new client connection the vnc_listen_io
method calls graphic_hw_update(). This is bogus because there
is a call to this method already in vnc_state_init() and the
client doesn't need up2date graphics console before reaching
that.

Signed-off-by: Daniel P. Berrange <address@hidden>
Message-id: address@hidden
Signed-off-by: Gerd Hoffmann <address@hidden>


  Commit: 2df2041036ee63ff9116631c6214e3ffb5f4bf45
      
https://github.com/qemu/qemu/commit/2df2041036ee63ff9116631c6214e3ffb5f4bf45
  Author: Daniel P. Berrange <address@hidden>
  Date:   2016-10-13 (Thu, 13 Oct 2016)

  Changed paths:
    M ui/vnc.c

  Log Message:
  -----------
  ui: remove bogus call to reset_keys() in vnc_init_state

The vnc_init_state method calls reset_keys() to reset the
modifier key state. This was originally added in

  commit 53762ddb277c690e486d0e17b10591774248c8cf
  Author: malc <address@hidden>
  Date:   Mon Dec 1 20:57:52 2008 +0000

    Reset the key modifiers upon client connect

This was valid at this time because there was only the
single VncState object which was persistent across client
connections and so needed resetting.

The persistent data was later split off into VncDisplay
and VncState was allocated at time of client connection:

  commit 753b4053311ff1437d99726970b1e7e6bf38249b
  Author: aliguori <address@hidden>
  Date:   Mon Feb 16 14:59:30 2009 +0000

    Support multiple VNC clients (Brian Kress)

at which point the modifier state is always 0 due to
use of g_new0. As such the reset_keys() call has been
a no-op ever since.

Signed-off-by: Daniel P. Berrange <address@hidden>
Message-id: address@hidden
Signed-off-by: Gerd Hoffmann <address@hidden>


  Commit: 90cd03a30ee96779ee9ae36a84b387452e256358
      
https://github.com/qemu/qemu/commit/90cd03a30ee96779ee9ae36a84b387452e256358
  Author: Daniel P. Berrange <address@hidden>
  Date:   2016-10-13 (Thu, 13 Oct 2016)

  Changed paths:
    M ui/vnc.c
    M ui/vnc.h

  Log Message:
  -----------
  ui: move some initialization out of vnc_init_state

Most of the fields in VncState are initialized in the
vnc_connect() method, but some are done in vnc_init_state()
instead.

The purpose of having vnc_init_state() is to delay starting
of the VNC wire protocol until after the websockets handshake
has completed. As such the vnc_init_state() method only needs
to be used for initialization that is dependant on the wire
protocol running.

This also lets us get rid of the initialized boolean flag
from the VncState struct.

Signed-off-by: Daniel P. Berrange <address@hidden>
Message-id: address@hidden
Signed-off-by: Gerd Hoffmann <address@hidden>


  Commit: dbee9897d5c35643ab2932a86bdf27bee673a7b8
      
https://github.com/qemu/qemu/commit/dbee9897d5c35643ab2932a86bdf27bee673a7b8
  Author: Daniel P. Berrange <address@hidden>
  Date:   2016-10-13 (Thu, 13 Oct 2016)

  Changed paths:
    M ui/vnc-ws.c
    M ui/vnc.c
    M ui/vnc.h

  Log Message:
  -----------
  ui: rename vnc_init_state to vnc_start_protocol

Rename the vnc_init_state method to reflect what its actual
purpose is, to discourage future devs from using it for more
general state initialization.

Signed-off-by: Daniel P. Berrange <address@hidden>
Message-id: address@hidden
Signed-off-by: Gerd Hoffmann <address@hidden>


  Commit: 2a57c55f26f7ba6dcea6d01ef74bae7069150f6f
      
https://github.com/qemu/qemu/commit/2a57c55f26f7ba6dcea6d01ef74bae7069150f6f
  Author: Gerd Hoffmann <address@hidden>
  Date:   2016-10-13 (Thu, 13 Oct 2016)

  Changed paths:
    M ui/input-linux.c

  Log Message:
  -----------
  input-linux: initialize key state

Query input device keys, initialize state accordingly, so the correct
state is reflected in case any key is pressed at initialization time.
There is a high chance for this to actually happen for the 'enter' key
in case you start qemu with a terminal command (directly or virsh).

When finding any pressed keys the input grab is delayed until all keys
are lifted, to avoid confusing guest and host with appearently stuck
keys.

Reported-by: Muted Bytes <address@hidden>
Signed-off-by: Gerd Hoffmann <address@hidden>
Message-id: address@hidden


  Commit: 6aa5a3679449cdf0b6fe5a6829b22e642ded57fd
      
https://github.com/qemu/qemu/commit/6aa5a3679449cdf0b6fe5a6829b22e642ded57fd
  Author: Peter Maydell <address@hidden>
  Date:   2016-10-13 (Thu, 13 Oct 2016)

  Changed paths:
    M ui/input-linux.c
    M ui/vnc-ws.c
    M ui/vnc.c
    M ui/vnc.h

  Log Message:
  -----------
  Merge remote-tracking branch 'remotes/kraxel/tags/pull-ui-20161013-1' into 
staging

ui: vnc cleanups, input-linux kbd fix.

# gpg: Signature made Thu 13 Oct 2016 09:47:43 BST
# gpg:                using RSA key 0x4CB6D8EED3E87138
# gpg: Good signature from "Gerd Hoffmann (work) <address@hidden>"
# gpg:                 aka "Gerd Hoffmann <address@hidden>"
# gpg:                 aka "Gerd Hoffmann (private) <address@hidden>"
# Primary key fingerprint: A032 8CFF B93A 17A7 9901  FE7D 4CB6 D8EE D3E8 7138

* remotes/kraxel/tags/pull-ui-20161013-1:
  input-linux: initialize key state
  ui: rename vnc_init_state to vnc_start_protocol
  ui: move some initialization out of vnc_init_state
  ui: remove bogus call to reset_keys() in vnc_init_state
  ui: remove bogus call to graphic_hw_update() in vnc_listen_io
  ui: refactor method for setting up VncDisplay auth types
  ui: rename misleading 'VncDisplay' variables
  ui: remove 'ws_tls' field from VncState
  ui: remove 'enabled' and 'ws_enabled' fields from VncState
  ui: remove misleading comment from vnc_init_state

Signed-off-by: Peter Maydell <address@hidden>


Compare: https://github.com/qemu/qemu/compare/692d88b40855...6aa5a3679449

reply via email to

[Prev in Thread] Current Thread [Next in Thread]