qemu-commits
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-commits] [qemu/qemu] 90e26f: target-arm/arm-semi.c: In SYS_HEAPINF


From: GitHub
Subject: [Qemu-commits] [qemu/qemu] 90e26f: target-arm/arm-semi.c: In SYS_HEAPINFO use correct...
Date: Thu, 07 Jul 2016 08:00:06 -0700

  Branch: refs/heads/master
  Home:   https://github.com/qemu/qemu
  Commit: 90e26f5aacd265257f7de58ee59f72dc36dff40e
      
https://github.com/qemu/qemu/commit/90e26f5aacd265257f7de58ee59f72dc36dff40e
  Author: Peter Maydell <address@hidden>
  Date:   2016-07-07 (Thu, 07 Jul 2016)

  Changed paths:
    M target-arm/arm-semi.c

  Log Message:
  -----------
  target-arm/arm-semi.c: In SYS_HEAPINFO use correct type for 'limit'

In commit f5666418c4 most of the SYS_HEAPINFO implementation was
fixed to use target_ulong rather than uint32_t, but the 'limit'
variable was not changed.

Reported-by: Laurent Desnogues <address@hidden>
Reviewed-by: Laurent Desnogues <address@hidden>
Signed-off-by: Peter Maydell <address@hidden>
Message-id: address@hidden


  Commit: bb14a1eda0d060413d17466c58b39e4c0dbcde4e
      
https://github.com/qemu/qemu/commit/bb14a1eda0d060413d17466c58b39e4c0dbcde4e
  Author: Paolo Bonzini <address@hidden>
  Date:   2016-07-07 (Thu, 07 Jul 2016)

  Changed paths:
    M hw/display/xlnx_dp.c

  Log Message:
  -----------
  xlnx_dp: fix iffy xlnx_dp_aux_push_tx_fifo

xlnx_dp_aux_push_tx_fifo takes an immediate uint8_t and a buffer length,
which must be 1 because that is how many uint8_t's fit in a uint8_t.
Sure enough, that is what xlnx_dp_write passes to it, but the function
is just weird.  Therefore, make xlnx_dp_aux_push_tx_fifo look like
xlnx_dp_aux_push_rx_fifo, taking a pointer to the buffer.

Reported by Coverity.

Signed-off-by: Paolo Bonzini <address@hidden>
Signed-off-by: Peter Maydell <address@hidden>


  Commit: 5229f45bd98558af84d806a98032df3cb741c357
      
https://github.com/qemu/qemu/commit/5229f45bd98558af84d806a98032df3cb741c357
  Author: Paolo Bonzini <address@hidden>
  Date:   2016-07-07 (Thu, 07 Jul 2016)

  Changed paths:
    M hw/misc/aux.c

  Log Message:
  -----------
  aux: fix break that wanted to break two levels out

The last "ret = AUX_I2C_NACK;" is dead, because it is always overridden
by AUX_I2C_ACK.  What really the code wants is to jump out of the switch
statement, and a "return" will not cut it because it would omit a debug
printf.

Change the logic so that we can break out of the while loop.  For clarity,
hoist the bus->last_* assignments up, right after i2c_start_transfer.

Signed-off-by: Paolo Bonzini <address@hidden>
Signed-off-by: Peter Maydell <address@hidden>


  Commit: e0dadc1e9ef1f35208e5d2af9c7740c18a0b769f
      
https://github.com/qemu/qemu/commit/e0dadc1e9ef1f35208e5d2af9c7740c18a0b769f
  Author: Peter Maydell <address@hidden>
  Date:   2016-07-07 (Thu, 07 Jul 2016)

  Changed paths:
    M hw/display/dpcd.c
    M hw/misc/Makefile.objs
    R hw/misc/aux.c
    A hw/misc/auxbus.c
    M include/hw/display/xlnx_dp.h
    R include/hw/misc/aux.h
    A include/hw/misc/auxbus.h

  Log Message:
  -----------
  aux: Rename aux.[ch] to auxbus.[ch] for the benefit of Windows

On Windows 'aux.*' is a reserved name and cannot be used for
filenames; see
  
https://msdn.microsoft.com/en-gb/library/windows/desktop/aa365247(v=vs.85).aspx

This prevents cloning the QEMU git repo on Windows:

C:\Java\sources\kvm> git clone https://github.com/qemu/qemu.git
Cloning into 'qemu'...
remote: Counting objects: 279563, done.
remote: Total 279563 (delta 0), reused 0 (delta 0), pack-reused 279563R
Receiving objects: 100% (279563/279563), 122.45 MiB | 3.52 MiB/s, done.
Resolving deltas: 100% (221942/221942), done.
Checking connectivity... done.
error: unable to create file hw/misc/aux.c (No such file or directory)
error: unable to create file include/hw/misc/aux.h (No such file or directory)
Checking out files: 100% (4795/4795), done.
fatal: unable to checkout working tree
warning: Clone succeeded, but checkout failed.
You can inspect what was checked out with 'git status'
and retry the checkout with 'git checkout -f HEAD'

(bug https://bugs.launchpad.net/bugs/1595240)

Rename the offending files for the benefit of Windows.

Reported-by: Алексей Курган <address@hidden>
Signed-off-by: Peter Maydell <address@hidden>
Reviewed-by: Eric Blake <address@hidden>
Reviewed-by: Wei Huang <address@hidden>
Tested-by: KONRAD Frederic <address@hidden>
Message-id: address@hidden


  Commit: eef9f19eea26cd8b4553459118f87d7150b53c5a
      
https://github.com/qemu/qemu/commit/eef9f19eea26cd8b4553459118f87d7150b53c5a
  Author: Shannon Zhao <address@hidden>
  Date:   2016-07-07 (Thu, 07 Jul 2016)

  Changed paths:
    M hw/block/m25p80.c

  Log Message:
  -----------
  hw/block/m25p80: fix resource leak

These two are spot by Coverity 1357232 and 1357233.

Signed-off-by: Shannon Zhao <address@hidden>
Message-id: address@hidden
Reviewed-by: Peter Maydell <address@hidden>
Signed-off-by: Peter Maydell <address@hidden>


  Commit: 66542f639927bd1420db38a969d5fa8ad1c89ae1
      
https://github.com/qemu/qemu/commit/66542f639927bd1420db38a969d5fa8ad1c89ae1
  Author: Jean-Christophe Dubois <address@hidden>
  Date:   2016-07-07 (Thu, 07 Jul 2016)

  Changed paths:
    M hw/arm/fsl-imx25.c
    M hw/arm/fsl-imx31.c
    M hw/arm/fsl-imx6.c
    M hw/misc/imx6_ccm.c
    M hw/timer/imx_gpt.c
    M include/hw/misc/imx_ccm.h
    M include/hw/timer/imx_gpt.h

  Log Message:
  -----------
  i.MX: split the GPT timer implementation into per SOC definitions

In various Freescale SOCs, the GPT timers can be configured to select
its input clock.

Depending on the SOC the set of available input clocks may vary.

The actual single GPT definition was no good enough and because of it
booting the sabrelite board with a i.MX6DL device tree would fail
because of an incorrect input clock definition for the i.MX6DL SOC.

This patch fixes the i.MX6DL boot failure by adding the ability to
define a different set of input clocks depending on the considered SOC.

A different class has been defined for i.MX25, i.MX31 and i.MX6 each with
its specific set of input clocks.

The patch has been tested by booting KZM, i.MX25 PDK, i.MX6Q sabrelite
and i.MX6DL sabrelite.

Signed-off-by: Jean-Christophe Dubois <address@hidden>
Message-id: address@hidden
Reviewed-by: Peter Maydell <address@hidden>
[PMM: fixed spacing round '/' operator]
Signed-off-by: Peter Maydell <address@hidden>


  Commit: 4f4a9ca4a4386c137301b3662faba076455ff15a
      
https://github.com/qemu/qemu/commit/4f4a9ca4a4386c137301b3662faba076455ff15a
  Author: Peter Maydell <address@hidden>
  Date:   2016-07-07 (Thu, 07 Jul 2016)

  Changed paths:
    M hw/arm/fsl-imx25.c
    M hw/arm/fsl-imx31.c
    M hw/arm/fsl-imx6.c
    M hw/block/m25p80.c
    M hw/display/dpcd.c
    M hw/display/xlnx_dp.c
    M hw/misc/Makefile.objs
    R hw/misc/aux.c
    A hw/misc/auxbus.c
    M hw/misc/imx6_ccm.c
    M hw/timer/imx_gpt.c
    M include/hw/display/xlnx_dp.h
    R include/hw/misc/aux.h
    A include/hw/misc/auxbus.h
    M include/hw/misc/imx_ccm.h
    M include/hw/timer/imx_gpt.h
    M target-arm/arm-semi.c

  Log Message:
  -----------
  Merge remote-tracking branch 'remotes/pmaydell/tags/pull-target-arm-20160707' 
into staging

target-arm queue:
 * fix a wrong variable type for A64 SYS_HEAPINFO semihosting call
 * xlnx_dp: fix iffy xlnx_dp_aux_push_tx_fifo
 * aux: fix break that wanted to break two levels out
 * aux: Rename aux.[ch] to auxbus.[ch] for the benefit of Windows
 * hw/block/m25p80: fix resource leak
 * i.MX: split the GPT timer implementation into per SOC definitions

# gpg: Signature made Thu 07 Jul 2016 14:48:09 BST
# gpg:                using RSA key 0x3C2525ED14360CDE
# gpg: Good signature from "Peter Maydell <address@hidden>"
# gpg:                 aka "Peter Maydell <address@hidden>"
# gpg:                 aka "Peter Maydell <address@hidden>"
# Primary key fingerprint: E1A5 C593 CD41 9DE2 8E83  15CF 3C25 25ED 1436 0CDE

* remotes/pmaydell/tags/pull-target-arm-20160707:
  i.MX: split the GPT timer implementation into per SOC definitions
  hw/block/m25p80: fix resource leak
  aux: Rename aux.[ch] to auxbus.[ch] for the benefit of Windows
  aux: fix break that wanted to break two levels out
  xlnx_dp: fix iffy xlnx_dp_aux_push_tx_fifo
  target-arm/arm-semi.c: In SYS_HEAPINFO use correct type for 'limit'

Signed-off-by: Peter Maydell <address@hidden>


Compare: https://github.com/qemu/qemu/compare/5563168c530e...4f4a9ca4a438

reply via email to

[Prev in Thread] Current Thread [Next in Thread]