qemu-commits
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-commits] [qemu/qemu] f2c1d5: console: add & use qemu_console_looku


From: GitHub
Subject: [Qemu-commits] [qemu/qemu] f2c1d5: console: add & use qemu_console_lookup_by_device_n...
Date: Tue, 01 Mar 2016 04:30:06 -0800

  Branch: refs/heads/master
  Home:   https://github.com/qemu/qemu
  Commit: f2c1d54c186c400ec676ec4d29ea4b8bf440c054
      
https://github.com/qemu/qemu/commit/f2c1d54c186c400ec676ec4d29ea4b8bf440c054
  Author: Gerd Hoffmann <address@hidden>
  Date:   2016-03-01 (Tue, 01 Mar 2016)

  Changed paths:
    M include/ui/console.h
    M ui/console.c
    M ui/input.c
    M ui/vnc.c

  Log Message:
  -----------
  console: add & use qemu_console_lookup_by_device_name

We have two places needing this, and a third one will come shortly.
So factor things out into a helper function to reduce code duplication.

Signed-off-by: Gerd Hoffmann <address@hidden>
Reviewed-by: Daniel P. Berrange <address@hidden>
Reviewed-by: Markus Armbruster <address@hidden>


  Commit: b98d26e33327cf3009be5ead5d6dc8bc0c65dea8
      
https://github.com/qemu/qemu/commit/b98d26e33327cf3009be5ead5d6dc8bc0c65dea8
  Author: Gerd Hoffmann <address@hidden>
  Date:   2016-03-01 (Tue, 01 Mar 2016)

  Changed paths:
    M qapi-schema.json
    M qmp-commands.hx
    M ui/input.c

  Log Message:
  -----------
  qapi: switch x-input-send-event from console to device+head

Use display device qdev id and head number instead of console index to
specify the QemuConsole.  This makes things consistent with input
devices (for input routing) and vnc server configuration, which both use
display and head too.

Signed-off-by: Gerd Hoffmann <address@hidden>
Reviewed-by: Daniel P. Berrange <address@hidden>
Reviewed-by: Markus Armbruster <address@hidden>


  Commit: f22d0af076b159426c50a7a76ce2a42b8de95b52
      
https://github.com/qemu/qemu/commit/f22d0af076b159426c50a7a76ce2a42b8de95b52
  Author: Gerd Hoffmann <address@hidden>
  Date:   2016-03-01 (Tue, 01 Mar 2016)

  Changed paths:
    M hw/input/hid.c
    M hw/input/ps2.c
    M hw/input/virtio-input-hid.c
    M monitor.c
    M qapi-schema.json
    M qmp-commands.hx
    M scripts/qapi.py
    M ui/cocoa.m
    M ui/gtk.c
    M ui/input-legacy.c
    M ui/sdl.c
    M ui/sdl2.c
    M ui/spice-input.c
    M ui/vnc.c

  Log Message:
  -----------
  qapi: rename input buttons

All lowercase, use-dash instead of CamelCase.

Signed-off-by: Gerd Hoffmann <address@hidden>
Reviewed-by: Daniel P. Berrange <address@hidden>
Reviewed-by: Markus Armbruster <address@hidden>
Reviewed-by: Eric Blake <address@hidden>


  Commit: 01df51432e6d22adcc23ccc989432b53d6bc9126
      
https://github.com/qemu/qemu/commit/01df51432e6d22adcc23ccc989432b53d6bc9126
  Author: Gerd Hoffmann <address@hidden>
  Date:   2016-03-01 (Tue, 01 Mar 2016)

  Changed paths:
    M qapi-schema.json
    M qmp-commands.hx
    M scripts/qapi.py

  Log Message:
  -----------
  qapi: rename InputAxis values.

Lowercase them.

Signed-off-by: Gerd Hoffmann <address@hidden>
Reviewed-by: Daniel P. Berrange <address@hidden>
Reviewed-by: Markus Armbruster <address@hidden>
Reviewed-by: Eric Blake <address@hidden>


  Commit: 6575ccddf4e7c2484bc14b10d5e89f57506c3953
      
https://github.com/qemu/qemu/commit/6575ccddf4e7c2484bc14b10d5e89f57506c3953
  Author: Gerd Hoffmann <address@hidden>
  Date:   2016-03-01 (Tue, 01 Mar 2016)

  Changed paths:
    M qapi-schema.json
    M qmp-commands.hx
    M ui/input.c

  Log Message:
  -----------
  qapi: promote input-send-event to stable

With all fixups being in place now, we can promote input-send-event
to stable abi by removing the x- prefix.

Signed-off-by: Gerd Hoffmann <address@hidden>
Reviewed-by: Markus Armbruster <address@hidden>
Reviewed-by: Eric Blake <address@hidden>


  Commit: 0b85d735831d69ff4ba776e7067ef2e285b234cf
      
https://github.com/qemu/qemu/commit/0b85d735831d69ff4ba776e7067ef2e285b234cf
  Author: Peter Maydell <address@hidden>
  Date:   2016-03-01 (Tue, 01 Mar 2016)

  Changed paths:
    M hw/input/hid.c
    M hw/input/ps2.c
    M hw/input/virtio-input-hid.c
    M include/ui/console.h
    M monitor.c
    M qapi-schema.json
    M qmp-commands.hx
    M scripts/qapi.py
    M ui/cocoa.m
    M ui/console.c
    M ui/gtk.c
    M ui/input-legacy.c
    M ui/input.c
    M ui/sdl.c
    M ui/sdl2.c
    M ui/spice-input.c
    M ui/vnc.c

  Log Message:
  -----------
  Merge remote-tracking branch 'remotes/kraxel/tags/pull-input-20160301-1' into 
staging

qapi: fix input-send-event and promote to stable

# gpg: Signature made Tue 01 Mar 2016 08:19:52 GMT using RSA key ID D3E87138
# gpg: Good signature from "Gerd Hoffmann (work) <address@hidden>"
# gpg:                 aka "Gerd Hoffmann <address@hidden>"
# gpg:                 aka "Gerd Hoffmann (private) <address@hidden>"

* remotes/kraxel/tags/pull-input-20160301-1:
  qapi: promote input-send-event to stable
  qapi: rename InputAxis values.
  qapi: rename input buttons
  qapi: switch x-input-send-event from console to device+head
  console: add & use qemu_console_lookup_by_device_name

Signed-off-by: Peter Maydell <address@hidden>


Compare: https://github.com/qemu/qemu/compare/d9c7737e57d1...0b85d735831d

reply via email to

[Prev in Thread] Current Thread [Next in Thread]