qemu-commits
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-commits] [qemu/qemu] 9e057c: vga: Start cutting out non-32bpp conv


From: GitHub
Subject: [Qemu-commits] [qemu/qemu] 9e057c: vga: Start cutting out non-32bpp conversion suppor...
Date: Thu, 02 Oct 2014 05:30:06 -0700

  Branch: refs/heads/master
  Home:   https://github.com/qemu/qemu
  Commit: 9e057c0b09c3018cd24c7a49995f8b66d5b3d1eb
      
https://github.com/qemu/qemu/commit/9e057c0b09c3018cd24c7a49995f8b66d5b3d1eb
  Author: Benjamin Herrenschmidt <address@hidden>
  Date:   2014-09-30 (Tue, 30 Sep 2014)

  Changed paths:
    M hw/display/vga.c

  Log Message:
  -----------
  vga: Start cutting out non-32bpp conversion support

Nowadays, we either share a surface with the host, or we create
a 32bpp ARGB console surface.

So we only need to draw/convert to 32bpp, enabling us to remove
all but one instance of vga_template.h inclusion (to be further
cleaned up), rgb_to_pixel_* etc...

Signed-off-by: Benjamin Herrenschmidt <address@hidden>
Signed-off-by: Gerd Hoffmann <address@hidden>
Reviewed-by: David Gibson <address@hidden>


  Commit: d2e043a804141ec0a896270d25d6ae370c473ddd
      
https://github.com/qemu/qemu/commit/d2e043a804141ec0a896270d25d6ae370c473ddd
  Author: Benjamin Herrenschmidt <address@hidden>
  Date:   2014-09-30 (Tue, 30 Sep 2014)

  Changed paths:
    M hw/display/vga.c
    M hw/display/vga_template.h

  Log Message:
  -----------
  vga: Remove remainder of old conversion cruft

All the macros used to generate different versions of vga_template.h
are now unnecessary, take them all out and remove the _32 suffix from
most functions.

Signed-off-by: Benjamin Herrenschmidt <address@hidden>
Signed-off-by: Gerd Hoffmann <address@hidden>
Reviewed-by: David Gibson <address@hidden>


  Commit: 46c3a8c8ebe2966cc1f7af12626f89c83d547bfb
      
https://github.com/qemu/qemu/commit/46c3a8c8ebe2966cc1f7af12626f89c83d547bfb
  Author: Benjamin Herrenschmidt <address@hidden>
  Date:   2014-09-30 (Tue, 30 Sep 2014)

  Changed paths:
    M hw/display/vga.c
    M hw/display/vga_template.h

  Log Message:
  -----------
  vga: Separate LE and BE conversion functions

Provide different functions for converting from an LE vs a BE
framebuffer. We cannot rely on the simple cases always being
shared surfaces since cirrus will need to always shadow for
cursor emulation, so we need the full set of functions to
be able to later handle runtime switching.

Signed-off-by: Benjamin Herrenschmidt <address@hidden>\
Signed-off-by: Gerd Hoffmann <address@hidden>
Reviewed-by: David Gibson <address@hidden>


  Commit: d3c2343af09b2e1a568ccac608b8b3d10a36c20c
      
https://github.com/qemu/qemu/commit/d3c2343af09b2e1a568ccac608b8b3d10a36c20c
  Author: Benjamin Herrenschmidt <address@hidden>
  Date:   2014-09-30 (Tue, 30 Sep 2014)

  Changed paths:
    M hw/display/cirrus_vga.c
    M hw/display/vga.c
    M hw/display/vga_int.h

  Log Message:
  -----------
  vga: Remove rgb_to_pixel indirection

We always use rgb_to_pixel32 nowadays.

Signed-off-by: Benjamin Herrenschmidt <address@hidden>
Signed-off-by: Gerd Hoffmann <address@hidden>
Reviewed-by: David Gibson <address@hidden>


  Commit: 2c79f2a2ecba89abe6304ef39c79cb9b3e616bcd
      
https://github.com/qemu/qemu/commit/2c79f2a2ecba89abe6304ef39c79cb9b3e616bcd
  Author: Benjamin Herrenschmidt <address@hidden>
  Date:   2014-09-30 (Tue, 30 Sep 2014)

  Changed paths:
    M hw/display/vga.c

  Log Message:
  -----------
  vga: Simplify vga_draw_blank() a bit

The test for surface_bits_per_pixel() isn't necessary anymore,
the 8bpp case never happens.

Signed-off-by: Benjamin Herrenschmidt <address@hidden>
Signed-off-by: Gerd Hoffmann <address@hidden>
Reviewed-by: David Gibson <address@hidden>


  Commit: 70a041fe2cc26b7a58c17e26f797fbc2c90c535a
      
https://github.com/qemu/qemu/commit/70a041fe2cc26b7a58c17e26f797fbc2c90c535a
  Author: Benjamin Herrenschmidt <address@hidden>
  Date:   2014-09-30 (Tue, 30 Sep 2014)

  Changed paths:
    M hw/display/cirrus_vga.c
    R hw/display/cirrus_vga_template.h

  Log Message:
  -----------
  cirrus: Remove non-32bpp cursor drawing

We only draw cursor on non-shared surfaces (so it seems...) and
these are always 32bpp

Signed-off-by: Benjamin Herrenschmidt <address@hidden>
Signed-off-by: Gerd Hoffmann <address@hidden>
Reviewed-by: David Gibson <address@hidden>


  Commit: ace89b8ff21cc3fb20986a334e54e6e6a1ccf729
      
https://github.com/qemu/qemu/commit/ace89b8ff21cc3fb20986a334e54e6e6a1ccf729
  Author: Benjamin Herrenschmidt <address@hidden>
  Date:   2014-09-30 (Tue, 30 Sep 2014)

  Changed paths:
    M hw/display/vga.c

  Log Message:
  -----------
  vga: Remove some "should be done in BIOS" comments

Not all platforms have a VGA BIOS, powerpc typically relies on
using the DISPI interface to initialize the card.

Signed-off-by: Benjamin Herrenschmidt <address@hidden>
Signed-off-by: Gerd Hoffmann <address@hidden>
Reviewed-by: David Gibson <address@hidden>


  Commit: e657d8ef3c810c4c46d3a61bb76103f77bdb499b
      
https://github.com/qemu/qemu/commit/e657d8ef3c810c4c46d3a61bb76103f77bdb499b
  Author: Benjamin Herrenschmidt <address@hidden>
  Date:   2014-09-30 (Tue, 30 Sep 2014)

  Changed paths:
    A hw/display/vga-helpers.h
    M hw/display/vga.c
    R hw/display/vga_template.h

  Log Message:
  -----------
  vga: Rename vga_template.h to vga-helpers.h

It's no longer a template, we only instanciate the file once.

Keep it a #included file so the functions remain static.

Signed-off-by: Benjamin Herrenschmidt <address@hidden>
Signed-off-by: Gerd Hoffmann <address@hidden>
Reviewed-by: David Gibson <address@hidden>


  Commit: 2c7d8736af209c7e5840c16a9167ad954774ce4c
      
https://github.com/qemu/qemu/commit/2c7d8736af209c7e5840c16a9167ad954774ce4c
  Author: Benjamin Herrenschmidt <address@hidden>
  Date:   2014-09-30 (Tue, 30 Sep 2014)

  Changed paths:
    M hw/display/vga.c
    M hw/display/vga_int.h

  Log Message:
  -----------
  vga: Make fb endian a common state variable

And initialize it based on target endian

Signed-off-by: Benjamin Herrenschmidt <address@hidden>
Signed-off-by: Gerd Hoffmann <address@hidden>
Reviewed-by: David Gibson <address@hidden>


  Commit: c3b10605147f9113b8b157d7226d3e215184bc0e
      
https://github.com/qemu/qemu/commit/c3b10605147f9113b8b157d7226d3e215184bc0e
  Author: Benjamin Herrenschmidt <address@hidden>
  Date:   2014-09-30 (Tue, 30 Sep 2014)

  Changed paths:
    M hw/display/vga.c
    M hw/display/vga_int.h

  Log Message:
  -----------
  vga: Add endian to vmstate

Include the endian state in the migration stream as an optional
subsection which we only include when the endian isn't the default,
thus enabling backward compatibility of the common case.

Signed-off-by: Benjamin Herrenschmidt <address@hidden>

Changes by kraxel:
 * Remove bochs dispi interface changes.  We'll do that in
   a different way to make sure we don't conflict with
   possible future bochs dispi interface changes.
 * keep live migration bits.

Signed-off-by: Gerd Hoffmann <address@hidden>
Reviewed-by: David Gibson <address@hidden>


  Commit: fbcaca994df3d750ab98e61e36195aac07dab741
      
https://github.com/qemu/qemu/commit/fbcaca994df3d750ab98e61e36195aac07dab741
  Author: Peter Maydell <address@hidden>
  Date:   2014-10-02 (Thu, 02 Oct 2014)

  Changed paths:
    M hw/display/cirrus_vga.c
    R hw/display/cirrus_vga_template.h
    A hw/display/vga-helpers.h
    M hw/display/vga.c
    M hw/display/vga_int.h
    R hw/display/vga_template.h

  Log Message:
  -----------
  Merge remote-tracking branch 'remotes/kraxel/tags/pull-vga-20141002-1' into 
staging

vga: cleanups, prepare for endianness switching

# gpg: Signature made Thu 02 Oct 2014 08:10:49 BST using RSA key ID D3E87138
# gpg: Good signature from "Gerd Hoffmann (work) <address@hidden>"
# gpg:                 aka "Gerd Hoffmann <address@hidden>"
# gpg:                 aka "Gerd Hoffmann (private) <address@hidden>"

* remotes/kraxel/tags/pull-vga-20141002-1:
  vga: Add endian to vmstate
  vga: Make fb endian a common state variable
  vga: Rename vga_template.h to vga-helpers.h
  vga: Remove some "should be done in BIOS" comments
  cirrus: Remove non-32bpp cursor drawing
  vga: Simplify vga_draw_blank() a bit
  vga: Remove rgb_to_pixel indirection
  vga: Separate LE and BE conversion functions
  vga: Remove remainder of old conversion cruft
  vga: Start cutting out non-32bpp conversion support

Signed-off-by: Peter Maydell <address@hidden>


Compare: https://github.com/qemu/qemu/compare/1831e150606a...fbcaca994df3

reply via email to

[Prev in Thread] Current Thread [Next in Thread]