qemu-commits
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-commits] [qemu/qemu] 68c0e1: q35: set fw_name


From: GitHub
Subject: [Qemu-commits] [qemu/qemu] 68c0e1: q35: set fw_name
Date: Tue, 04 Jun 2013 08:30:12 -0700

  Branch: refs/heads/master
  Home:   https://github.com/qemu/qemu
  Commit: 68c0e134a090666246b467deaf9046e573b089f2
      
https://github.com/qemu/qemu/commit/68c0e134a090666246b467deaf9046e573b089f2
  Author: Michael S. Tsirkin <address@hidden>
  Date:   2013-05-30 (Thu, 30 May 2013)

  Changed paths:
    M hw/pci-host/q35.c

  Log Message:
  -----------
  q35: set fw_name

PCI host bridges need to set fw_name to be discoverable
by bios for boot device selection.

In particular, seabios expects root device to be called
"/pci/@i0cf8", so let's set it up like that for Q35.

Cc: address@hidden
Signed-off-by: Michael S. Tsirkin <address@hidden>
Tested-by: Amos Kong <address@hidden>


  Commit: cbef02f819b05112cb626a955d8c86e30afe6a9f
      
https://github.com/qemu/qemu/commit/cbef02f819b05112cb626a955d8c86e30afe6a9f
  Author: Michael S. Tsirkin <address@hidden>
  Date:   2013-06-02 (Sun, 02 Jun 2013)

  Changed paths:
    M hw/pci-bridge/Makefile.objs
    A hw/pci-bridge/dec.c
    A hw/pci-bridge/dec.h
    M hw/pci-host/Makefile.objs
    R hw/pci-host/dec.c
    R hw/pci-host/dec.h

  Log Message:
  -----------
  dec.c - move to pci-bridge

Looks like dec.c is in pci-host by mistake.
Moving it over to pci-bridge.

Acked-by: Andreas Färber <address@hidden>
Signed-off-by: Michael S. Tsirkin <address@hidden>


  Commit: ec0503b4f0a37b55fedc164185369bf5f0030f7b
      
https://github.com/qemu/qemu/commit/ec0503b4f0a37b55fedc164185369bf5f0030f7b
  Author: Michael S. Tsirkin <address@hidden>
  Date:   2013-06-02 (Sun, 02 Jun 2013)

  Changed paths:
    M hw/nvram/mac_nvram.c
    M hw/sparc/sun4m.c
    M hw/sparc64/sun4u.c
    A include/hw/nvram/openbios_firmware_abi.h
    R include/hw/sparc/firmware_abi.h

  Log Message:
  -----------
  firmware_abi: move to include/hw/nvram/

firmware_abi.h with structs for OpenBIOS landed in hw/sparc/ by mistake
- move it to hw/nvram/ alongside fw_cfg.h.  In addition to sparc it's
included from ppc mac_nvram.c and will need to include it from prep.c in
the future.

Acked-by: Andreas Färber <address@hidden>
Signed-off-by: Michael S. Tsirkin <address@hidden>


  Commit: edf9735e40841298874ee308fdecca2ac2aa5bdf
      
https://github.com/qemu/qemu/commit/edf9735e40841298874ee308fdecca2ac2aa5bdf
  Author: Michael S. Tsirkin <address@hidden>
  Date:   2013-06-02 (Sun, 02 Jun 2013)

  Changed paths:
    M hw/intc/apic.c

  Log Message:
  -----------
  apic: rename apic specific bitopts

apic has its own version of bitops, with the
difference that it works on u32 and not long.
Add apic_ prefix to avoid namespace clashes.

We should look into reusing standard bitops long-term,
but that's not entirely trivial.

Signed-off-by: Michael S. Tsirkin <address@hidden>


  Commit: a88b362c6ffbb7a802bf0ed5ef0e2447164dc989
      
https://github.com/qemu/qemu/commit/a88b362c6ffbb7a802bf0ed5ef0e2447164dc989
  Author: Laszlo Ersek <address@hidden>
  Date:   2013-06-02 (Sun, 02 Jun 2013)

  Changed paths:
    M hw/acpi/piix4.c
    M hw/core/loader.c
    M hw/i386/multiboot.c
    M hw/i386/multiboot.h
    M hw/i386/pc.c
    M hw/i386/pc_piix.c
    M hw/sparc/sun4m.c
    M hw/sparc64/sun4u.c
    M include/hw/i386/pc.h
    M include/hw/loader.h

  Log Message:
  -----------
  refer to FWCfgState explicitly

Currently some places use pointer-to-void even though they mean
pointer-to-FWCfgState. Clean them up.

Signed-off-by: Laszlo Ersek <address@hidden>
Reviewed-by: Anthony Liguori <address@hidden>
Signed-off-by: Michael S. Tsirkin <address@hidden>


  Commit: 45936c8b79012da4c8986c20af4afcc9cd14bb8e
      
https://github.com/qemu/qemu/commit/45936c8b79012da4c8986c20af4afcc9cd14bb8e
  Author: Michael S. Tsirkin <address@hidden>
  Date:   2013-06-02 (Sun, 02 Jun 2013)

  Changed paths:
    M include/hw/i386/pc.h
    M include/hw/nvram/fw_cfg.h
    M include/qemu/typedefs.h

  Log Message:
  -----------
  fw_cfg: move typedef to qemu/typedefs.h

Less header dependencies this way.

Signed-off-by: Michael S. Tsirkin <address@hidden>


  Commit: 600c60b76d0682f6c39d19bfff79da9321e8cf86
      
https://github.com/qemu/qemu/commit/600c60b76d0682f6c39d19bfff79da9321e8cf86
  Author: Michael S. Tsirkin <address@hidden>
  Date:   2013-06-02 (Sun, 02 Jun 2013)

  Changed paths:
    M hw/misc/pvpanic.c
    M hw/nvram/fw_cfg.c
    M include/hw/nvram/fw_cfg.h

  Log Message:
  -----------
  fw_cfg: add API to find FW cfg object

Remove some code duplication by adding a
function to look up the fw cfg file.
This way, we don't need to duplicate same strings everywhere.
Use by both fw cfg and pvpanic device.

Signed-off-by: Michael S. Tsirkin <address@hidden>


  Commit: cac122103abac633d7b39aac87273bf6d5a37588
      
https://github.com/qemu/qemu/commit/cac122103abac633d7b39aac87273bf6d5a37588
  Author: Michael S. Tsirkin <address@hidden>
  Date:   2013-06-02 (Sun, 02 Jun 2013)

  Changed paths:
    M hw/nvram/fw_cfg.c

  Log Message:
  -----------
  fw_cfg: fw_cfg is a singleton

Make sure we only have a single instance ever:
because if it isn't we can't find it so it's
useless anyway.

Signed-off-by: Michael S. Tsirkin <address@hidden>


  Commit: c3c4fe35be9f6c37388ba7615c6c33e8f4034438
      
https://github.com/qemu/qemu/commit/c3c4fe35be9f6c37388ba7615c6c33e8f4034438
  Author: Michael S. Tsirkin <address@hidden>
  Date:   2013-06-02 (Sun, 02 Jun 2013)

  Changed paths:
    M hw/misc/pvpanic.c

  Log Message:
  -----------
  pvpanic: use FWCfgState explicitly

Use the type-safe FWCfgState structure instead
of the unsafe void *.

Signed-off-by: Michael S. Tsirkin <address@hidden>


  Commit: 8ddd08c5d1415a71f21157686d43f48ff14992b6
      
https://github.com/qemu/qemu/commit/8ddd08c5d1415a71f21157686d43f48ff14992b6
  Author: Stefan Hajnoczi <address@hidden>
  Date:   2013-06-04 (Tue, 04 Jun 2013)

  Changed paths:
    M tests/qemu-iotests/054.out

  Log Message:
  -----------
  qemu-iotests: fix 054 cluster size help output

Commit f3f4d2c09b9cf46903ba38425ec46c44185162bd added a hint to increase
the cluster size when a large image cannot be created.  Test 054 now has
outdated output and fails because the golden output does not match.

This patch updates the 054 golden output.

Signed-off-by: Stefan Hajnoczi <address@hidden>
Signed-off-by: Kevin Wolf <address@hidden>


  Commit: b64ec4e4ade581d662753cdeb0d7e0e27aafbf81
      
https://github.com/qemu/qemu/commit/b64ec4e4ade581d662753cdeb0d7e0e27aafbf81
  Author: Fam Zheng <address@hidden>
  Date:   2013-06-04 (Tue, 04 Jun 2013)

  Changed paths:
    M block.c
    M blockdev.c
    M configure
    M hw/block/xen_disk.c
    M include/block/block.h
    M scripts/create_config

  Log Message:
  -----------
  block: add block driver read only whitelist

We may want to include a driver in the whitelist for read only tasks
such as diagnosing or exporting guest data (with libguestfs as a good
example). This patch introduces a readonly whitelist option, and for
backward compatibility, the old configure option --block-drv-whitelist
is now an alias to rw whitelist.

Drivers in readonly list is only permitted to open file readonly, and
returns -ENOTSUP for RW opening.

E.g. To include vmdk readonly, and others read+write:
    ./configure --target-list=x86_64-softmmu \
          --block-drv-rw-whitelist=qcow2,raw,file,qed \
          --block-drv-ro-whitelist=vmdk

Signed-off-by: Fam Zheng <address@hidden>
Signed-off-by: Kevin Wolf <address@hidden>


  Commit: ecc1c88efddb376687084c3387c38b3a458c5892
      
https://github.com/qemu/qemu/commit/ecc1c88efddb376687084c3387c38b3a458c5892
  Author: Stefan Hajnoczi <address@hidden>
  Date:   2013-06-04 (Tue, 04 Jun 2013)

  Changed paths:
    M tests/qemu-iotests/030
    M tests/qemu-iotests/041
    M tests/qemu-iotests/iotests.py

  Log Message:
  -----------
  qemu-iotests: make assert_no_active_block_jobs() common

Tests 030 and 041 both use query-block-jobs to check whether any block
jobs are active.  Make this code common so that 'drive-backup' and other
new feature tests will be able to reuse it.

Suggested-by: Kevin Wolf <address@hidden>
Signed-off-by: Stefan Hajnoczi <address@hidden>
Signed-off-by: Kevin Wolf <address@hidden>


  Commit: 2575fe16d257a1fb5f452391b868b3c3263a9aca
      
https://github.com/qemu/qemu/commit/2575fe16d257a1fb5f452391b868b3c3263a9aca
  Author: Stefan Hajnoczi <address@hidden>
  Date:   2013-06-04 (Tue, 04 Jun 2013)

  Changed paths:
    M tests/qemu-iotests/030
    M tests/qemu-iotests/041
    M tests/qemu-iotests/iotests.py

  Log Message:
  -----------
  qemu-iotests: make cancel_and_wait() common

The cancel_and_wait() function has been duplicated in 030 and 041.  Move
it into iotests.py and let it return the event so tests can perform
additional asserts.

Note that 041's cancel_and_wait(wait_ready=True) is replaced by
wait_ready_and_cancel(), which uses the new wait_ready() and
cancel_and_wait() underneath.

Suggested-by: Kevin Wolf <address@hidden>
Signed-off-by: Stefan Hajnoczi <address@hidden>
Signed-off-by: Kevin Wolf <address@hidden>


  Commit: 3a3918c396c5caeab35a7f51af905172a13d996a
      
https://github.com/qemu/qemu/commit/3a3918c396c5caeab35a7f51af905172a13d996a
  Author: Stefan Hajnoczi <address@hidden>
  Date:   2013-06-04 (Tue, 04 Jun 2013)

  Changed paths:
    M tests/qemu-iotests/041
    M tests/qemu-iotests/iotests.py

  Log Message:
  -----------
  qemu-iotests: make compare_images() common

The iotests.compare_images() function returns True if two image files
have the identical data.  Previously this was implemented by converting
images to raw and then comparing their contents using Python.  Since
"qemu-img compare" is now available and is more efficient, switch to it.

This function will be reused by the 'drive-backup' test case.

Suggested-by: Kevin Wolf <address@hidden>
Signed-off-by: Stefan Hajnoczi <address@hidden>
Signed-off-by: Kevin Wolf <address@hidden>


  Commit: 2499a096a2427f0a5c71750c9f79cf2d2d2d60f4
      
https://github.com/qemu/qemu/commit/2499a096a2427f0a5c71750c9f79cf2d2d2d60f4
  Author: Stefan Hajnoczi <address@hidden>
  Date:   2013-06-04 (Tue, 04 Jun 2013)

  Changed paths:
    M tests/qemu-iotests/030
    M tests/qemu-iotests/041
    M tests/qemu-iotests/iotests.py

  Log Message:
  -----------
  qemu-iotests: make create_image() common

Both 030 and 041 use create_image().  Move it to iotests.py.

Also drop ImageStreamingTestCase since the class now has no methods.

Suggested-by: Kevin Wolf <address@hidden>
Signed-off-by: Stefan Hajnoczi <address@hidden>
Signed-off-by: Kevin Wolf <address@hidden>


  Commit: 29d782710f87f01991bfc85cd9bef7d15280a5e2
      
https://github.com/qemu/qemu/commit/29d782710f87f01991bfc85cd9bef7d15280a5e2
  Author: Stefan Hajnoczi <address@hidden>
  Date:   2013-06-04 (Tue, 04 Jun 2013)

  Changed paths:
    M block.c
    M include/block/block.h
    M savevm.c

  Log Message:
  -----------
  block: drop bs_snapshots global variable

The bs_snapshots global variable points to the BlockDriverState which
will be used to save vmstate.  This is really a savevm.c concept but was
moved into block.c:bdrv_snapshots() when it became clear that hotplug
could result in a dangling pointer.

While auditing the block layer's global state I came upon bs_snapshots
and realized that a variable is not necessary here.  Simply find the
first BlockDriverState capable of internal snapshots each time this is
needed.

The behavior of bdrv_snapshots() is preserved across hotplug because new
drives are always appended to the bdrv_states list.  This means that
calling the new find_vmstate_bs() function is idempotent - it returns
the same BlockDriverState unless it was hot-unplugged.

Signed-off-by: Stefan Hajnoczi <address@hidden>
Reviewed-by: Eric Blake <address@hidden>
Reviewed-by: Wenchao Xia <address@hidden>
Signed-off-by: Wenchao Xia <address@hidden>
Signed-off-by: Kevin Wolf <address@hidden>


  Commit: de08c606f9ddafe647b6843e2b10a6d6030b0fc0
      
https://github.com/qemu/qemu/commit/de08c606f9ddafe647b6843e2b10a6d6030b0fc0
  Author: Wenchao Xia <address@hidden>
  Date:   2013-06-04 (Tue, 04 Jun 2013)

  Changed paths:
    M block.c
    M block/Makefile.objs
    A block/snapshot.c
    M include/block/block.h
    A include/block/snapshot.h
    M savevm.c

  Log Message:
  -----------
  block: move snapshot code in block.c to block/snapshot.c

All snapshot related code, except bdrv_snapshot_dump() and
bdrv_is_snapshot(), is moved to block/snapshot.c. bdrv_snapshot_dump()
will be moved to another file later. bdrv_is_snapshot() is not related
with internal snapshot. It also fixes small code style errors reported
by check script.

Signed-off-by: Wenchao Xia <address@hidden>
Signed-off-by: Kevin Wolf <address@hidden>


  Commit: f364ec65b56b69c55b674cb6560aa1fbbea9e013
      
https://github.com/qemu/qemu/commit/f364ec65b56b69c55b674cb6560aa1fbbea9e013
  Author: Wenchao Xia <address@hidden>
  Date:   2013-06-04 (Tue, 04 Jun 2013)

  Changed paths:
    M block.c
    M block/Makefile.objs
    A block/qapi.c
    M include/block/block.h
    M include/block/block_int.h
    A include/block/qapi.h
    M qemu-img.c
    M savevm.c

  Log Message:
  -----------
  block: move qmp and info dump related code to block/qapi.c

This patch is a pure code move patch, except following modification:
1 get_human_readable_size() is changed to static function.
2 dump_human_image_info() is renamed to bdrv_image_info_dump().
3 in qmp_query_block() and qmp_query_blockstats, use bdrv_next(bs)
instead of direct traverse of global array 'bdrv_states'.
4 collect_snapshots() and collect_image_info() are renamed, unused parameter
*fmt in collect_image_info() is removed.
5 code style fix.

To avoid conflict and tip better, macro in header file is BLOCK_QAPI_H
instead of QAPI_H. Now block.h and snapshot.h are at the same level in
include path, block_int.h and qapi.h will both include them.

Signed-off-by: Wenchao Xia <address@hidden>
Reviewed-by: Eric Blake <address@hidden>
Signed-off-by: Kevin Wolf <address@hidden>


  Commit: 5b91704469c0f801e0219f26458356872c4145ab
      
https://github.com/qemu/qemu/commit/5b91704469c0f801e0219f26458356872c4145ab
  Author: Wenchao Xia <address@hidden>
  Date:   2013-06-04 (Tue, 04 Jun 2013)

  Changed paths:
    M block/qapi.c
    M include/block/qapi.h
    M qemu-img.c
    M savevm.c

  Log Message:
  -----------
  block: dump snapshot and image info to specified output

bdrv_snapshot_dump() and bdrv_image_info_dump() do not dump to a buffer now,
some internal buffers are still used for format control, which have no
chance to be truncated. As a result, these two functions have no more issue
of truncation, and they can be used by both qemu and qemu-img with correct
parameter specified.

Signed-off-by: Wenchao Xia <address@hidden>
Signed-off-by: Kevin Wolf <address@hidden>


  Commit: e47dccc64b6ca570e4db96fd5fdb3bef251eb559
      
https://github.com/qemu/qemu/commit/e47dccc64b6ca570e4db96fd5fdb3bef251eb559
  Author: Anthony Liguori <address@hidden>
  Date:   2013-06-04 (Tue, 04 Jun 2013)

  Changed paths:
    M hw/acpi/piix4.c
    M hw/core/loader.c
    M hw/i386/multiboot.c
    M hw/i386/multiboot.h
    M hw/i386/pc.c
    M hw/i386/pc_piix.c
    M hw/intc/apic.c
    M hw/misc/pvpanic.c
    M hw/nvram/fw_cfg.c
    M hw/nvram/mac_nvram.c
    M hw/pci-bridge/Makefile.objs
    A hw/pci-bridge/dec.c
    A hw/pci-bridge/dec.h
    M hw/pci-host/Makefile.objs
    R hw/pci-host/dec.c
    R hw/pci-host/dec.h
    M hw/pci-host/q35.c
    M hw/sparc/sun4m.c
    M hw/sparc64/sun4u.c
    M include/hw/i386/pc.h
    M include/hw/loader.h
    M include/hw/nvram/fw_cfg.h
    A include/hw/nvram/openbios_firmware_abi.h
    R include/hw/sparc/firmware_abi.h
    M include/qemu/typedefs.h

  Log Message:
  -----------
  Merge remote-tracking branch 'mst/tags/for_anthony' into staging

pci: misc cleanups

This includes some pci-related cleanups,
and fw cfg cleanups which will be useful for on-going
pci related work.

Signed-off-by: Michael S. Tsirkin <address@hidden>

# gpg: Signature made Sun 02 Jun 2013 02:46:52 PM CDT using RSA key ID D28D5469
# gpg: Can't check signature: public key not found

# By Michael S. Tsirkin (8) and Laszlo Ersek (1)
# Via Michael S. Tsirkin
* mst/tags/for_anthony:
  pvpanic: use FWCfgState explicitly
  fw_cfg: fw_cfg is a singleton
  fw_cfg: add API to find FW cfg object
  fw_cfg: move typedef to qemu/typedefs.h
  refer to FWCfgState explicitly
  apic: rename apic specific bitopts
  firmware_abi: move to include/hw/nvram/
  dec.c - move to pci-bridge
  q35: set fw_name

Message-id: address@hidden
Signed-off-by: Anthony Liguori <address@hidden>


  Commit: a3416197447e7846a927b6ccb4f1edb3a1982443
      
https://github.com/qemu/qemu/commit/a3416197447e7846a927b6ccb4f1edb3a1982443
  Author: Anthony Liguori <address@hidden>
  Date:   2013-06-04 (Tue, 04 Jun 2013)

  Changed paths:
    M block.c
    M block/Makefile.objs
    A block/qapi.c
    A block/snapshot.c
    M blockdev.c
    M configure
    M hw/block/xen_disk.c
    M include/block/block.h
    M include/block/block_int.h
    A include/block/qapi.h
    A include/block/snapshot.h
    M qemu-img.c
    M savevm.c
    M scripts/create_config
    M tests/qemu-iotests/030
    M tests/qemu-iotests/041
    M tests/qemu-iotests/054.out
    M tests/qemu-iotests/iotests.py

  Log Message:
  -----------
  Merge remote-tracking branch 'kwolf/for-anthony' into staging

# By Stefan Hajnoczi (6) and others
# Via Kevin Wolf
* kwolf/for-anthony:
  block: dump snapshot and image info to specified output
  block: move qmp and info dump related code to block/qapi.c
  block: move snapshot code in block.c to block/snapshot.c
  block: drop bs_snapshots global variable
  qemu-iotests: make create_image() common
  qemu-iotests: make compare_images() common
  qemu-iotests: make cancel_and_wait() common
  qemu-iotests: make assert_no_active_block_jobs() common
  block: add block driver read only whitelist
  qemu-iotests: fix 054 cluster size help output

Message-id: address@hidden
Signed-off-by: Anthony Liguori <address@hidden>


Compare: https://github.com/qemu/qemu/compare/171392406d8e...a3416197447e

reply via email to

[Prev in Thread] Current Thread [Next in Thread]