[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[PATCH v3 05/15] acpi/ghes: Fix acpi_ghes_record_errors() argument
From: |
Mauro Carvalho Chehab |
Subject: |
[PATCH v3 05/15] acpi/ghes: Fix acpi_ghes_record_errors() argument |
Date: |
Tue, 12 Nov 2024 11:14:49 +0100 |
Align the header file with the actual implementation of
this function, as the first argument is source ID and not
notification type.
Signed-off-by: Mauro Carvalho Chehab <mchehab+huawei@kernel.org>
Reviewed-by: Jonathan Cameron <Jonathan.Cameron@huawei.com>
Reviewed-by: Igor Mammedov <imammedo@redhat.com>
---
Changes from v8:
- Non-rename/cleanup changes merged altogether;
- source ID is now more generic, defined per guest target.
That should make easier to add support for 86.
Signed-off-by: Mauro Carvalho Chehab <mchehab+huawei@kernel.org>
---
include/hw/acpi/ghes.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/include/hw/acpi/ghes.h b/include/hw/acpi/ghes.h
index 20016c226d1f..50e3a25ea384 100644
--- a/include/hw/acpi/ghes.h
+++ b/include/hw/acpi/ghes.h
@@ -73,7 +73,7 @@ void acpi_build_hest(GArray *table_data, GArray
*hardware_errors,
const char *oem_id, const char *oem_table_id);
void acpi_ghes_add_fw_cfg(AcpiGhesState *vms, FWCfgState *s,
GArray *hardware_errors);
-int acpi_ghes_record_errors(uint8_t notify, uint64_t error_physical_addr);
+int acpi_ghes_record_errors(uint8_t source_id, uint64_t error_physical_addr);
/**
* acpi_ghes_present: Report whether ACPI GHES table is present
--
2.47.0
- [PATCH v3 09/15] acpi/ghes: better name GHES memory error function, (continued)
- [PATCH v3 09/15] acpi/ghes: better name GHES memory error function, Mauro Carvalho Chehab, 2024/11/12
- [PATCH v3 04/15] acpi/ghes: better handle source_id and notification, Mauro Carvalho Chehab, 2024/11/12
- [PATCH v3 12/15] acpi/ghes: better name the offset of the hardware error firmware, Mauro Carvalho Chehab, 2024/11/12
- [PATCH v3 07/15] acpi/ghes: Change the type for source_id, Mauro Carvalho Chehab, 2024/11/12
- [PATCH v3 13/15] acpi/ghes: move offset calculus to a separate function, Mauro Carvalho Chehab, 2024/11/12
- [PATCH v3 03/15] acpi/ghes: simplify the per-arch caller to build HEST table, Mauro Carvalho Chehab, 2024/11/12
- [PATCH v3 08/15] acpi/ghes: make the GHES record generation more generic, Mauro Carvalho Chehab, 2024/11/12
- [PATCH v3 05/15] acpi/ghes: Fix acpi_ghes_record_errors() argument,
Mauro Carvalho Chehab <=
- [PATCH v3 11/15] acpi/ghes: rename etc/hardware_error file macros, Mauro Carvalho Chehab, 2024/11/12
- [PATCH v3 02/15] acpi/ghes: simplify acpi_ghes_record_errors() code, Mauro Carvalho Chehab, 2024/11/12
- [PATCH v3 01/15] acpi/ghes: get rid of ACPI_HEST_SRC_ID_RESERVED, Mauro Carvalho Chehab, 2024/11/12
- [PATCH v3 10/15] acpi/ghes: don't crash QEMU if ghes GED is not found, Mauro Carvalho Chehab, 2024/11/12
- [PATCH v3 14/15] acpi/ghes: Change ghes fill logic to work with only one source, Mauro Carvalho Chehab, 2024/11/12
- [PATCH v3 06/15] acpi/ghes: Remove a duplicated out of bounds check, Mauro Carvalho Chehab, 2024/11/12