[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[PATCH 02/40] pl050: rename pl050_keyboard_init() to pl050_kbd_init()
From: |
Mark Cave-Ayland |
Subject: |
[PATCH 02/40] pl050: rename pl050_keyboard_init() to pl050_kbd_init() |
Date: |
Wed, 29 Jun 2022 13:39:48 +0100 |
This is for consistency with all of the other devices that use the PS2 keyboard
device.
Signed-off-by: Mark Cave-Ayland <mark.cave-ayland@ilande.co.uk>
---
hw/input/pl050.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/hw/input/pl050.c b/hw/input/pl050.c
index c7980b6ed7..8e32b8ed46 100644
--- a/hw/input/pl050.c
+++ b/hw/input/pl050.c
@@ -166,7 +166,7 @@ static void pl050_realize(DeviceState *dev, Error **errp)
qdev_get_gpio_in_named(dev, "ps2-input-irq", 0));
}
-static void pl050_keyboard_init(Object *obj)
+static void pl050_kbd_init(Object *obj)
{
PL050State *s = PL050(obj);
@@ -183,7 +183,7 @@ static void pl050_mouse_init(Object *obj)
static const TypeInfo pl050_kbd_info = {
.name = "pl050_keyboard",
.parent = TYPE_PL050,
- .instance_init = pl050_keyboard_init,
+ .instance_init = pl050_kbd_init,
};
static const TypeInfo pl050_mouse_info = {
--
2.30.2
- [PATCH 00/40] PS2 device QOMification - part 2, Mark Cave-Ayland, 2022/06/29
- [PATCH 01/40] pl050: move PL050State from pl050.c to new pl050.h header file, Mark Cave-Ayland, 2022/06/29
- [PATCH 06/40] pl050: move logic from pl050_realize() to pl050_init(), Mark Cave-Ayland, 2022/06/29
- [PATCH 05/40] pl050: introduce new PL050_MOUSE_DEVICE QOM type, Mark Cave-Ayland, 2022/06/29
- [PATCH 08/40] pl050: introduce pl050_kbd_class_init() and pl050_kbd_realize(), Mark Cave-Ayland, 2022/06/29
- [PATCH 11/40] pl050: don't use legacy ps2_mouse_init() function, Mark Cave-Ayland, 2022/06/29
- [PATCH 03/40] pl050: change PL050State dev pointer from void to PS2State, Mark Cave-Ayland, 2022/06/29
- [PATCH 04/40] pl050: introduce new PL050_KBD_DEVICE QOM type, Mark Cave-Ayland, 2022/06/29
- [PATCH 07/40] pl050: introduce PL050DeviceClass for the PL050 device, Mark Cave-Ayland, 2022/06/29
- [PATCH 02/40] pl050: rename pl050_keyboard_init() to pl050_kbd_init(),
Mark Cave-Ayland <=
- [PATCH 09/40] pl050: introduce pl050_mouse_class_init() and pl050_mouse_realize(), Mark Cave-Ayland, 2022/06/29
- [PATCH 12/40] lasips2: don't use vmstate_register() in lasips2_realize(), Mark Cave-Ayland, 2022/06/29
- [PATCH 13/40] lasips2: remove the qdev base property and the lasips2_properties array, Mark Cave-Ayland, 2022/06/29
- [PATCH 14/40] lasips2: remove legacy lasips2_initfn() function, Mark Cave-Ayland, 2022/06/29
- [PATCH 15/40] lasips2: change LASIPS2State dev pointer from void to PS2State, Mark Cave-Ayland, 2022/06/29
- [PATCH 10/40] pl050: don't use legacy ps2_kbd_init() function, Mark Cave-Ayland, 2022/06/29
- [PATCH 16/40] lasips2: QOMify LASIPS2Port, Mark Cave-Ayland, 2022/06/29
- [PATCH 17/40] lasips2: introduce new LASIPS2_KBD_PORT QOM type, Mark Cave-Ayland, 2022/06/29
- [PATCH 19/40] lasips2: move keyboard port initialisation to new lasips2_kbd_port_init() function, Mark Cave-Ayland, 2022/06/29
- [PATCH 18/40] lasips2: introduce new LASIPS2_MOUSE_PORT QOM type, Mark Cave-Ayland, 2022/06/29