[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[PATCH 4/7] hw/acpi/vmgenid: Make ACPI_VMGENID depends on FW_CFG Kconfig
From: |
Philippe Mathieu-Daudé |
Subject: |
[PATCH 4/7] hw/acpi/vmgenid: Make ACPI_VMGENID depends on FW_CFG Kconfig |
Date: |
Mon, 26 Apr 2021 21:35:17 +0200 |
The TYPE_VMGENID device depends on fw_cfg:
$ git grep \ fw_cfg hw/acpi/vmgenid.c
hw/acpi/vmgenid.c:128: fw_cfg_add_file(s, VMGENID_GUID_FW_CFG_FILE,
guid->data,
hw/acpi/vmgenid.c:131: fw_cfg_add_file_callback(s,
VMGENID_ADDR_FW_CFG_FILE, NULL, NULL, NULL,
Add the proper Kconfig dependency.
Signed-off-by: Philippe Mathieu-Daudé <philmd@redhat.com>
---
hw/acpi/Kconfig | 1 +
1 file changed, 1 insertion(+)
diff --git a/hw/acpi/Kconfig b/hw/acpi/Kconfig
index 1932f66af8d..b9dc932d2a7 100644
--- a/hw/acpi/Kconfig
+++ b/hw/acpi/Kconfig
@@ -40,5 +40,6 @@ config ACPI_VMGENID
bool
default y
depends on PC
+ select FW_CFG
config ACPI_HW_REDUCED
--
2.26.3
- [PATCH 0/7] hw/nvram/fw_cfg: Do not build device if not needed (Spring cleanup), Philippe Mathieu-Daudé, 2021/04/26
- [PATCH 1/7] stubs: Restrict fw_cfg stubs to sysemu, Philippe Mathieu-Daudé, 2021/04/26
- [PATCH 2/7] hw/nvram: Rename FW_CFG_MIPS as generic FW_CFG Kconfig symbol, Philippe Mathieu-Daudé, 2021/04/26
- [PATCH 3/7] hw/nvram: Declare FW_CFG_DMA Kconfig symbol in hw/nvram/, Philippe Mathieu-Daudé, 2021/04/26
- [PATCH 4/7] hw/acpi/vmgenid: Make ACPI_VMGENID depends on FW_CFG Kconfig,
Philippe Mathieu-Daudé <=
- [PATCH 6/7] hw/{arm,hppa,riscv}: Add fw_cfg arch-specific stub, Philippe Mathieu-Daudé, 2021/04/26
- [PATCH 5/7] hw: Have machines Kconfig-select FW_CFG, Philippe Mathieu-Daudé, 2021/04/26