[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [PATCH v4 12/12] exec: Fix overlap of PAGE_ANON and PAGE_TARGET_1
From: |
Nathan Chancellor |
Subject: |
Re: [PATCH v4 12/12] exec: Fix overlap of PAGE_ANON and PAGE_TARGET_1 |
Date: |
Wed, 7 Apr 2021 14:33:37 -0700 |
On Tue, Apr 06, 2021 at 10:40:31AM -0700, Richard Henderson wrote:
> Unfortuately, the elements of PAGE_* were not in numerical
> order and so PAGE_ANON was added to an "unused" bit.
> As an arbitrary choice, move PAGE_TARGET_{1,2} together.
>
> Cc: Laurent Vivier <laurent@vivier.eu>
> Fixes: 26bab757d41b ("linux-user: Introduce PAGE_ANON")
> Buglink: https://bugs.launchpad.net/bugs/1922617
> Signed-off-by: Richard Henderson <richard.henderson@linaro.org>
Tested-by: Nathan Chancellor <nathan@kernel.org>
> ---
> include/exec/cpu-all.h | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/include/exec/cpu-all.h b/include/exec/cpu-all.h
> index d76b0b9e02..32cfb634c6 100644
> --- a/include/exec/cpu-all.h
> +++ b/include/exec/cpu-all.h
> @@ -268,8 +268,8 @@ extern intptr_t qemu_host_page_mask;
> #define PAGE_RESERVED 0x0100
> #endif
> /* Target-specific bits that will be used via page_get_flags(). */
> -#define PAGE_TARGET_1 0x0080
> -#define PAGE_TARGET_2 0x0200
> +#define PAGE_TARGET_1 0x0200
> +#define PAGE_TARGET_2 0x0400
>
> #if defined(CONFIG_USER_ONLY)
> void page_dump(FILE *f);
> --
> 2.25.1
>
>
- [PATCH v4 09/12] target/arm: Rename mte_probe1 to mte_probe, (continued)
- [PATCH v4 09/12] target/arm: Rename mte_probe1 to mte_probe, Richard Henderson, 2021/04/06
- [PATCH v4 11/12] target/arm: Remove log2_esize parameter to gen_mte_checkN, Richard Henderson, 2021/04/06
- [PATCH v4 10/12] target/arm: Simplify sve mte checking, Richard Henderson, 2021/04/06
- [PATCH v4 12/12] exec: Fix overlap of PAGE_ANON and PAGE_TARGET_1, Richard Henderson, 2021/04/06
- Re: [PATCH v4 00/12] target/arm mte fixes, no-reply, 2021/04/06
- Re: [PATCH v4 00/12] target/arm mte fixes, Peter Maydell, 2021/04/08