qemu-arm
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-arm] [PATCH for-4.0 0/2] Rename cpu_physical_memory_write_rom() to


From: Peter Maydell
Subject: [Qemu-arm] [PATCH for-4.0 0/2] Rename cpu_physical_memory_write_rom() to address_space_write_rom()
Date: Thu, 22 Nov 2018 13:35:05 +0000

The API of cpu_physical_memory_write_rom() is odd, because it
takes an AddressSpace, unlike all the other cpu_physical_memory_*
access functions. We note this oddity as a TODO in the
docs/devel/loads-stores.rst documentation.

Rename cpu_physical_memory_write_rom() to address_space_write_rom(),
and give it an API that matches address_space_write().
We also adjest the cpu_physical_memory_write_rom_internal()
function which is local to exec.c similarly.

thanks
-- PMM
    
Peter Maydell (2):
  exec.c: Rename cpu_physical_memory_write_rom_internal()
  Rename cpu_physical_memory_write_rom() to address_space_write_rom()

 include/exec/cpu-common.h   |  2 --
 include/exec/memory.h       | 26 ++++++++++++++++++++++++++
 exec.c                      | 30 +++++++++++++++++++-----------
 hw/core/loader.c            |  4 ++--
 hw/intc/apic.c              |  7 ++++---
 hw/misc/tz-mpc.c            |  2 +-
 hw/sparc/sun4m.c            |  5 +++--
 docs/devel/loads-stores.rst | 35 ++++++++++++++++-------------------
 8 files changed, 71 insertions(+), 40 deletions(-)

-- 
2.19.1




reply via email to

[Prev in Thread] Current Thread [Next in Thread]