[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[Qemu-arm] [PULL v2 15/20] xen: Use the PCI_DEVICE macro
From: |
Laurent Vivier |
Subject: |
[Qemu-arm] [PULL v2 15/20] xen: Use the PCI_DEVICE macro |
Date: |
Tue, 30 Oct 2018 12:23:32 +0100 |
From: Philippe Mathieu-Daudé <address@hidden>
TYPE_XEN_PT_DEVICE is a subclass of TYPE_PCI_DEVICE, the clean way
to access the PCIDevice pointer is using the PCI_DEVICE() macro.
Suggested-by: Peter Maydell <address@hidden>
Signed-off-by: Philippe Mathieu-Daudé <address@hidden>
Reviewed-by: Markus Armbruster <address@hidden>
Acked-by: Anthony PERARD <address@hidden>
Acked-by: Michael S. Tsirkin <address@hidden>
Message-Id: <address@hidden>
Signed-off-by: Laurent Vivier <address@hidden>
---
hw/xen/xen_pt_config_init.c | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/hw/xen/xen_pt_config_init.c b/hw/xen/xen_pt_config_init.c
index aee31c62bb..47f9010c75 100644
--- a/hw/xen/xen_pt_config_init.c
+++ b/hw/xen/xen_pt_config_init.c
@@ -358,7 +358,7 @@ static uint64_t xen_pt_get_bar_size(PCIIORegion *r)
static XenPTBarFlag xen_pt_bar_reg_parse(XenPCIPassthroughState *s,
int index)
{
- PCIDevice *d = &s->dev;
+ PCIDevice *d = PCI_DEVICE(s);
XenPTRegion *region = NULL;
PCIIORegion *r;
@@ -469,7 +469,7 @@ static int xen_pt_bar_reg_write(XenPCIPassthroughState *s,
XenPTReg *cfg_entry,
{
XenPTRegInfo *reg = cfg_entry->reg;
XenPTRegion *base = NULL;
- PCIDevice *d = &s->dev;
+ PCIDevice *d = PCI_DEVICE(s);
const PCIIORegion *r;
uint32_t writable_mask = 0;
uint32_t bar_emu_mask = 0;
@@ -543,7 +543,7 @@ static int
xen_pt_exp_rom_bar_reg_write(XenPCIPassthroughState *s,
{
XenPTRegInfo *reg = cfg_entry->reg;
XenPTRegion *base = NULL;
- PCIDevice *d = (PCIDevice *)&s->dev;
+ PCIDevice *d = PCI_DEVICE(s);
uint32_t writable_mask = 0;
uint32_t throughable_mask = get_throughable_mask(s, reg, valid_mask);
pcibus_t r_size = 0;
@@ -1587,7 +1587,7 @@ static int xen_pt_pcie_size_init(XenPCIPassthroughState
*s,
const XenPTRegGroupInfo *grp_reg,
uint32_t base_offset, uint8_t *size)
{
- PCIDevice *d = &s->dev;
+ PCIDevice *d = PCI_DEVICE(s);
uint8_t version = get_capability_version(s, base_offset);
uint8_t type = get_device_type(s, base_offset);
uint8_t pcie_size = 0;
--
2.17.2
- [Qemu-arm] [PULL v2 05/20] qemu-iotests: fix filename containing checks, (continued)
- [Qemu-arm] [PULL v2 05/20] qemu-iotests: fix filename containing checks, Laurent Vivier, 2018/10/30
- [Qemu-arm] [PULL v2 10/20] linux-user: fix comment s/atomic_write/atomic_set/, Laurent Vivier, 2018/10/30
- [Qemu-arm] [PULL v2 14/20] qobject: Catch another straggler for use of qdict_put_str(), Laurent Vivier, 2018/10/30
- [Qemu-arm] [PULL v2 03/20] memory.h: fix typos in comments, Laurent Vivier, 2018/10/30
- [Qemu-arm] [PULL v2 18/20] hw/intc/gicv3: Remove useless parenthesis around DIV_ROUND_UP macro, Laurent Vivier, 2018/10/30
- [Qemu-arm] [PULL v2 04/20] tests/tcg/README: fix location for lm32 tests, Laurent Vivier, 2018/10/30
- [Qemu-arm] [PULL v2 16/20] tests/bios-tables-test: Remove an useless cast, Laurent Vivier, 2018/10/30
- [Qemu-arm] [PULL v2 13/20] configure: Support pkg-config for zlib, Laurent Vivier, 2018/10/30
- [Qemu-arm] [PULL v2 17/20] hw/pci-host: Remove useless parenthesis around DIV_ROUND_UP macro, Laurent Vivier, 2018/10/30
- [Qemu-arm] [PULL v2 20/20] milkymist-minimac2: Use qemu_log_mask(GUEST_ERROR) instead of error_report, Laurent Vivier, 2018/10/30
- [Qemu-arm] [PULL v2 15/20] xen: Use the PCI_DEVICE macro,
Laurent Vivier <=
- [Qemu-arm] [PULL v2 12/20] tests: Fix typos in comments and help message (found by codespell), Laurent Vivier, 2018/10/30
- Re: [Qemu-arm] [PULL v2 00/20] Qemu trivial for 3.1 patches, Peter Maydell, 2018/10/30