[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [Qemu-arm] [Qemu-devel] [PATCH v6 3/4] kvm: add kvm_support_device()
From: |
Peter Xu |
Subject: |
Re: [Qemu-arm] [Qemu-devel] [PATCH v6 3/4] kvm: add kvm_support_device() helper function |
Date: |
Wed, 23 Mar 2016 22:56:52 +0800 |
User-agent: |
Mutt/1.5.24 (2015-08-30) |
On Wed, Mar 23, 2016 at 03:28:28PM +0300, Sergey Fedorov wrote:
> On 23/03/16 08:32, Peter Xu wrote:
> > diff --git a/include/sysemu/kvm.h b/include/sysemu/kvm.h
> > index 6695fa7..8738fa1 100644
> > --- a/include/sysemu/kvm.h
> > +++ b/include/sysemu/kvm.h
> > @@ -306,6 +306,15 @@ void kvm_device_access(int fd, int group, uint64_t
> > attr,
> > */
> > int kvm_create_device(KVMState *s, uint64_t type, bool test);
> >
> > +/**
> > + * kvm_support_device - probe whether KVM support specific device
> > + *
> > + * @vmfd: The fd handler for VM
> > + * @type: type of device
> > + *
> > + * @return: true if supported, otherwise false.
> > + */
> > +bool kvm_support_device(int vmfd, uint64_t type);
>
> Why don't name the function like 'kvm_device_supported' to better express its
> predicative nature?
Because I am trying to follow existing naming style, like:
"kvm_create_device" (please see above).
Thanks.
-- peterx
[Qemu-arm] [PATCH v6 4/4] arm: implement query-gic-capabilities, Peter Xu, 2016/03/23
Re: [Qemu-arm] [PATCH v6 0/4] ARM: add query-gic-capabilities SMP command, Peter Xu, 2016/03/23
Re: [Qemu-arm] [PATCH v6 0/4] ARM: add query-gic-capabilities SMP command, Andrea Bolognani, 2016/03/23
Re: [Qemu-arm] [Qemu-devel] [PATCH v6 0/4] ARM: add query-gic-capabilities SMP command, Christoffer Dall, 2016/03/23