pyatcron-devel-list
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: Comments on the diagram (was:RE:[Pyatcron-devel-list]Cronbackend: a


From: NICOLOVICI Xavier
Subject: RE: Comments on the diagram (was:RE:[Pyatcron-devel-list]Cronbackend: a correction)
Date: Wed, 19 Nov 2003 09:10:52 +0100

Brian,
 
About the getCommand of the CronEntry and AtEntry class. I think that they must be renamed to getRegisterString.
 
This function should return a string used to register the task. For the CronEntry, the getRegisterString will return:
"* * * * * /the/command/to/run -its -parameters"
 
This first fileds will be build with the Schedule fields and the command to run will be build with the GenericTask pointed by the Schedule object.
 
Does this makes things a bit clear to you?
 
Now, I'm currently thinking about a CronEntryCollector and an AtEntryCollector who will be in charge of parsing the existing cron and at entries (ie retrieve the definitions from system), manage list of CronEntry and AtEntry (addition and deletion of some), export those list to a GtkList, and rebuild the system cron and at entries.
 
The process flow will then be as follow:
1. Create CronEntryCollector
2. CronEntryCollector.parseUserCrontab(<username>)
3. Build a list of CronEntry with their associated Task
4. Export the list to the GUI and let user make some modifications
5. When user exit or apply changes, call CronEntryCollector.applyChanges()
 
The same will be done for the AtEntry with AtEntryCollector.
 
Any comments?
 
Xavier
-----Message d'origine-----
De : address@hidden [mailto:address@hiddenDe la part de Brian Dee
Envoyé : mardi, 18. novembre 2003 19:15
À : pyatcron-devel
Objet : RE: Comments on the diagram (was:RE:[Pyatcron-devel-list]Cronbackend: a correction)

Just a question about the diagram. The Scheduler, GenericTask, CronEntry, and AtEntry classes all have a geCommand() method, but none has the actual Command variable to 'get'. Where is that supposed to be? And what about setCommand()?
This e-mail contains proprietary information some or all of which may be legally privileged. It is intended for the recipient only. If an addressing or a transmission error has misdirected this e-mail, please notify the author by replying to the e-mail. If you are not the intended recipient you must not use, disclose, distribute, copy, print, or rely on this e-mail.
We take reasonable precautions to ensure our e-mails are virus free. However, we cannot accept responsibility for any virus transmitted by us and recommend that you subject any incoming e-mail to your own virus checking procedures.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]