[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Phpgroupware-users] Revisiting a installation problem...

From: Stephen N. Stremmel
Subject: Re: [Phpgroupware-users] Revisiting a installation problem...
Date: Tue, 19 Nov 2002 08:30:00 -0600
User-agent: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.1b) Gecko/20020722

Chris Weiss wrote:
is register_globals on in your php.ini?

Yes, register_globals is on for this. I have it set in the httpd.conf, and confirmed by phpinfo() in the phpgroupware directory. And of course, I accidentally deleted the directory that had my manually modified phpgroupware files in it, so I have to try to do it again. I want to say that I only modified a few files in the /phpgroupware/setup/ directory, and that got me to the first page, and thats where it stopped. I would REALLY love it if I could do the setup like its supposed to do. It just seems to be a path problem more than anything else. Like I said, once I dumped the relative paths it got to the first page, although I suppose that it could be a php of apache config problem.

Stephen N. Stremmel (address@hidden) wrote*:

Today we will revisit a problem that seems to affect a few people. After
posting this I ran across several emails in this group and the bugs
group pertaining to this problem, but no resolutions. Below is my
original email:

---Original Email - Sent 05 Nov 2002---
   I have looked through the the archives and have not found the
answer to my problem. Some were close, but they related to the RPM
installation, and not the tarball install.

RH 7.1
PhpGroupware- tarball


When I go to 'http://servername/phpgroupware/setup/', I get this error:

Template Error: filename: file ../setup/templates/default/head.tpl does
not exist.
Fatal error: Call to a member function on a non-object in
/www/html/phpgroupware/phpgwapi/inc/ on line 440
~~~~~ - Line 440:

I untarred the tarball in my DocRoot, changed the 'files' dir to the web
server owner/group and chmod'd the 'files' to 700 (like in the docs). I
then added a db to mysql, and created an owner/password for that new db
(No Privileges). After the first time that setup didn't work, I chown'd
the whole 'phpgroupware' dir to the server owner/group, but to no avail.
Both files exist. Do I need to tweak my PHP? I tried Register_Globals
'On' and 'Off', with no change in error.

Any suggestions???

--End Original Email--

Since then I tried to update to the current version via CVS with no
help. I tried with chmod -R 777 phpgroupware, again to no avail. The
file (phpgroupware/setup/templates/default/head.tpl) exists, and I can
open it in my browser window. Hmmm...
I tried to setup everything manually, but I ran into a problem. I read
about some problems using relative paths (../setup/templates), so I
figured that I would try to change them all into absolute paths. I was
able to go through many of the files under 'setup/' and change the
'../setup/' to an absolute path. After that, I was able to get it to
show the first page of the setup script where you do the header
passwords, etc (which were already filled in), and I was able to save
the file, but when I hit continue, it just loops around to the same page
again. I would LOVE to use this, but it is driving me nuts. My html/php
skills are ok, but I can't seem to figure out where to go after the
continue button. If I knew maybe I could try to manually configure the
entire thing.
So, can someone either point me in the right direction to fix it, tell
me WHAT to fix, or give me a roadmap to the installation (ie.
manageheader.php, then the continue button calls ????.php, then that
calls ???, etc...) so that I can try to manually configure it.
Shoot, maybe it has been fixed in CVS and I just didn't do the CVS part

Thank You,
Stephen N. Stremmel
Baylor College of Medicine              Voice: (713)798-5666    
Sr. Systems Administrator               Email: address@hidden

/Give a man a fire,
/and he'll be warm for a night.
/Set a man on fire,
/And he'll be warm the rest of his life.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]