[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Phpgroupware-users] problem getting phpwebhosting to work properly

From: Dave Hall
Subject: Re: [Phpgroupware-users] problem getting phpwebhosting to work properly
Date: Sat, 26 Oct 2002 22:30:37 +1000

SI Reasoning <address@hidden> wrote:

> I worked with Dave on IRC and made some progress but also ran 
> across some 
> issues:
> it requires a specific domain name created in configuration setup.
> This resolved the problem I mentioned here (although there are 
> still many 
> problems we have not resolved yet...later in this email...)
> Having to choose a domain name causes us some problems here. If we 
> choose the 
> domain name of the local server it works fine on the local lan but 
> refuses 
> entry remotely (where we have a firewall/nat setup with port 80 
> forwarded).If we use the internet ip address, then it will not 
> work locally (some 
> weirdness when a local computer is sent through the nat, and then 
> back into 
> the nat and then forwarded. It doesn't work in many situations, 
> including 
> this one.

I was thinking about this a bit more.  Have you tried running the server
on another port? like 8080 or 8008??  Secondly do you have allow direct
access if availble ticked on in phpwebhosting??

> other issues:
> we tried going to manage apps and uninstall/reinstall but it did 
> not fix the 
> following issues:

This was a suggestion of mine to try to clean out the data in the
phpgw_vfs table. 

> At one time I had deleted the /home/user1 directory, however phpwh 
> did not 
> acknowledge that deletion. This meant that everytime (even after 
> uninstall/install) it kept defaulting back to the original (and 
> now ddeleted) 
> directory. I had to recreate it and it worked fine.

Another idea would be to try the following:

2 Run this DELETE FROM phpgw_vfs WHERE app = 'phpwebhosting';
3 Delete all the directories in /path/to/phpgw/files/home
4 login again

If it fails ... you wasted 5 mins and just restore your db ... if not
problem solved.  This should also recreate the home/groupname dirs for
you too.

> The groups that I created previously are not seen in the new file 
> manager, 
> even when the groupd directories are moved to /home. I am a 
> memeber of all of 
> the groups, and we even reset the acls in admin>user groups so 
> that each 
> group is fully acceptable to the group. No difference.

The groups won't be auto ported afaik.  Once the dirs are created
automagically, cp the old files/group dirs over.  The run update within
phpwh for each dir.

> all files and directories within phpgroupware were changed to 
> apache:apache 
> and 770

once doing the moves double check that

> The biggest issue is the first one. It force me to choose either 
> remote access 
> or local access. When I had previously left the url section of the 
> admin 
> configuration blank, it had worked fine with everything else. 
> Maybe one could 
> either allow for several internet address choices for the url 
> section or 
> phpwh could be fixed to work with the ip address used like all of 
> the other 
> programs.

I think if all or the majority of the core apps allow this behaviour
then this should be logged as a bug on savannah (on the bug manager, not
the support manager :) ).  I will try to investigate it further, but
phpwh is really zone's forte.

> After that the next big issue is getting group access to files 
> uploaded, etc.

Yes see above ... once phpwh creates the dirs you can copy them manually.

btw i am sorry i couldn't stick around earlier ... coming to the end of
semester for uni ... lots on.

Keep us posted on your progress.


Dave Hall (aka skwashd)

> On Saturday 26 October 2002 1:41 am, Chris Weiss wrote:
> > view source and look for "<form action=" (about 2/3 the way 
> down).  the
> > line should contine with someting like
> > "/phpGroupWare//phpwebhosting/index.php?path=L2hvbWU..."
> >
> > SI Reasoning (address@hidden) wrote*:
> > >Hash: SHA1
> > >
> > >I have been using phpgroupware for quite a while, but I have 
> not been able
> > > to get phpwebhosting to work properly. The server is Mandrake 
> 8.2 fully
> > > upgraded.
> > >
> > >The problem is that if I click on any of the buttons in 
> phpwebhosting> > (even edit comments), then I get sent to google 
> (where it searches the
> > > name phpgroupware) and the url in my browser is 
> keyword:phpgroupware> >
> > >any ideas?

Attachment: dave.hall.vcf
Description: Card for <>

reply via email to

[Prev in Thread] Current Thread [Next in Thread]