[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Paparazzi-devel] Re: Cannot read messages from ap

From: Aniket Aranake
Subject: [Paparazzi-devel] Re: Cannot read messages from ap
Date: Tue, 15 Jul 2008 12:01:06 -0400

Mohammad and Gautier,

Thank you very much for your responses. The solution that worked for me follows:

First I created a new session, identical to address@hidden except with a Baudrate of 9600. This allowed me to connect to receive alive messages.

I then followed the instructions on the wiki ( to increase the Baudrate of the airborne modem and autopilot to 57600. Using a serial terminal I also changed the ground station modem's Baudrate to match.

The only gotcha is the networking/security protocol on Xbee modems. (Digi 9XTend, page 44) I found a quick way to get things to work was to send the command ATMK0 to both modems, which puts them in "sniffer mode" so that they accept packets without discrimination. This isn't a good idea for an airborne plane, but hopefully this post will help somebody else diagnose their downlink.

Thanks again,

On Sun, Jul 13, 2008 at 8:21 AM, Mohammad Ali Haji Pour <address@hidden> wrote:

I had the same problem. All I did was changing the Maxstream frequency in config file to 9600, and creating a new session  in paparazzi center just like the existing Maxstream one but changing the 57600 to 9600.



----- Original Message -----
From: Aniket Aranake <address@hidden>
Date: Sunday, July 13, 2008 2:58 am
Subject: [Paparazzi-devel] Cannot read messages from ap
To: address@hidden

> Hello all,
> I am trying to read messages transmitted by the autopilot. I have been
> able
> to get demo4 to work, which transmits the cpu_time using
> DOWNLINK_SEND_TAKEOFF by using the following procedure:
>    1. Connect the autopilot to /dev/ttyUSB0 (I use UART1)
>    2. In one terminal, run the program sw/ground_segment/tmtc/link
>    3. In a second terminal, run the program ivyprobe '(.*)'
>    4. Open the device /dev/ttyUSB0 in a serial terminal, I use a program
>    called cutecom for this purpose.
> By doing this, I can read the cpu_time in the terminal running
> ivyprobe. My
> problem is that this does not work with a full autopilot flashed onto
> the
> board, in my case funjet1. No messages appear in ivyprobe, although huge
> amounts of hex data is showing up in the serial terminal. I have tried
> this
> with and without maxstream serial modems, configuring everything to 9600
> BAUD. Additionally, when I try to run the "Flight address@hidden BAUD"
> session, the GCS is completely blank; the aircraft does not appear on
> the
> main panel and no controls/info appear in the botom.
> Any help would be greatly appreciated. Thanks!
> Aniket
> _______________________________________________
> Paparazzi-devel mailing list
> address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]