[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[monit] monit start up script

From: Abdellah Tantan
Subject: [monit] monit start up script
Date: Fri, 20 Mar 2009 13:51:39 -0500



We were trying to install monit as our Linux monitoring tool, however; after many reinstallation attempts we could not’t get monit to start from init at boot-time, matter fact these two file never do not seem to exist /etc/monit and /etc/default/monit in any of the installations. We tried monit 4.10 and monit 5.0 beta_7 complied packages with the same result.


We are not sure if this is related to the OS, we are using (SUSE Linux Enterprise Server 10 - Linux #1 SMP Fri Jan 16 14:59:01 UTC 2009 i686 i686 i386 GNU/Linux).


These are the installation steps we followed.


$ tar zxvf monit-x.y.z.tar.gz (were x.y.z denotes version numbers)

$ cd monit-x.y.z

$ ./configure (use ./configure --help to view available options)

$ make && make install.


I am not sure if we need to pass an argument to. /configre that would get the desire installation.


To give you an idea about our installation the command

find / -name monit gives the following ouput





All monit files are under $/opt/monit-5.0_beta7/



We also tried to install  monit-4.10.1-40.1.i586.rpm with no luck.

$ rpm -ivh monit-4.10.1-40.1.i586.rpm

$ error: Failed dependencies:

$ rpmlib(PayloadIsLzma) <= 4.4.2-1 is needed by monit-4.10.1-40.1.i586

This error is common when you tried to install rpms that are not 100% compatible with the OS version


Monit is working fine; we just want to be able to have it starts automatically at boot time.

Any ideas what we might be doing wrong?


Thanks a lot


PAYDQ services

Abdellah Tantan

System Admin





reply via email to

[Prev in Thread] Current Thread [Next in Thread]