[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Lyxblogger-users] LyxBlogger Installation Issue

From: Jack Desert
Subject: Re: [Lyxblogger-users] LyxBlogger Installation Issue
Date: Sat, 19 Jan 2013 16:05:24 -0800

Hi Paschall,

Sometimes LyX does not pick up the LyXBlogger converter, even when LyXBlogger is correctly installed.

I suggest you first verify your LyXBlogger installation by running LyXBlogger from the command line. If that works fine, it will tell me that LyX 2.0.5 on Windows is not picking up the LyXBlogger converter properly, and you would have to set up the converter manually.

Let me know how that goes.


On Sat, Jan 19, 2013 at 12:10 PM, Paschall Baker <address@hidden> wrote:

No luck. After completely uninstalling Lyx 2.05 (removing all user files) and reinstalling, then reinstalling Lyxblogger, I do not see the converter listed in Lyx after reconfiguration. Import socket threw no error, so Python is fine. I have not attempted to run Lyxblogger from the command line. Since you mention that a correct install should show up in the Converters section, I am assuming that something went wrong. I'd love to be able to use this, but I guess I'm stuck with simple HTML or XHTML, both of which work fine.


If you have any suggestions, I'll try them out.


Thank you.




From: Jack Desert [mailto:address@hidden]
Sent: Saturday, January 19, 2013 1:40 AM
To: Paschall Baker

Subject: Re: LyxBlogger Installation Issue


Best of luck. Like I said, if you start LyX from command line you'll be able to see what errors it's throwing.


On Fri, Jan 18, 2013 at 8:07 PM, Paschall Baker <address@hidden> wrote:

Yes. I caught that before you wrote back. I installed correctly and followed your instructions about setting up in Lyx 2.0. But it still freezes when attempting to export into Lyxblogger. I uninstalled Lyx and reinstalled, starting from scratch. Am going to go through everything again tomorrow or Sunday and will let you know how it fares.


Thank you for writing back so soon. I’d love to see what your programming can do. Many thanks.




From: Jack Desert [mailto:address@hidden]
Sent: Friday, January 18, 2013 10:31 PM
To: Paschall Baker; address@hidden
Subject: Re: LyxBlogger Installation Issue


HI Paschall,

Nice to see another LyXBlogger user out there..

the first thing I notice is that you are calling


where you should be calling

  > python install

So try that first. When I run this on my machine (linux), I get output like this:

address@hidden:~/downloads/LyXBlogger_0.42/INSTALL$sudo python install
[sudo] password for jd:
running install
running build
running build_py
running install_lib
running install_egg_info
Removing /usr/local/lib/python2.7/dist-packages/LyXBlogger-0.0.0.egg-info
Writing /usr/local/lib/python2.7/dist-packages/LyXBlogger-0.0.0.egg-info

so it says it's installing into the /usr/local/lib/python2.7/dist-packages/LyXBlogger-0.0.0.egg-info directory. I expect that on windows it should also tell you where it's installing.

Hopefully that will take care of it. Once installed, you can call LyXBlogger from the command line, like so:

  python -m lyxblogger <input_file>

Once you have LyXBlogger running from command line, then try it with LyX. (You can even start LyX from command line and then any errors thrown will show up in the console)

Let me know how that goes.




On Fri, Jan 18, 2013 at 4:44 PM, Paschall Baker <address@hidden> wrote:

I have tried unsuccessfully four times to install the Lyxblogger. I received
no error when testing Python, as directed. When I attempt to install the
"setup-no-elyxer", I receive the following in the window:


Traceback (most recent call last):
  File "C:\Downloads\LyXBlogger_0.41\INSTALL\", line 29,
in <m
    from distutils.core import setup
  File "C:\Program Files (x86)\LyX 2.0\Python\lib\distutils\", line
20, i
n <module>
    from distutils.dist import Distribution
  File "C:\Program Files (x86)\LyX 2.0\Python\lib\distutils\", line
10, i
n <module>
    from email import message_from_file
ImportError: No module named email



When I attempt to blog a small paragraph, Lyx posts a message at the bottom
of the window, but nothing is produced and Lyx hangs.

Also, where are the files placed when LyXBlogger installed. You make no
mention of how to test for a successful installation.

Please let me know if you need more information.

Thank you for any help you can provide.




reply via email to

[Prev in Thread] Current Thread [Next in Thread]