[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[lwip-devel] [patch #9331] PPP: ppp_singlebuf: Use pbuf_coalesce() inste
From: |
Sylvain Rochet |
Subject: |
[lwip-devel] [patch #9331] PPP: ppp_singlebuf: Use pbuf_coalesce() instead of open-coded |
Date: |
Fri, 5 May 2017 08:59:44 -0400 (EDT) |
User-agent: |
Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0 |
Follow-up Comment #2, patch #9331 (project lwip):
There is indeed a confusion between a chain of pbuf and a queue of pbuf. A
chain of pbuf is one packet, and a queue is multiple packets, each of them
composed with multiple pbufs. From what I observed packet queues were never
implemented in lwIP and we only have single packets. Therefore p->next == NULL
works as well as p->len == p->tot_len, but from the pbuf documentation, p->len
== p->tot_len looks like more right because in this case we only coalesce the
first packet and following packets are dropped, while p->next == NULL is false
in case of a packets queues.
Maybe we should just consider that packets queues will never materialize, so
p->len == p->tot_len and p->next == NULL are exactly the same.
Sylvain
_______________________________________________________
Reply to this item at:
<http://savannah.nongnu.org/patch/?9331>
_______________________________________________
Message sent via/by Savannah
http://savannah.nongnu.org/