[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Linphone-users] Application crash on OS X 10.15.7 Ver 4.3.2, also tried

From: Christopher Story
Subject: [Linphone-users] Application crash on OS X 10.15.7 Ver 4.3.2, also tried with latest daily build Linphone-4.4.0-alpha.79+be439824-mac
Date: Mon, 3 Jan 2022 13:46:18 -0600

Im getting a crash on the Linphone app for OSX, this happens immediately after it starts..  Here are some messages from the command line when trying the daily build...

I also deleted the entire linphone directory in application support/linphone and its prefs and it still crashes..  Im not seeing anything in the logs of linphone in application support at all (zero bytes)..  

I do have the apple crash report, not sure if you need that..  its showing a "Graphics kernel error: 0xfffffffb"

I have Qt 5.15.2 dev system installed for another project im working on, but i dont think this is trying to load those libs.

% ./linphone

QML debugging is enabled. Only use this in a safe environment.

An OpenGL surfcace format was requested that is either not version 3.2 or higher or a not Core Profile.

Chromium on macOS will fall back to software rendering in this case.

Hardware acceleration and features such as WebGL will not be available.

QProcess: Destroyed while process ("whoami") is still running.

2022-01-03 13:28:27:149 bctbx-error-bctbx_file_open: Error open No such file or directory

[13:28:42:176][0x7fe701d1a140][Info]"Starting Linphone (bin: linphone)"

[13:28:42:176][0x7fe701d1a140][Info]"Use locale: en_US"

[13:28:42:310][0x7fe701d1a140][Info]Available fonts :  (".AppleSystemUIFont", ".SF NS Mono", "Al Bayan", "Al Nile", "Al Tarikh", "American Typewriter", "Andale Mono", "Apple Braille", "Apple Chancery", "Apple Color Emoji", "Apple SD Gothic Neo", "Apple Symbols", "AppleGothic", "AppleMyungjo", "Arial", "Arial Black", "Arial Hebrew", "Arial Hebrew Scholar", "Arial Narrow", "Arial Rounded MT Bold", "Arial Unicode MS", "Avenir", "Avenir Next", "Avenir Next Condensed", "Ayuthaya", "Baghdad", "Bangla MN", "Bangla Sangam MN", "Baskerville", "Beirut", "Big Caslon", "Bodoni 72", "Bodoni 72 Oldstyle", "Bodoni 72 Smallcaps", "Bodoni Ornaments", "Bradley Hand", "Brush Script MT", "Chalkboard", "Chalkboard SE", "Chalkduster", "Charter", "Cochin", "Comic Sans MS", "Copperplate", "Corsiva Hebrew", "Courier", "Courier New", "Damascus", "DecoType Naskh", "Devanagari MT", "Devanagari Sangam MN", "Didot", "DIN Alternate", "DIN Condensed", "Diwan Kufi", "Diwan Thuluth", "Euphemia UCAS", "Farah", "Farisi", "Futura", "Galvji", "GB18030 Bitmap", "Geeza Pro", "Geneva", "Georgia", "Gill Sans", "Gujarati MT", "Gujarati Sangam MN", "Gurmukhi MN", "Gurmukhi MT", "Gurmukhi Sangam MN", "Heiti SC", "Heiti TC", "Helvetica", "Helvetica Neue", "Herculanum", "Hiragino Maru Gothic ProN", "Hiragino Mincho ProN", "Hiragino Sans", "Hiragino Sans GB", "Hoefler Text", "Impact", "InaiMathi", "ITF Devanagari", "ITF Devanagari Marathi", "Kailasa", "Kannada MN", "Kannada Sangam MN", "Kefa", "Khmer MN", "Khmer Sangam MN", "Kohinoor Bangla", "Kohinoor Devanagari", "Kohinoor Gujarati", "Kohinoor Telugu", "Kokonor", "Krungthep", "KufiStandardGK", "Lao MN", "Lao Sangam MN", "Lucida Grande", "Luminari", "Malayalam MN", "Malayalam Sangam MN", "Marker Felt", "Menlo", "Microsoft Sans Serif", "Mishafi", "Mishafi Gold", "Monaco", "Mshtakan", "Mukta Mahee", "Muna", "Myanmar MN", "Myanmar Sangam MN", "Nadeem", "New Peninim MT", "Noteworthy", "Noto Nastaliq Urdu", "Noto Sans", "Noto Sans Javanese", "Noto Sans Kannada", "Noto Sans Myanmar", "Noto Sans Oriya", "Noto Sans UI", "Noto Serif Myanmar", "Optima", "Oriya MN", "Oriya Sangam MN", "Palatino", "Papyrus", "Phosphate", "PingFang HK", "PingFang SC", "PingFang TC", "Plantagenet Cherokee", "PT Mono", "PT Sans", "PT Sans Caption", "PT Sans Narrow", "PT Serif", "PT Serif Caption", "Raanana", "Rockwell", "Sana", "Sathu", "Savoye LET", "Shree Devanagari 714", "SignPainter", "Silom", "Sinhala MN", "Sinhala Sangam MN", "Skia", "Snell Roundhand", "Songti SC", "Songti TC", "STIXGeneral", "STIXIntegralsD", "STIXIntegralsSm", "STIXIntegralsUp", "STIXIntegralsUpD", "STIXIntegralsUpSm", "STIXNonUnicode", "STIXSizeFiveSym", "STIXSizeFourSym", "STIXSizeOneSym", "STIXSizeThreeSym", "STIXSizeTwoSym", "STIXVariants", "STSong", "Sukhumvit Set", "Symbol", "Tahoma", "Tamil MN", "Tamil Sangam MN", "Telugu MN", "Telugu Sangam MN", "Thonburi", "Times", "Times New Roman", "Trattatello", "Trebuchet MS", "Verdana", "Waseem", "Webdings", "Wingdings", "Wingdings 2", "Wingdings 3", "Zapf Dingbats", "Zapfino")

[13:28:42:310][0x7fe701d1a140][Info]"Running app..."

[13:28:42:388][0x7fe701d1a140][Info]"Activated selectors:" ("custom", "en_US", "unix", "darwin", "mac", "osx", "macos")

[13:28:42:389][0x7fe701d1a140][Info]"Registering types..."

[13:28:42:389][0x7fe701d1a140][Info]"Registering shared types..."

[13:28:42:389][0x7fe701d1a140][Info]"Registering tool types..."

[13:28:42:390][0x7fe701d1a140][Info]"Registering shared tool types..."

[13:28:43:221][0x7fe701d1a140][Info]"Loading main view..."

[13:28:43:960][0x7fe701d1a140][Info]"Launch async core creation."

[13:28:47:508][0x7fe701d1a140][Info]Core is starting  "Starting up"

[13:28:47:671][0x7fe701d1a140][Info]Core is running  "On"

[13:28:47:671][0x7fe701d1a140][Info]"Set `Friends` path: `/Users/testuser/Library/Application Support/linphone/friends.db`"

[13:28:47:825][0x7fe701d1a140][Info]"Set `CallLogs` path: `/Users/testuser/Library/Application Support/linphone/call-history.db`"

[13:28:47:826][0x7fe701d1a140][Info]Using ZrtpSecrets path :  "/Users/testuser/Library/Application Support/linphone/zrtp-secrets.db"

[13:28:47:826][0x7fe701d1a140][Info]Using UserCertificate path :  "/Users/testuser/Library/Application Support/linphone/"

[13:28:47:826][0x7fe701d1a140][Info]Using RootCa path :  "/Applications/"

[13:28:47:828][0x7fe701d1a140][Info]"Start iterate"

[13:28:47:828][0x7fe701d1a140][Info]Sip addresses model from Chats : 0 ms.

[13:28:47:829][0x7fe701d1a140][Info]Sip addresses model from Calls : 0 ms.

[13:28:47:829][0x7fe701d1a140][Info]Sip addresses model from Refs : 0 ms.

[13:28:47:829][0x7fe701d1a140][Info]Sip addresses model from Contacts : 0 ms.

[13:28:47:829][0x7fe701d1a140][Info]Sip addresses model initialized in: 0 ms.

[13:28:47:829][0x7fe701d1a140][Info]"Notify event count: 0."

[13:28:47:830][0x7fe701d1a140][Info]"Migrate from old rc file (0 to 2)."

[13:28:47:830][0x7fe701d1a140][Info]"CoreManager initialized"

[13:28:48:499][0x7fe701d1a140][Info]"Open Linphone app."

[13:28:48:499][0x7fe701d1a140][Info]"Creating subwindow: `qrc:/ui/views/App/Calls/CallsWindow.qml`."

[13:28:50:005][0x7fe701d1a140][Info]"Subwindow status: `1`."

[13:28:50:050][0x7fe701d1a140][Info]"Creating subwindow: `qrc:/ui/views/App/Settings/SettingsWindow.qml`."

[13:28:50:241][0x7fe701d1a140][Info]"Subwindow status: `1`."

zsh: abort      ./linphone

nbkhwjm@Chriss-MacBook-Pro MacOS %

reply via email to

[Prev in Thread] Current Thread [Next in Thread]