[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: [Linphone-users] URGENT help

From: Simon Morlat
Subject: RE: [Linphone-users] URGENT help
Date: 11 Jun 2002 14:17:27 +0200

Le mar 11/06/2002 à 06:39, Karthikeyan S a écrit :
> hai Simon,
> First of all thanx for ur directions.
> I am now using the latest 0.8.0 as u said and i tried to compile.
> It gives the following error while compiling
> make[1]: Entering directory `/home/ngnsip/Linphone/linphone-0.8.0/lpc10-1.5'
> /bin/sh ../libtool --mode=link gcc  -g -O2 -Wall -Wunused  -w   -o bitio
> bitio.o
> gcc -g -O2 -Wall -Wunused -w -o bitio bitio.o  ./.libs/ -lm
> bitio.o: In function `g_error':
> /usr/include/glib-1.2/glib.h:1328: undefined reference to `g_logv'
> bitio.o: In function `g_message':
> /usr/include/glib-1.2/glib.h:1337: undefined reference to `g_logv'
> bitio.o: In function `g_warning':
> /usr/include/glib-1.2/glib.h:1346: undefined reference to `g_logv'
> collect2: ld returned 1 exit status
> make[1]: *** [bitio] Error 1
> make[1]: Leaving directory `/home/ngnsip/Linphone/linphone-0.8.0/lpc10-1.5'
> make: *** [install-recursive] Error 1

Strange error: it does not show here, probably because of difference in
compilers. It is fixed for next version, however to avoid it, please do
the following:
in lpc10-1.5/ directory
rm bitio.c
touch bitio.c
The error occurs when compiling bitio.c, that is not a required program
for linphone (it was just for basic testing, a long time ago.
I hope this workaround will work.

> The problem which i reported yesterday is on version 0.7.1 with libosip
> version 0.7.8
> The machine has RH 7.1 installed with Intel i810  82801AA Ac'97 audio sound
> card.
> Now i tried to test the sipomatic with the currect configuration. I got the
> following debug output after Linphone got connected with sipomatic robot.
>  U can c the ACK)
> I used address@hidden:5064 and lo as the interface.
> L0 -1023770307- SND ACK f:sip:address@hidden t:sip:address@hidden:5064 cseq:1
> callid:515640063
> L1 -1023770307- <callback.c> OnEvent_New_OutgoingAck!
> L3 -1023770307- <trn_manager.c> method called: 81158a0
> Lost (or Only -1 bytes written.
> Lost (or Only -1 bytes written.
> Lost (or lateOnly -1 bytes written.
> Lost (or late) Only -1 bytes written.
> Lost (or late) paOnly -1 bytes written.
> Lost (or late) pacOnly -1 bytes written.
> Lost (or late) packeOnly -1 bytes written.
> Lost (or late) packetsOnly -1 bytes written.
> Lost (or late) packets:Only -1 bytes written.
> Lost (or late) packets: 5Only -1 bytes written.
> Lost (or late) packets: 562Only -1 bytes written.
> Lost (or late) packets: 593 Only -1 bytes written.
> Lost (or late) packets: 655   Only -1 bytes written.
> Lost (or late) packets: 717     Only -1 bytes written.
> Only -1 bytes written.: 748
> LoOnly -1 bytes written.810
> LosOnly -1 bytes written.41
> Lost Only -1 bytes written.
> L4 -1023770318- <udp_listen.c> RCV MESSAGE ON UDP!
> BYE sip:address@hidden SIP/2.0
> via: SIP/2.0/UDP
> from: sip:address@hidden
> to: sip:address@hidden
> cseq: 1 BYE
> call-id: address@hidden
> contact: sip:address@hidden
> user-agent: oSIP/Linphone-0.4.2
> content-length: 0
user-agent: oSIP/Linphone-0.4.2
Are you sure you are using linphone-0.7.1 ? I'm a bit suprise with this
sip message. Are you sure you have not an older version of linphone
installed somewhere ?
Please check that.

Finally, the -1 bytes written are related to a sound device access
problem. But before investigating more, please check your linphone's
The best thing is to use 0.8.0.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]