lilypond-auto
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Lilypond-auto] [LilyIssues-auto] [testlilyissues:issues] #5848 flower:


From: Auto mailings of changes to Lily Issues via Testlilyissues-auto
Subject: [Lilypond-auto] [LilyIssues-auto] [testlilyissues:issues] #5848 flower: Clean up libc-extension
Date: Sat, 11 Apr 2020 16:05:47 -0000


[issues:#5848] flower: Clean up libc-extension

Status: Started
Created: Tue Mar 17, 2020 09:03 PM UTC by Jonas Hahnfeld
Last Updated: Sat Apr 11, 2020 04:01 PM UTC
Owner: Jonas Hahnfeld

flower: Clean up libc-extension

Individual commits:
1) Remove unused includes of libc-extension.hh

2) Rewrite String_convert::to_upper, ::to_lower via std::transform

3) Rename my_round to round_halfway_up

The function differs from std::round() in the handling of negative
numbers: While std::round() rounds halfway cases away from zero,
round_halfway_up (as the name suggests) rounds them up for historic
reasons.
This can apparently be relied upon at least when manually positioning
ties (input/regression/tie-single-manual.ly). In the long run, these
cases should be identified and taken care of individually. Keep this
function for the time being, but DO NOT USE in newly written code.

While passing by, move some system headers last (this helps avoid issues
that one of LilyPond's headers depends on other system headers being
loaded first) and add them if apparently used in the file.

http://codereview.appspot.com/553740043


Sent from sourceforge.net because address@hidden is subscribed to https://sourceforge.net/p/testlilyissues/issues/

To unsubscribe from further messages, a project admin can change settings at https://sourceforge.net/p/testlilyissues/admin/issues/options. Or, if this is a mailing list, you can unsubscribe from the mailing list.

_______________________________________________
Testlilyissues-auto mailing list
address@hidden
https://lists.sourceforge.net/lists/listinfo/testlilyissues-auto

reply via email to

[Prev in Thread] Current Thread [Next in Thread]