[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Octave can't find BLAS or LAPACK

From: John Ferreira
Subject: Re: Octave can't find BLAS or LAPACK
Date: Mon, 11 Apr 2022 11:27:08 -0400


I have successfully added the -m32 flags to C, CPP and Fortran compilers. ./configure seems to work. However, when I run make -j5 I eventually get a make error:
Liboctave/system/ fatal error: codecvt: No such file or directory

Is there a known fix for this issue?

Thank you,
John F

On Apr 10, 2022, at 4:56 PM, Dmitri A. Sergatskov <> wrote:

Please reply to the list.
You need to provide flags for C, C++, and Fortran compilers. 
For gcc/clang the flag is "-m32"
Try some kind of "Hello world" program first to make sure you got them right.


On Sun, Apr 10, 2022 at 4:47 PM John Ferreira <> wrote:
I tried passing CFLAG=“-mcpu=i686” 
I also tried CFLAG=“-march =i686”

But I still got the same BLAS and LAPACK error.


On Apr 10, 2022, at 4:34 PM, Dmitri A. Sergatskov <> wrote:

On Sun, Apr 10, 2022 at 4:26 PM John Ferreira <> wrote:

I am attempting to build a recent version of octave as a 32--bit i686 package for RHEL 7. I have installed the BLAS and LAPACK packages but ./configure does not detect the libraries. I have the 32 bit packages including the -devel packages installed as seen below:

I have also tried passing the library paths in ./configure option as:
./configure  --prefix=/home/jferreira/builds/octaveCompile --with-blas=/usr/lib/ --with-lapack=/usr/lib/

I still get: configure: error: BLAS and LAPACK libraries are required.

Any help would be appreciated.

Did you tell your compiler to build i686 binary?


Thank you,
John Ferreira


reply via email to

[Prev in Thread] Current Thread [Next in Thread]