[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Help with running embedded standalone program v 6.4.0

From: ashwin damle
Subject: Re: Help with running embedded standalone program v 6.4.0
Date: Mon, 10 Jan 2022 14:23:32 +0530

Hi Markus,

Yes, you are correct. That was the issue. I had copied the liboctave and libinterp DLLs.  I tried with the solution you'd suggested and it worked. 

Alternatively, after your email, I removed the copied DLLs and started searching for a way to not include DLLs in the local executable director. I had already included the Octave bin directory "C:\Program Files\GNU Octave\Octave-6.4.0\mingw64\bin" in the PATH. However, it was not working and had to place the DLL in the working directory. I realised that this octave directory was in the PATH but was superseded by other directories. I move the Octave bin directory up the order. I think this made Windows give preference to the directory and I no longer need to copy individual DLLs in the working directory.

Thank you for the pointer!

Ashwin Damle

On Thu, 6 Jan 2022 at 18:22, Markus Mützel <> wrote:
IIUC, that symbol demangles to:
std::basic_filebuf<char, std::char_traits<char> >::open(wchar_t const*, std::_Ios_Openmode)
That is a symbol that should be exported by the standard libraries.
It looks like you copied some (but not all) necessary libraries to a different folder with the executable. Either, copy the standard libraries to that folder, too, or try compiling with `-static-libstdc++` to check if that makes a difference.
 mkoctfile --link-stand-alone -o embedded.exe -static-libstdc++
Gesendet: Donnerstag, 06. Januar 2022 um 12:52 Uhr
Von: "ashwin damle" <>
Betreff: Re: Help with running embedded standalone program v 6.4.0
Please note that although the screenshot says callOctave.exe, inside it is the same program. I thought of clarifying.
On Thu, 6 Jan 2022 at 09:47, ashwin damle <> wrote:
I am trying to run the embedded program at Standalone Programs (GNU Octave (version 6.4.0)) - attached.
When I execute the program using .exe created using mkoctfile --link-stand-alone -o embedded.exe
I get the following error. My computer is Windows 10, Gnu Octave v6.4.0. This was working in the previous version v 6.2.0. Could you please guide.
Ashwin Damle
Ashwin Damle
---------- We are transitioning to a web based forum for community help discussions at

Ashwin Damle

reply via email to

[Prev in Thread] Current Thread [Next in Thread]