[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: f951: internal compiler error: Illegal instruction: 4 when installin

From: Andrew Janke
Subject: Re: f951: internal compiler error: Illegal instruction: 4 when installing packages
Date: Sat, 17 Apr 2021 21:27:15 -0400
User-agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.14; rv:78.0) Gecko/20100101 Thunderbird/78.9.1

On 4/15/21 9:19 AM, mzerobin via Help-octave wrote:
> Again, thank you for your help.

You're welcome! Happy to help.

> First, since building from source using the command 'brew reinstall
> --build-from-source gcc' did not work I looked for other ways and found a
> video to build gcc-10 from source 
> <>  . I followed it and it took
> many many hours to build. During the process several warnings occurred.
> However, I did not take notes which ones. Still, when installing the
> statistics package it resulted in the same error.
> Finally, trying to install the statistics package in Octave resulted in the
> same error as before.
> I am very thankful for any additional tips I could try to get it
working. Do
> you know if there is a way to maybe build gcc explicitly for the
processor I
> am using?

I'm about out of ideas here; sorry. AFAIK, what you're doing "should
have" worked. There's nothing special you need to do to build a program
specifically for your CPU; that's just what should happen by default
when you build from source.

Maybe try MacPorts instead? They have better support for older macOS
versions and machines than Homebrew does.

You could also try building this stuff with `HOMEBREW_MAKE_JOBS=1`.
It'll go a lot slower, but you'll get easier-to-read diagnostic output
in the build logs.

> Furthermore, I searched for 'f951' in /usr/local where I actually found 3
> exec. 
> One in //usr/local/gfortran/libexec/gcc/x86_64-apple-darwin15/6.1.0/f951/
> A second one in
> //usr/local/gcc-10/libexec/gcc/x86_64-apple-darwin19.6.0/11.0.1/f951/
> And a third one in
> //usr/local/Cellar/gcc/10.2.0_4/libexec/gcc/x86_64-apple-darwin19/10.2.0/f951/
> Although I am far from being an expert in this matter I believe that maybe
> this could cause the error? I.e. that I have the same exec in three
> different directories?

Now that is a bit odd. Where did that /usr/local/gfortran installation
come from?

The other two things look like two separate GCC installations (the f951
program is part of GCC, like the rest of GNU Fortran); one from Homebrew
and one that you did using one of the other processes.

Which one of these you're picking up will depend on your $PATH settings
when you do the build.

I've made an issue about adding support for this scenario to If you
have some spare time, maybe you could drop by there and write some
comments about your use case? It won't happen any time soon, but it
might be useful for you or other users in the future.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]