[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: Image acquisition

From: Nkosiphile Bhebhe
Subject: RE: Image acquisition
Date: Wed, 21 Aug 2019 08:40:57 +0000





From: Kai Torben Ohlhus
Sent: Wednesday, August 21, 2019 8:40 AM
To: Nkosiphile Bhebhe
Cc: address@hidden
Subject: Re: Image acquisition


On 8/21/19 1:51 PM, Nkosiphile Bhebhe wrote:

>> On 21 Aug 2019, at 05:47, Kai Torben Ohlhus <address@hidden> wrote:
>>> On 8/21/19 12:38 PM, Nkosiphile Bhebhe wrote:
>>> Good Day,
>>> I am trying to connect to a point grey CCD camera using octave on ubuntu. I have tried to install the image acquisition package but I get the following error “unable to find the v4l2_open function”.
>>> I only started using octave recently may you kindly assist?
>>> Kind Regards
>>> Nkosiphile
>> Did you install the build dependencies [1,2] mentioned at the bottom of [3]?
>>   sudo apt-get install libv4l-dev libfltk1.1-dev
>> If you did this and installed the image acquisition package without
>> errors, you must load the package as well
>>   pkg load image-acquisition
>> HTH,
>> Kai
>> [1]
>> [2]
>> [3]
> Hi Kai,
> Thank you for the response.
> Yes I did install the dependencies, I thought I didn’t do it the right
way and repeated the procedure and it said the dependencies are already
installed. Do I have to follow a specific order when setting up?
> Kind Regards
>  Nkosiphile

Dear Nkosiphile,

Please reply at the bottom of this mail (bottom-posting) for this
mailing list and keep the list itself in the CC so many others smarter
than me can help you as well.

I just repeated the procedure myself on my Laptop with openSUSE 15.1 and
I get:

$ sudo zypper install libv4l-devel fltk-devel  # Different for Ubuntu!
$ octave

octave:1> pkg install -forge image-acquisition
For information about changes from previous versions of the
image-acquisition package, run 'news image-acquisition'.
octave:2> pkg load image-acquisition
octave:3> imaqhwinfo
ans =

  scalar structure containing the fields:

    driver = uvcvideo
    card = Integrated Camera
    bus_info = usb-0000:00:14.0-10
    version = 4.12.14
    capabilities =  2233466881
    device = /dev/video0
octave:4> obj = videoinput("v4l2", "/dev/video0")
obj = videoinput for v4l2
      device               = /dev/video0
warning: duplicate type v4l2_handler
      driver               = uvcvideo
      card                 = Integrated Camera
      VideoInput           = 0
      VideoResolution      = 640 x 480 px
      VideoFormat          = YUYV

So seems kind of working.

What exactly is your error message or makes you believe things are not
working?  When do you see this message “unable to find the v4l2_open
function”?  While installing?  Especially, what is your version of
Ubuntu and Octave?


Thanks Kai for your response,


I see the message below when I run “pkg install -forge image-acquisition” on the command window. So I am running ubuntu 18.04.3 and octave 5. I have installed the dependencies from the links you sent me but I keep getting the same error. Just to confirm, will running ubuntu on a virtual machine be a problem as I have my Linux installed on a virtual machine with the host machine running on windows?



>> pkg install -forge image-acquisition

configure: error: unable to find the v4l2_open() function

checking whether the C++ compiler works... yes

checking for C++ compiler default output file name... a.out

checking for suffix of executables...

checking whether we are cross compiling... no

checking for suffix of object files... o

checking whether we are using the GNU C++ compiler... yes

checking whether g++ accepts -g... yes

checking for mkoctfile... yes

checking for fltk-config... /usr/bin/fltk-config

checking for v4l2_open in -lv4l2... no


pkg: error running the configure script for image-acquisition.

error: called from

    configure_make at line 78 column 9

    install at line 194 column 7

    pkg at line 394 column 9


Kind regards





The information contained in this communication is confidential and may be legally privileged. It is intended solely for the use of the individual or entity to whom it is addressed and others authorised to receive it.
If you are not the intended recipient you are hereby notified that any disclosure, copying, distribution or taking action in reliance of the contents of this information is strictly prohibited and may be unlawful. The NMISA is neither liable for the proper, complete transmission of the information contained in this communication, any delay in its receipt, or that the mail is virus-free.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]