[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Read-only file system error when installing a package

From: Steven Evans
Subject: Re: Read-only file system error when installing a package
Date: Sat, 18 May 2019 19:20:03 -0400
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Thunderbird/52.6.0

    Thanks so much, Mike.  That did, indeed, solve the problem. However, now I have another one.     After typing "pkg install -forge parallel" at the Octave prompt, I receive an error message which says:

pkg: error running `make' for the parallel package.
error: called from
    configure_make at line 99 column 9
    install at line 184 column 7
    pkg at line 441 column 9

    Before printing out this error, it prints out a lot of other things, of which, I'm embarrassed to say that I don't fully understand.  I copied everything that it prints out and pasted it into a text file, which I've attached to this message.     In your message, you said that I was trying to do a global install.  Does typing "pkg install -forge parallel" mean that I'm trying to do a global install?     I typed "pkg install -forge parallel", based on a webpage which speaks about the parallel package:

    At the top of that page, it says to type "pkg install -forge parallel" in order to install the package.  Does this cause the global install that you're talking about?     Would it matter that I now have two versions of Octave installed?  I tried to install the parallel package on the version of Octave that I have originally (version 4.0.0).  When trying to install the package, I received a message which said:

error: the following dependencies were unsatisfied:
   parallel needs struct >= 1.0.12

    I figured I was receiving the message because my version of Octave was too old for the package.  So I installed version 5.0.1 using flatpack.  It turns out that I can still use my old version of Octave by typing "octave-cli" at a Linux command prompt.  In order to run the new version, I type "flatpak run org.octave.Octave".  Is it a problem for me to have the two versions?     I realized the version wasn't the cause of the struct issue when I tried to install the parallel package on version 5.0.1, and still got the struct message.  I later found out that I'm receiving that message because I have to install struct, which is a different package.  So I installed that package by typing "pkg install -forge struct", on my 5.0.1 version of Octave.  I then tried to install the parallel package, which gave me the error in the attached text file.     I'm not sure whether any of that is related to this error message about 'make' not running correctly, but I figured it wouldn't hurt to let you know.     Thanks again for your help on how to get beyond my "read-only" issue.  Could this new issue be related to the global install that you mentioned earlier?

Thanks for your time and patience,


On 05/18/2019 03:08 PM, Mike Miller wrote:
On Sat, May 18, 2019 at 12:01:11 -0400, Steven Evans wrote:
     When trying to install Octave's parallel package, I receive the
following error:

warning: creating installation directory /app/share/octave/packages
warning: called from
     install at line 30 column 5
     pkg at line 441 column 9
error: could not create installation directory: Read-only file system
error: called from
     install at line 33 column 7
     pkg at line 441 column 9

     I receive this error after typing "pkg install -forge parallel" at the
Octave prompt.
This error message occurs because you are trying to do a "global"
package install into the /app filesystem in Flatpak, which is indeed a
read only filesystem. So this error message is correct.

But the reason you are doing a "global" package install is because...

     My operating system is Lubuntu 16.04.  I recently installed the latest
version of Octave (version 5.1.0) using Flatpak.
     I don't know if this matters, but after installing Octave, I have to put
"sudo" in front of the "flatpak run org.octave.Octave" command, when
starting Octave.
Yes, it definitely matters, don't run Flatpak apps with sudo.

     I got this run command by following the instructions at the bottom of
this page:

     In order to start Octave via the command line, it says to type "flatpak
run org.octave.Octave".  However, if I don't put "sudo" before this,  a
window pops up saying I don't have read and write permissions.  I've
attached a screen shot of this, so that you'll see what I mean.  That error
message gave me the idea of putting "sudo" before the command; which seems
to work.
The error in your screenshot means you have probably run Octave with
sudo at some point in the past, and Ubuntu's sudo configuration is
weird. Try

     sudo rm -rf /home/evansste/.config/octave

to delete the root-owned files in your home directory, then run Octave
again as your own user.

Running a user application with sudo is hardly ever a good idea.

     Because I received that error by not using "sudo", I'm wondering if that
could be related to me not being able to install the parallel package.  If
so, what am I doing wrong? Any ideas on how to fix this?
Please try the above and let us know if it works.

A Tool for the Technical Community

Attachment: error results.txt
Description: Text document

reply via email to

[Prev in Thread] Current Thread [Next in Thread]