[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

octave gui not working - 'exiting with signal 6'

From: Lee Strobel
Subject: octave gui not working - 'exiting with signal 6'
Date: Wed, 08 May 2019 22:16:55 -0400
User-agent: Evolution 3.32.1


I seem to be having a problem and I'm wondering if anyone can help?

When I try to launch the Octave gui, the window opens and then closes
after about 3 seconds, with the message 'octave exited with signal 6'.
The cli version seems to work fine and I am not having issues with any
other X graphical programs.

The problem seems similar to the one described here:

I have read that thread and tried using strace. At first, strace showed
quite a few links to libraries that relate to OpenFOAM (free software
Computational Fluid Dynamics (CFD) program), which I also have
installed. I had something in my .bashrc that set up some environment
variables to do with OpenFOAM, which may have caused some sort of

So, I removed that from .bashrc and now I don't see any references to
OpenFOAM in the strace output, but the Octave gui still isn't working.
I will attach the output of strace to this e-mail (I used strace -f, so
that it follows child processes). I can't see anything obvious in the
output that might be causing the problem. It looks like one of the
child processes is aborting for some reason, but I can't see what is
causing it.

It seems strange, because I am sure the Octave gui was working just
after I installed it, but now it isn't. I have tried uninstalling and
re-installing. I am using Parabola GNU/Linux (Arch-based) on an Armv7
Chromebook - the latest package version is 'octave 5.1.0-4'.

Thanks in advance for any assistance.


Lee Strobel

Attachment: output
Description: Text document

reply via email to

[Prev in Thread] Current Thread [Next in Thread]