[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: Installing instrument control package

From: JohnD
Subject: RE: Installing instrument control package
Date: Wed, 3 Apr 2019 08:05:15 -0400

> ------------------------------
> Message: 3
> Date: Wed, 3 Apr 2019 02:26:44 -0500 (CDT)
> From: martinhedegaard <address@hidden>
> To: address@hidden
> Subject: RE: Installing instrument control package
> Message-ID: <address@hidden>
> Content-Type: text/plain; charset=us-ascii
> Hi,
> I did what you said and created a script. cd to where it was and ran it,
> got the following output from the bash terminal:
> ./ line 3: $'\r': command not found
> ./ line 8: $'\r': command not found
> ./ line 18: $'\r': command not found
> ./ line 22: $'\r': command not found
> /include/gpib/ib.h: No such file or directory
> : No such file or directory
> ./ line 27: syntax error near unexpected token `|'
> '/ line 27: `  | sed "s/^.*NI488CC  *//" \
> I only copy pasted what was on the wiki into a file so i don't understand
> what goes wrong here. also i cant find the /usr folder, in my octave
> directory i got an x86_64-w64-mingw32 folder. I know that if i run not as
> admin i cannot create the folders however this is the first time i have
> encountered these issues.
> I already have an ib.h file and a libgpib.a file created in another folder
> just need to figure out why the libgpib.a file is not found when i try to
> install instrument-control package. if i put in ib.h in the include folder
> in octave 4.4.1 when i run the install the make file finds it however it
> cannot find the libgpib.a file pasted into the lib folder.

It sounds like when you copied it, it got some return character characters
in it - how did you create the script file ?

Octave is using 4.4 is using msys in windows to provide the unix commands,
and so is using the emulated file structure from that which translates the
/usr to the octave install directory,
So /usr/include is really the octaveinstalldir/include

reply via email to

[Prev in Thread] Current Thread [Next in Thread]