[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: error: feval: function 'pkg.m' not found

From: Doug Stewart
Subject: Re: error: feval: function 'pkg.m' not found
Date: Sun, 29 Jul 2018 11:59:30 -0400

On Sun, Jul 29, 2018 at 9:58 AM, ashwin damle <address@hidden> wrote:

Yes, I tried with octave::feval ("pkg", ovl ("load", "control"), 0); It does not work.

In order to try one or other option, I tried "pkg.m" and mistakenly sent the same file - "pkg.m" nor "pkg" works.

Did it work for you?
yes it does!

 mkoctfile --link-stand-alone -o embedded
address@hidden:~$ ./embedded
warning: function ./erase.m shadows a core library function
GCD of [10, 15] is 5


Please let me know.


On Sun, 29 Jul 2018 at 18:19, Doug Stewart <address@hidden> wrote:

On Sun, Jul 29, 2018 at 7:51 AM, ashwin damle <address@hidden> wrote:
Hi Support,

Could you please help me with this? I execute the script from as is with added line of  octave::feval ("pkg.m", ovl ("load", "control"), 0);  to load the control package. The executable is generated but on execution I get the error

error: feval: function 'pkg.m' not found
error encountered in Octave evaluator!

The reference used for the package load line is where in a interval package is loaded.

I was using an older version of Octave before but now I am running 
GNU Octave 4.4.0 on Windows-10 64 bit.

Attached is the file I am using. Before running mkoctfile in the command window the environment variable is to be set using setenv('OCTAVE_LINK_DEPS', " -liconv"). I have given reference in the .cc file.

I was wanting to execute use this in the latest Octave. Could you please help?

Ashwin Damle

did you try:
  octave::feval ("pkg", ovl ("load", "control"), 0); 


Ashwin Damle

DASCertificate for 206392

reply via email to

[Prev in Thread] Current Thread [Next in Thread]