[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Unable to set vim as default editor in octave 4.0/4.2.1

From: theor
Subject: Unable to set vim as default editor in octave 4.0/4.2.1
Date: Tue, 10 Oct 2017 18:19:04 -0700

I'm trying to set Vim as my editor by setting a .octaverc file. However, I haven't been able to change the behavior of Octave. I've written my .octaverc file as suggested in the wiki ( in a few different ways, such as

    edit mode async
    EDITOR("xfce4-terminal -e 'vim %s'")

where I've tried xterm instead of xfce4-terminal and gvim instead of vim. The following .octaverc file has been attempted.

    edit mode sync
    edit home .
    EDITOR('vim > /dev/tty 2>&1 < /dev/tty %s')

And I've tried gvim instead of vim.

I can verify that the script actually ran at startup since EDITOR returns the inputted string. However, when I try to edit a file via e.g. the command

    >> edit temp.m

the normal editor opens up in the editor tab. It's no different than if I had a blank .octaverc file. I'm not sure what else to try, I started on octave 4.0 and updated octave to 4.2.1 but the problem persists. I'm on xubuntu (ubuntu 16.04) using vim 7.4.

Thanks for reading,

reply via email to

[Prev in Thread] Current Thread [Next in Thread]