[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: database connection fails

From: Olaf Till
Subject: Re: database connection fails
Date: Tue, 3 Jan 2017 18:47:21 +0100
User-agent: Mutt/1.5.23 (2014-03-12)

On Tue, Jan 03, 2017 at 11:53:07AM +0100, Karen Kuhn wrote:
> Hi all,
> I tried to connect to a test database via
> conn = pq_connect(setdbopts("host", "localhost","port", "5432","dbname",
> "testdb", "user", "superx", "password", ""))
> and get the error:
> error: octave_pq_get_postgres_oid: could not convert given type tostring
> error: could not read types
> error: __pq_connect__ failed
> error: called from:
> error:   /usr/share/octave/packages/database-2.4.2/pq_connect.m atline 112,
> column 8
> Has anyone an idea where the problem might be and how I can get it work?

This is an error internal to the package. I still don't see why this
should occur, though I've identified the position in the package code
where the error seems to come from.

> I'm working on a Debian 8.6 machine with octave 3.8.2 and postgresql 9.4.9.
> I installed the packages struct 1.0.14 and database 2.4.2 without any
> problem report via:
> pkg install -global -verbose struct
> pkg install -global -verbose database

Trying to reproduce the problem, I wonder why the above commands
should have worked:

- What was in the paths 'struct' and 'database' in the current
  directory? Where have you got it from?

- Did you run Octave as the root user? The -global option should only
  be necessary for a non-root user, but a non-root user on a normal
  Debian system shouldn't have permissions for a global install.

Have you any further version of Octave or its libraries installed on
your system?

Have you possibly installed database both locally (under ~/octave/)
and system-wide?


public key id EAFE0591, e.g. on x-hkp://

Attachment: signature.asc
Description: Digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]