[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Plot function not working

From: Nicholas Jankowski
Subject: Re: Plot function not working
Date: Fri, 19 Aug 2016 09:47:23 -0400

On Fri, Aug 19, 2016 at 3:28 AM, ammc <address@hidden> wrote:

I've tried following the instructions here,
but as they are for the MacBook, I'm not sure they apply. I downloaded
gnuplot and installed in the Octave folder and then changed graphics toolkit
to gnuplot, but when I ran >> getenv("GNUPLOT"), I got >> ans =
I then tried running [status,output]=system(sprintf("which
but I got back
>>'which' is not recognized as an internal or external command,
operable program or batch file.
status =  127
output =

Other than a few specific packages, the windows versions should run without having to install any other software. There are both .exe installers and .zip file installers for the latest versions (4.0.3 being most recent.)  As Andreas said, please reply to the list with exactly which you installed.

Here are the official installers:

I believe there are also 64bit installers but I don't have the link handy.

Based on the usual experience with windows, I'd recommend fully uninstalling both gnuplot and octave.  I prefer to use the zip files rather than an executable installer. Just unzip it into C:\Octave, and you should be able to run (or manually create shortcuts to) the octave.bat file.  I haven't heard of anyone else having plot issues like you describe with those versions.

Nick J.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]