[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Octave: symbolic 2.2.3 released

From: Constantine Frangos
Subject: Re: Octave: symbolic 2.2.3 released
Date: Tue, 1 Dec 2015 18:22:10 +0200 (SAST)

Hi Mike,

Thanks for the fast response. I used synaptic package manager
(on ubuntu 14.04) to install SymPy, and the version that appears
in the package manager is SymPy 0.7.4.

How can I install SymPy 0.7.5 via the synaptic package manager ?

(I do not want to risk damaging the linux installation).



----- Original Message -----
From: "Mike Miller" <address@hidden>
To: address@hidden
Sent: Tuesday, December 1, 2015 6:10:23 PM
Subject: Re: Octave: symbolic 2.2.3 released

On Tue, Dec 01, 2015 at 17:46:19 +0200, Constantine Frangos wrote:
> I have Octave 3.8 running on a linux 64 bit machine, and 
> have managed to install SymPy
> What is the correct version of the symbolic toolbox for the above
> and how do I specify this from the Octave command line when
> installing ?
> octave:1> pkg install -forge symbolic  ?
> The above command currently produces the error:
> configure: error: SymPy version 0.7.5 or later is required
> checking for sort... /usr/bin/sort
> checking for GNU coreutils... yes
> checking for python... /usr/bin/python
> checking python module: sympy... yes
> checking for SymPy version...
> checking for gawk... gawk
> pkg: error running the configure script for symbolic.
> error: called from 'configure_make' in file 
> /usr/share/octave/3.8.1/m/pkg/private/configure_make.m near line 72, column 9
> error: called from:
> error:   /usr/share/octave/3.8.1/m/pkg/private/install.m at line 206, column 5
> error:   /usr/share/octave/3.8.1/m/pkg/pkg.m at line 394, column 9
> octave:1> 

The error has told you exactly what you need to do. SymPy 0.7.4 is not
supported, the symbolic package will not work correctly. Try installing
SymPy 0.7.5 (or 0.7.6, the latest version).


Help-octave mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]