[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: mkoctfile on octave 3.8.2 / fink OSX

From: Alexander Hansen
Subject: Re: mkoctfile on octave 3.8.2 / fink OSX
Date: Sun, 24 May 2015 16:47:15 -0700

On May 21, 2015, at 08:32, Rudolf Widmer-Schnidrig <address@hidden> wrote:

Am 21/05/15 um 16:51 schrieb Alexander Hansen:
On May 21, 2015, at 06:59, Rudolf Widmer-Schnidrig <address@hidden> wrote:

Dear List,

I did a clean install of OSX/Yosemite.
On this system I installed fink, and with fink I installed octave-3.8.2

When trying to complete the installation by adding some sourceforge packages I ran into this problem:

octave:1> pkg install -forge control
pkg: unable to find the mkoctfile command, Octave installation is incomplete
error: called from '__gripe_missing_component__' in file /sw/share/octave/3.8.2/m/help/__gripe_missing_component__.m near line 53, column 3
error: called from:
error:   /sw/share/octave/3.8.2/m/pkg/private/install.m at line 199, column 5
error:   /sw/share/octave/3.8.2/m/pkg/pkg.m at line 394, column 9

octave:1> help mkoctfile
'mkoctfile' is a function from the file /sw/share/octave/3.8.2/m/miscellaneous/mkoctfile.m

Thus when calling "pkg" octave cannot find mkoctfile.m
but invoking "help mkoctfile" seems to find it.

Also the path to mkoctfile ( /sw/share/octave/3.8.2/m/miscellaneous/ ) is set:

octave:2> path

Octave's search path contains the following directories:

. /sw/share/octave/3.8.2/m/plot
/sw/lib/octave/3.8.2/site/oct/x86_64-apple-darwin /sw/share/octave/3.8.2/m/plot/appearance
/sw/share/octave/3.8.2/site/m /sw/share/octave/3.8.2/m/plot/draw
/sw/lib/octave/3.8.2/oct/x86_64-apple-darwin /sw/share/octave/3.8.2/m/plot/util
/sw/share/octave/3.8.2/m /sw/share/octave/3.8.2/m/polynomial
/sw/share/octave/3.8.2/m/audio /sw/share/octave/3.8.2/m/prefs
/sw/share/octave/3.8.2/m/deprecated /sw/share/octave/3.8.2/m/set
/sw/share/octave/3.8.2/m/elfun /sw/share/octave/3.8.2/m/signal
/sw/share/octave/3.8.2/m/general /sw/share/octave/3.8.2/m/sparse
/sw/share/octave/3.8.2/m/geometry /sw/share/octave/3.8.2/m/specfun
/sw/share/octave/3.8.2/m/gui /sw/share/octave/3.8.2/m/special-matrix
/sw/share/octave/3.8.2/m/help /sw/share/octave/3.8.2/m/startup
/sw/share/octave/3.8.2/m/image /sw/share/octave/3.8.2/m/statistics
/sw/share/octave/3.8.2/m/io /sw/share/octave/3.8.2/m/statistics/base
/sw/share/octave/3.8.2/m/java /sw/share/octave/3.8.2/m/statistics/distributions
/sw/share/octave/3.8.2/m/linear-algebra /sw/share/octave/3.8.2/m/statistics/models
/sw/share/octave/3.8.2/m/miscellaneous /sw/share/octave/3.8.2/m/statistics/tests
/sw/share/octave/3.8.2/m/optimization /sw/share/octave/3.8.2/m/strings
/sw/share/octave/3.8.2/m/path /sw/share/octave/3.8.2/m/testfun
/sw/share/octave/3.8.2/m/pkg /sw/share/octave/3.8.2/m/time

Anybody has a suggestion whats going wrong here?

          many thanks in advance,          -Ruedi

I’m a bit behind on updating the Octave Forge packages in Fink, because the people who actually pay my bills are demanding a lot of my time, but you might just do “fink install control-oct382” to install the control package.  The Fink setup does support manually installed Octave Forge packages, too, provided that you install the corresponding build-time package first via "fink install octave382-dev”.  That’s what contains the headers and mkoctfile.

Dear Alexander,

your suggestions worked. I could install the control and signal packages. thanks a lot.

moving on I tried to do the equivalent of "Hello World!" in graphics:

octave:2> x=(0:0.1:20)';
octave:3> y=sin(x);
octave:4> plot(x,y)
May 21 17:13:15 Rudolfs-MacBook-Pro.local octave-cli-3.8.2[5263] <Error>: CGContextFillRects: invalid context 0x0. This is a serious error. This application, or a library it uses, is using an invalid context  and is thereby contributing to an overall degradation of system stability and reliability. This notice is a courtesy: please fix this problem. It will become a fatal error in an upcoming update.

This warning got repeated ~100 times and then the correct plot appeared!


I don’t happen to know if FLTK upstream has patched for this in a development branch, but it’s a problem with how they’re using Apple’s CoreGraphics, apparently.

Alexander Hansen, Ph.D.
Fink User Liaison

reply via email to

[Prev in Thread] Current Thread [Next in Thread]