[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: still problem of loading 32 bit tiff image using imread after reconf

From: Carnë Draug
Subject: Re: still problem of loading 32 bit tiff image using imread after reconfiguring GraphicsMagick
Date: Mon, 23 Mar 2015 13:02:25 +0000

On 21 March 2015 at 00:43, "Yang, Fei" <address@hidden> wrote:
> Hello all,
> I am a new user of Octave, and I use the version running in Centos linux.
> Currently when I tried to load one 32 bit floating-point image into
> Octave using command 'imread', I found it had been automatically converted
> to 8 bit. Also I got the error notice as: warning: 'your version of
> GraphicsMagick limits images to 8 bits per pixel'.
> After searching the internet, I downloaded GraphicsMagick and configure to
> 32 bit, following the link below (But I adjusted his methods and download
> what I want for Centos system.
> Then I follow the instruction on that webpage and re-download Octave and
> recompile it.
> However, the situation did not change, still all the images that I used
> 'imread' to load were converted to 8 bit. And I tried many times.
> So could any of you please give me some suggestions to solve this problem?

After building GraphicsMagick with quantum depth 32, you will need to
rebuild Octave with them.

Do you still get the warning about being limited to 8 bits per pixel?  If
so, you need to set your paths better as Octave configure script must still
be picking up your old install of GraphicsMagick.

If you are not getting the warning, then there must be something about
your file.  You will have to upload it somewhere if you want us to replicate
the issue.

Also, note that GraphicsMagick only handles images with integer files.  This
means that 32 bit integers will be read correctly, but if your image is
floating point, then GraphicsMagick will convert them to integers.  See


reply via email to

[Prev in Thread] Current Thread [Next in Thread]