[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Octave 3.8.1 on Linux; updating mex files for LIBSVM

From: Colin Beckingham
Subject: Octave 3.8.1 on Linux; updating mex files for LIBSVM
Date: Fri, 28 Mar 2014 07:51:52 -0400

I'm running Octave 3.8.1 installed from openSUSE (12.3) science
repository 64 bit version.

In Octave 3.8.0 I successfully compiled the package LIBSVM
( into Octave which produced the
required mex files in the ~/octave directory under my /home structure.

Since then my Octave has been updated to 3.8.1. Libsvm no longer works:

>> svmtrain
error: /home/colin/octave/svmtrain.mex: failed to load: cannot open shared object file: No such file or

I believe this is because is now version 2. I tried
adding a symlink from so.1 to so.2 but this was ineffective.

I tried a "pkg update" and this did a number of things but did not
change my access to libsvm.

Changing to directory Downloads where the libsvm package exists and
attempting to install again produces:

>> pkg install libsvm-3.17.tar.gz
bundles of packages are not allowed
error: called from 'install' in
file /usr/share/octave/3.8.1/m/pkg/private/install.m near line 90,
column 11
error: called from:
error:   /usr/share/octave/3.8.1/m/pkg/private/install.m at line 146,
column 5
error:   /usr/share/octave/3.8.1/m/pkg/pkg.m at line 394, column 9

Note: an earlier error message complained of a file COPYING missing from
the package, so I added an empty one. I also added an empty DESCRIPTION
file in case that would unblock, but no difference.

Suggestions would be appreciated. Thanks.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]