[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: crashing when try to plot

From: Alexander Hansen
Subject: Re: crashing when try to plot
Date: Thu, 20 Mar 2014 19:53:23 -0700
User-agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:24.0) Gecko/20100101 Thunderbird/24.4.0

On 3/20/14, 7:44 PM, Ben Abbott wrote:

On Mar 20, 2014, at 9:55 PM, Scott Junner <address@hidden> wrote:

On Fri, Mar 21, 2014 at 11:17 AM, Ben Abbott <address@hidden> wrote:

On Mar 20, 2014, at 7:29 PM, Doug Stewart <address@hidden> wrote:

On Thu, Mar 20, 2014 at 8:46 AM, Scott Junner <address@hidden> wrote:

I'm guessing the way to use an email list is simply to send an email to the 
address. If I got that wrong my appologies.

I've installed octave as per the instructions on this page

I had tried using the install instructions on the wiki but failed.

When using octave all is fine until I try to plot(x, y). The basics of the 
message I get can be seen in the following text when trying to run gnuplot as 

$ exec '/Applications/'

dyld: Library not loaded: /opt/X11/lib/libfreetype.6.dylib

   Referenced from: /usr/X11/lib/libfontconfig.1.dylib

   Reason: Incompatible library version: libfontconfig.1.dylib requires version 
17.0.0 or later, but libfreetype.6.dylib provides version 13.0.0

/Applications/ line 71: 12247 Trace/BPT trap: 5       GNUTERM="${GNUTERM}" GNUPLOT_HOME="${GNUPLOT_HOME}" PATH="${PATH}" 

[Process completed]


I guess my fundamental problem here is I don't know how to update the bit that 
needs updating.

Cheers for any help


To help us help you, tell us more.
What OS?
what version of octave?
where did you get octave from?

He's on Mac OSX using Homebrew.

Scott, you have a conflict between incompatible libraries.  It looks to me as 
if you have an X11 install in /opt/X11 and another in /usr/X11.  I have Xquartz 
installed in /usr/X11, but nothing in /opt/X11.

Where did your "/opt/X11/lib/libfreetype.6.dylib" come from?


Thanks guys.

After Ben's and Alexanders reply's here and on Google+ I think my problem 
begins several months ago. Not knowing what I'm doing to my file system and not 
choosing an appropriate package manager and then not using it half the time has 
created a big ol mess.

Doug to answer your questions. Mac 10.9.2, I downloaded octave-3.4.0-i386.dmg  
from the coursera website. It was made available in the Machine Learning course 
material. It seemed at first to solve my problem because it was that 
wonderfully simple trick of drag and drop into the applications folder and hey 
presto, working. But... not. Recall I had previously tried to install octave 
using instructions on wiki with Homebrew. All dependencies seemed to install 
fine but final command to install octave failed using that approach.

Ben, I cannot answer Where did your "/opt/X11/lib/libfreetype.6.dylib" come 
from? Unless above answers it. I installed Xquartz many moons ago.

Scott, you may be able to resolve the library conflict by removing the X11 
install under /opt.  My Xquartz is under /usr/X11, I assume your's is as well. 
From the terminal, try ...

        sudo mv /opt /foo

You'll need to enter your password.

Then try running octave and producing a plot.


Help-octave mailing list

Xquartz's X11 core is installed in /opt/X11 on 10.8 and later, with symlinks in /usr/X11 and /usr/X11R6.

Alexander Hansen, Ph.D.
Fink User Liaison
My package updates:

reply via email to

[Prev in Thread] Current Thread [Next in Thread]