[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: parcellfun test issue on Mac OS 10.8, was Re: problems installing op

From: Alexander Hansen
Subject: Re: parcellfun test issue on Mac OS 10.8, was Re: problems installing openmpi_ext
Date: Tue, 26 Nov 2013 09:03:30 -0800
User-agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:24.0) Gecko/20100101 Thunderbird/24.1.1

On 9/22/13 2:33 PM, Alexander Hansen wrote:
On 9/11/13 9:54 AM, Alexander Hansen wrote:
On 9/11/13 9:28 AM, c. wrote:

On 11 Sep 2013, at 17:06, Ben Abbott <address@hidden> wrote:

Ok.  That is easily fixed. First from a bash shell ...

    sudo port uninstall octave-bim

Then from macports octave-devel

pkg install -forge bim
pkg load bim
Elapsed time is 11.1524 seconds.
parcellfun: child process 35648 created
parcellfun: child process 35649 created
parcellfun: 200/200 jobs done
parcellfun: waiting for child process 35648 to close
parcellfun: waiting for child process 35649 to close
Elapsed time is 5.37539 seconds.



Thanks for helping with this!

Although Francis might be happy
now with a working Octave installed
from MacPorts, it would be great if
we could also help Alexander fix the
problems with the Octave package in Fink.


I'd like that, too. :-)

I've got an unresolved bug report on Savannah (#38280) which appears
also to be related to file I/O.

I've just tried a build where the various *FLAGS variables are set to
what Carlo used, but that didn't change the results.  There didn't seem
to be substantial differences between his configure setup and Fink's
otherwise.  This was still using clang[++] as the C[++] compiler.

I'm trying a build using (FSF) g++-4.8 now.

Hi.  I've been a bit busy, but I'm still plugging away at this.  No
success as of yet.

I've got the following configure options right now:

     config_opts = '--prefix=/sw' '--with-lapack=-L/sw/lib/lapack/3.4.2
-lreflapack' '--with-blas=-L/sw/lib/lapack/3.4.2 -lrefblas'
'--with-framework-carbon' '--with-x' '--x-libraries=/usr/X11/lib'
'--x-includes=/usr/X11/include' '--with-magick=GraphicsMagick'
'--host=x86_64-apple-darwin' '--build=x86_64-apple-darwin'
'--infodir=/sw/share/info' '--mandir=/sw/share/man'
'--libexecdir=/sw/lib' '--enable-shared' '--enable-dl'
'--disable-static' '--disable-docs' '--enable-dependency-tracking'
'build_alias=x86_64-apple-darwin' 'host_alias=x86_64-apple-darwin'
'CC=flag-sort -r gcc' 'CFLAGS=-D_THREAD_SAFE -pipe -O2 -MD -g'
'LDFLAGS=-Wl,-dead_strip_dylibs -L/sw/lib' 'CPPFLAGS=-D_THREAD_SAFE
-I/sw/include' 'CXX=flag-sort -r g++' 'CXXFLAGS=-pipe -O2 -MD -g
-I/usr/X11/include' 'F77=/sw/bin/gfortran-fsf-4.8' 'FFLAGS=-pipe -O2'

and I've been trying to back out the various patches that I've applied.
  If anybody's bored, those are visible via

in the files and the various octave*.patch files.

A little update:

I tried building Octave-3.6.4 manually with the default tuning, using Fink dependencies and the minimum patching that let the build proceed. Even with that, I'm still seeing errors with fload from the general package, as per

I saw some reports that Homebrew and Macports folks are now seeing the same thing with parcellfun (general):

Alexander Hansen, Ph.D.
Fink User Liaison
My package updates:

reply via email to

[Prev in Thread] Current Thread [Next in Thread]